DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 26th November 2009
birdmansdomain birdmansdomain is offline
Port Guard
 
Join Date: Jun 2009
Posts: 13
Thanked 0 Times in 0 Posts
Default static ip's not showing up in routing table

so i'm running openbsd 4.6 with pf,snort as a gateway. all my interfaces are set up for static ip, everything works fine. Though when i look at routing table the ip's dont appear. Confused to why this is.
Reply With Quote
  #2   (View Single Post)  
Old 26th November 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,251
Thanked 182 Times in 149 Posts
Default

Please show us the output of ifconfig -A and netstat -rn -f inet.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #3   (View Single Post)  
Old 26th November 2009
birdmansdomain birdmansdomain is offline
Port Guard
 
Join Date: Jun 2009
Posts: 13
Thanked 0 Times in 0 Posts
Default

Code:
# ifconfig -A
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 33200
        priority: 0
        groups: lo
        inet 127.0.0.1 netmask 0xff000000
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
ral0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:1d:6a:3a:48:66
        priority: 4
        groups: wlan
        media: IEEE802.11 autoselect mode 11g hostap
        status: active
        ieee80211: nwid Inland_Empire chan 10 bssid 00:1d:6a:3a:48:66
        inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
        inet6 fe80::21d:6aff:fe3a:4866%ral0 prefixlen 64 scopeid 0x1
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:18:e7:18:3d:34
        priority: 0
        media: Ethernet autoselect (100baseTX full-duplex,rxpause,txpause)
        status: active
        inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255
        inet6 fe80::218:e7ff:fe18:3d34%re0 prefixlen 64 scopeid 0x2
em0: flags=8b43<UP,BROADCAST,RUNNING,PROMISC,ALLMULTI,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:0d:60:47:d3:9c
        priority: 0
        groups: egress
        media: Ethernet autoselect (100baseTX full-duplex,rxpause,txpause)
        status: active
        inet6 fe80::20d:60ff:fe47:d39c%em0 prefixlen 64 scopeid 0x3
        inet 70.64.72.16 netmask 0xfffffc00 broadcast 255.255.255.255
enc0: flags=0<> mtu 1536
        priority: 0
pflog0: flags=141<UP,RUNNING,PROMISC> mtu 33200
        priority: 0
        groups: pflog
Code:
# netstat -rn -f inet
Routing tables

Internet:
Destination        Gateway            Flags   Refs      Use   Mtu  Prio Iface
default            70.64.72.1         UGS        0      173     -     8 em0
70.64.72/22        link#3             UC         1        0     -     4 em0
70.64.72.1         00:30:b8:c5:05:40  UHLc       1        0     -     4 em0
70.64.72.16        127.0.0.1          UGHS       0        0 33200     8 lo0
127/8              127.0.0.1          UGRS       0        0 33200     8 lo0
127.0.0.1          127.0.0.1          UH         2        0 33200     4 lo0
192.168.0/24       link#2             UC         1        0     -     4 re0
192.168.0.10       00:24:8c:b9:1d:e4  UHLc       1      269     -     4 re0
192.168.1/24       link#1             UC         0        0     -     4 ral0
224/4              127.0.0.1          URS        0        0 33200     8 lo0
I have 2 laptops connecting to ral0 i'm also not using dhcpd
Reply With Quote
  #4   (View Single Post)  
Old 26th November 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,251
Thanked 182 Times in 149 Posts
Default

I see several IP's but indeed they don't seem to match the ifconfig ones exactly
Code:
# netstat -rn -f inet
Routing tables

Internet:
Destination        Gateway            Flags   Refs      Use   Mtu  Prio Iface
default            70.64.72.1         UGS        0      173     -     8 em0
70.64.72/22        link#3             UC         1        0     -     4 em0
70.64.72.1         00:30:b8:c5:05:40  UHLc       1        0     -     4 em0
70.64.72.16        127.0.0.1          UGHS       0        0 33200     8 lo0
127/8              127.0.0.1          UGRS       0        0 33200     8 lo0
127.0.0.1          127.0.0.1          UH         2        0 33200     4 lo0
192.168.0/24       link#2             UC         1        0     -     4 re0
192.168.0.10       00:24:8c:b9:1d:e4  UHLc       1      269     -     4 re0
192.168.1/24       link#1             UC         0        0     -     4 ral0
224/4              127.0.0.1          URS        0        0 33200     8 lo0
I never ran snort, so I wonder what that is doing besides putting interfaces into promiscuous mode.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #5   (View Single Post)  
Old 27th November 2009
birdmansdomain birdmansdomain is offline
Port Guard
 
Join Date: Jun 2009
Posts: 13
Thanked 0 Times in 0 Posts
Default

snort just listens in on my external interface and modifies pf
yeh the 192.168.0.10 is my wired interface connected to my gw/firewall
but what its not showing is 192.168.1.15 and 192.168.1.12 which are 2 of my netbooks that are fully connected to the network and am able to do everything i usually do
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
snd_emu10k1 and static kly FreeBSD General 3 17th September 2009 01:28 PM
I think I just mangled my partition table Mantazz FreeBSD Installation and Upgrading 2 2nd July 2009 09:55 PM
Static IP address problem rex FreeBSD General 2 25th November 2008 08:53 PM
Cannot assign static IP. bsdnewbie999 OpenBSD General 5 21st June 2008 09:50 AM
dhcpd problems... dynamic and static leases present edhunter FreeBSD General 7 16th May 2008 02:34 PM


All times are GMT. The time now is 09:00 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick