DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 14th December 2009
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default [Solved]Warning domain_not_set.invalid

$ hostname
Quote:
athlon64.domain_not_set.invalid
$ cat /etc/hosts
Quote:
# $OpenBSD: hosts,v 1.12 2009/03/10 00:42:13 deraadt Exp $
#
# Host Database
#
# RFC 1918 specifies that these networks are "internal".
# 10.0.0.0 10.255.255.255
# 172.16.0.0 172.31.255.255
# 192.168.0.0 192.168.255.255
#
127.0.0.1 localhost
::1 localhost
xxxxxxx athlon64.domain_not_set.invalid athlon64
$ cat /etc/resolv.conf
Quote:
search domain_not_set.invalid
nameserver ........
nameserver ........
nameserver ....
nameserver 192.168.1.1
lookup file bind
How i can fix this warning?

Last edited by aleunix; 15th December 2009 at 11:19 AM. Reason: Problem solved
Reply With Quote
  #2   (View Single Post)  
Old 14th December 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,158
Thanked 182 Times in 149 Posts
Default

You probably won't believe me but athlon64.domain_not_set.invalid is a valid name for your computer.
This name consists of 3 parts:
  1. athlon64 : the local host name
  2. domain_not_set : the domain name
  3. invalid : the Top Level Domain (TLD) name

If you configure a zone file for "domain_not_set.invalid" for your private nameserver 192.168.1.1 it will even resolve.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #3   (View Single Post)  
Old 14th December 2009
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

How can configure a zone file for "domain_not_set.invalid"?

When i start openbsd i obtain an error that said a character used on the string isn't valid.
If that message is visible on dmesg i would tried to send it.
Reply With Quote
  #4   (View Single Post)  
Old 14th December 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,158
Thanked 182 Times in 149 Posts
Default

If your Athlon box has a private RFC 1928 address like 192.168.x.x or 10.x.x.x.x then you can configure a private domain/zone for it. But you don't have to.
You also can edit /etc/myname and /etc/hosts to change to a not so confusing names.

If your box has a public IP then you should use the official name that goes with that IP address.

See http://en.wikipedia.org/wiki/Hostnam...lid_host_names for the character set restrictions for host names.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #5   (View Single Post)  
Old 14th December 2009
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

Thanks.
Reply With Quote
  #6   (View Single Post)  
Old 14th December 2009
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

You should typically avoid _'s entirely, some resolvers support them.. others do not, and traditionally they're not acceptable in Unix hostnames either.

It's like the '-' character, some combinations are invalid as per the specifications.. like -joe-.userdom.com is not valid on standards complaint systems, but it is on Windows/Linux and OS X.
Reply With Quote
  #7   (View Single Post)  
Old 14th December 2009
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

Now i have change:
/etc/myname
and
/etc/hosts
for use this domain:
athlon64.localdomain.it

But if i doing the command:
hostname
athlon64.domain_not_set.invalid
and also i haven't change /etc/resolv.conf
because if i change hostname and /etc/resolv.conf
i obtain this error when i tried to use program:
$ xfe
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
while if i change only myname and hosts the problem isn't present.

Now how i can sure then when i restart the system all go well?
I have missed some files?
Reply With Quote
  #8   (View Single Post)  
Old 14th December 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,158
Thanked 182 Times in 149 Posts
Default

You should not use it as top level domain, which is an official TLD on the internet.
Some programs will try to lookup athlon64.localdomain.it in the official DNS. Of course this lookup will fail.
Code:
$ host athlon64.localdomain.it
Host athlon64.localdomain.it not found: 3(NXDOMAIN)
Instead use a TLD that doesn't exist e.g. xit

It could be that some configuration files still have your old domain_not_set.invalid domain name in it.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #9   (View Single Post)  
Old 14th December 2009
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

Same problem even using xit.
In summary i can change even
/etc/resolv.conf
but in the instant that i change hostname
sudo hostname athlon64.localdomain.xit

i obtain the error.

I have changed these files:
/etc/myname
/etc/hosts
/etc/resolv.conf
Reply With Quote
Old 14th December 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,158
Thanked 182 Times in 149 Posts
Default

My guess is that the old name is still somewhere in the X "." dot files in your home directory e.g.
Code:
$ hexdump -C .serverauth.19562                                 
00000000  01 00 00 11 68 65 72 63  75 6c 65 73 2e 75 74 70  |....hercules.utp|
00000010  2e 78 6e 65 74 00 01 30  00 12 4d 49 54 2d 4d 41  |.xnet..0..MIT-MA|
00000020  47 49 43 2d 43 4f 4f 4b  49 45 2d 31 00 10 08 76  |GIC-COOKIE-1...v|
00000030  5a d4 c5 52 40 77 b3 52  92 7b 41 b3 1a bc 01 00  |ZÔÅR@w³R.{A³.¼..|
00000040  00 11 68 65 72 63 75 6c  65 73 2e 75 74 70 2e 78  |..hercules.utp.x|
00000050  6e 65 74 00 01 31 00 12  4d 49 54 2d 4d 41 47 49  |net..1..MIT-MAGI|
00000060  43 2d 43 4f 4f 4b 49 45  2d 31 00 10 92 78 02 3b  |C-COOKIE-1...x.;|
00000070  9b 29 97 16 1a 42 5f 6c  de 3e 8f 0a              |.)...B_lÞ>..|
Here you see my hostname hercules.utp.xnet.

Have you tried to reboot your system? That way the hostname will be set from the /etc/myname file.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
Old 14th December 2009
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

No i haven't reboot the system.

$ hexdump -C .serverauth.6112
00000000 01 00 00 1f 61 74 68 6c 6f 6e 36 34 2e 64 6f 6d |....athlon64.dom|
00000010 61 69 6e 5f 6e 6f 74 5f 73 65 74 2e 69 6e 76 61 |ain_not_set.inva|
00000020 6c 69 64 00 01 30 00 12 4d 49 54 2d 4d 41 47 49 |lid..0..MIT-MAGI|
00000030 43 2d 43 4f 4f 4b 49 45 2d 31 00 10 cb 50 60 de |C-COOKIE-1..ËP`Þ|
00000040 47 10 58 e1 89 53 8d 28 cc e6 35 39 |G.Xá.S.(Ìæ59|
0000004c

But in summary use said that i can reboot after the change the i have doing on:
/etc/myname
/etc/hosts
/etc/resolv.conf
without problems?

Note:
Thanks!
after doing:
sudo hostname athlon64.localdomain.itx
and reboot the problem seem resolved!

I would like known if there is a way on openbsd to avoid to restart the OS an restart only specific service?

Last edited by aleunix; 14th December 2009 at 09:25 PM.
Reply With Quote
Old 14th December 2009
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,158
Thanked 182 Times in 149 Posts
Default

In your case you only would have had to quit X Window.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
Old 15th December 2009
There0 There0 is offline
./dev/null
 
Join Date: Jul 2008
Posts: 169
Thanked 10 Times in 10 Posts
Default

I sometimes use "shutdown now" to drop to single user mode then "exit" back up to try and reload/test some settings, i have noticed that PF still runs fine when doing this, am not sure about how many other "services" are running.

I use this on my main firewall as i also up the securelevel to 2 and cannot edit anything or reload much until i drop to single user mode which also drops my securelevel to 1.
__________________
The more you learn, the more you realize how little you know ....
Reply With Quote
Old 15th December 2009
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

Nice idea.
Eventually i open a new topic about this question.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mount-msdosfs /dev/dao: : Invalid argument harold FreeBSD General 5 12th December 2010 06:59 AM
cvs warning message inquiry revzalot OpenBSD Installation and Upgrading 1 4th September 2009 12:12 PM
tcpdump snaplen WARNING bsdnewbie999 OpenBSD General 1 17th March 2009 03:24 AM
Mount DVD - invalid argument. maxrussell FreeBSD General 17 7th January 2009 08:46 AM
Warning error every exit of X aleunix OpenBSD Packages and Ports 2 6th June 2008 08:46 PM


All times are GMT. The time now is 03:58 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick