DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 20th May 2008
starbuck's Avatar
starbuck starbuck is offline
Port Guard
 
Join Date: Apr 2008
Location: Eugene, OR
Posts: 31
Thanked 0 Times in 0 Posts
Default +arplookup ###.###.##.### failed: host is not on local network

Hey All, I've got a FreeBSD 7 box set up at work and I'm seeing the following message in my periodic daily security output:

Code:
*myhostname* kernel log messages:
+arplookup ###.###.55.183 failed: host is not on local network
+arplookup ###.###.55.183 failed: host is not on local network
+arplookup ###.###.55.183 failed: host is not on local network
Where ###.###.55.183 is a local IP address. I did some digging and found out that this is probably due to a netmask configuration problem, but I'm not sure how to resolve it properly.

This server is new and doesn't really do anything right now, it basically just has SSH running. It's on a local University network that uses multiple subnets. So the server has an IP like ###.###.54.106 while the IP address I'm seeing in the security output is ###.###.55.183. These IP addresses are statically assigned, we've actually got servers on the .55 and .54 subnets.

Any ideas on how to fix this?

Here is my netstat -r output:

Code:
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default            vl-54-gw           UGS         0    30446    em0
localhost          localhost          UH          0      468    lo0
###.###.54.0       link#1             UC          0        0    em0
vl-54-gw           00:00:5e:00:01:01  UHLW        2        0    em0    106
vl-54.uonet1-gw.uo 00:d0:01:95:e0:00  UHLW        1        0    em0   1199
vl-54.uonet2-gw.uo 00:d0:01:95:dc:00  UHLW        1        0    em0   1196
...and ifconfig

Code:
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
        ether 00:15:17:50:a6:3a
        inet6 ...snip... 
        inet ###.###.54.106 netmask 0xffffff00 broadcast ###.###.54.255
        inet6 ...snip... 
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
em1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
        ether 00:15:17:50:a6:3b
        media: Ethernet autoselect
        status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet6 ::1 prefixlen 128 
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
        inet 127.0.0.1 netmask 0xff000000
Thanks!
Reply With Quote
  #2   (View Single Post)  
Old 20th May 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Your interface is configured with a netmask of 255.255.255.0 or /24. This means that the first 24 bits (or three octets) form the network. In your case: xxx.xxx.54.0 is the network.

This means you can only see IPs from xxx.xxx.54.0 through xxx.xxx.54.255.

If you need to see IPs on the xxx.xxx.55.0 network as well, then you need to make your netmask smaller. You'll need to contact your network admin to find out what the correct subnet mask is.

(As a quick-n-dirty hack, you can make your subnet mask 255.255.0.0 or /16 and you'll see all the IPs from xxx.xxx.0.0 through xxx.xxx.255.255. But that's a bad hack, and you really should use the correct subnet mask.)
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
  #3   (View Single Post)  
Old 20th May 2008
starbuck's Avatar
starbuck starbuck is offline
Port Guard
 
Join Date: Apr 2008
Location: Eugene, OR
Posts: 31
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by phoenix View Post
Your interface is configured with a netmask of 255.255.255.0 or /24. This means that the first 24 bits (or three octets) form the network. In your case: xxx.xxx.54.0 is the network.

This means you can only see IPs from xxx.xxx.54.0 through xxx.xxx.54.255.

If you need to see IPs on the xxx.xxx.55.0 network as well, then you need to make your netmask smaller. You'll need to contact your network admin to find out what the correct subnet mask is.

(As a quick-n-dirty hack, you can make your subnet mask 255.255.0.0 or /16 and you'll see all the IPs from xxx.xxx.0.0 through xxx.xxx.255.255. But that's a bad hack, and you really should use the correct subnet mask.)
Ok, so apparently our Network Services department assigns static IP address through DHCP. So the fix was to run dhclient on my network interface and it was automagically given the correct IP address and netmask:

Code:
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
        ether 00:15:17:50:a6:3a
        inet6 ...snip... 
        inet6 ...snip... 
        inet ###.###.54.106 netmask 0xfffffe00 broadcast ###.###.55.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
em1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
        ether 00:15:17:50:a6:3b
        media: Ethernet autoselect
        status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet6 ::1 prefixlen 128 
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
        inet 127.0.0.1 netmask 0xff000000
Thanks for the in-depth response phoenix, I talked to a coworker of mine who is more familiar with our network and apparently I need to read up on networking. I was mistaken when I said that "we've actually got servers on the .55 and .54 subnets." Apparently the subnet spans from ###.223.54.0 to ###.223.55.255. So yeah, I've got some more reading to do. Thanks again!
Reply With Quote
  #4   (View Single Post)  
Old 20th May 2008
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

Strange, but it works.

You are using a /23 subnet mask, or 255.255.254.0 . (binary 111111111.11111111.11111110.0000000 - when you look at how subnets work, you'll see how the binary is important.) In todays world of sharply limited internet addresses, tricks like this to make best use of a limited assignment of addresses are becoming more common.
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh/rdesktop into host behind NAT JMJ_coder General software and network 18 13th January 2009 08:19 PM
Local transfer is slow. maurobottone OpenBSD General 1 10th January 2009 02:12 PM
local dns (dnsmasq) bsdperson FreeBSD Ports and Packages 3 3rd September 2008 06:48 AM
proxy : replace gif with local gif milo974 OpenBSD General 4 17th July 2008 06:45 AM
/usr/local and application directories ducu_00 FreeBSD Ports and Packages 14 23rd May 2008 05:37 PM


All times are GMT. The time now is 09:31 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick