DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 10th April 2010
matiasar matiasar is offline
Real Name: Matías
New User
 
Join Date: Apr 2010
Location: Buenos Aires, Argentina
Posts: 3
Thanked 0 Times in 0 Posts
Default Tryin' to use ZTE 3G Dongle in FreeBSD8

Hello all.
I've been trying to get working the 3G dongle ZTE626 for internet access in FreeBSD 8, up to now, without success. I'm quite new to BSDs.

I did the following.

1.1) Tested in linux (Debian Squeezy) using usb_modeswitch to switch the device to modem function. Tested the result with lsusb Switched to Modem ... [OK]

1.2) Tested the device with minicom to send some AT command ... [OK]

1.3) Connected to Internt with wvdial ... Internet communications ... [OK]

In linux after switching to modem function the device is attached to a node /dev/ttyUSB2. Thats the comm. port I used in wvdial and minicom.

2) FreeBSD8

2.1) I compiled usb_modeswitch. And switched to modem function. Seemed to have switched to modem ... [OK]

Code:
# usbconfig dump_device_desc

ugen2.2: <ZTE Configuration ZTE,Incorporated> at usbus2, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

  bLength = 0x0012
  bDescriptorType = 0x0001
  bcdUSB = 0x0200
  bDeviceClass = 0x0000
  bDeviceSubClass = 0x0000
  bDeviceProtocol = 0x0000
  bMaxPacketSize0 = 0x0040
  idVendor = 0x19d2
  idProduct = 0x0031
  bcdDevice = 0x0000
}  iManufacturer = 0x0002  <ZTE,Incorporated>
  iProduct = 0x0001  <ZTE Configuration>
  iSerialNumber = 0x0003  <P671A2PERD010000>
  bNumConfigurations = 0x0001
I mean seemed to work because idVendor and idProduct are the same as linux's lsusb in modem function.

2.2) What node the device is attached? ... [FAILED]

I think the problem is here... I don't know if the device is beeing recognized. I use u3g driver, I put it in loader.conf

I tried minicom in /dev/ttycuau0 without response from modem. I think that node is not linked to this dongle.

An interesting message I get in /var/log/message is the following:

Code:
root: Unknown USB device: vendor 0x19d2 product 0x0031 bus uhub2
Those are really idVendor and idProduct of this device.

Am I missing some step?
Does anybody knows if is there any other approach I could try?
Is there anything else I could try before giving up?

Thanks in advance,
Matías
Reply With Quote
  #2   (View Single Post)  
Old 10th April 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

As you can see from the output of "usbconfig", it is attaching as a ugen(4) device.. i.e: a generic catch-all device used for unrecognized/unsupported components.

So for now, this device may not be supported by FreeBSD.. it may however be supported by OpenBSD or NetBSD, or perhaps by loading a different kernel module (..someone else may be able to clarify, if one exists for your device).
Reply With Quote
  #3   (View Single Post)  
Old 12th April 2010
matiasar matiasar is offline
Real Name: Matías
New User
 
Join Date: Apr 2010
Location: Buenos Aires, Argentina
Posts: 3
Thanked 0 Times in 0 Posts
Default

Yes, I'm tend to think there's no support yet for this device...

Thanks!
Reply With Quote
  #4   (View Single Post)  
Old 12th April 2010
matiasar matiasar is offline
Real Name: Matías
New User
 
Join Date: Apr 2010
Location: Buenos Aires, Argentina
Posts: 3
Thanked 0 Times in 0 Posts
Default

By u3g man page I noticed that apparently that driver doesn't support ZTE devices.

Are there other drivers for 3G devices?

Regards
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
usb modem toshiba g450+freebsd8.0 xnl96 FreeBSD General 4 3rd October 2009 12:04 PM
Asus Bluetooth dongle WL-BTD201M mfaridi OpenBSD General 10 7th December 2008 05:41 AM


All times are GMT. The time now is 12:21 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick