DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 1st May 2008
syrushcw syrushcw is offline
Port Guard
 
Join Date: May 2008
Posts: 17
Thanked 0 Times in 0 Posts
Default Moused

See thread here
I narrowed the problem down to X I added this to my rc.conf
moused_enable="YES"
moused_port="/dev/ums0"
and my mouse works in ttyv but not in X, and I do not see where it is configured wrong in X. Tell me what ever info you need and Ill post it.

Last edited by Carpetsmoker; 2nd May 2008 at 05:28 AM. Reason: All solved
Reply With Quote
  #2   (View Single Post)  
Old 1st May 2008
syrushcw syrushcw is offline
Port Guard
 
Join Date: May 2008
Posts: 17
Thanked 0 Times in 0 Posts
Default

Woot got it to work Xorg -configure and it detected it. How do you put resolved in the subject on this forum?
Reply With Quote
  #3   (View Single Post)  
Old 1st May 2008
18Googol2's Avatar
18Googol2 18Googol2 is offline
Real Name: whoami
Spam Deminer
 
Join Date: Apr 2008
Location: pwd
Posts: 283
Thanked 20 Times in 18 Posts
Default

- Have you tried the following utility?

Code:
#xorgconfig
- You might wanna try the sysmouse device in the xorg.conf file:

Code:
Section "InputDevice"

    Identifier  "Mouse1"
    Driver  "mouse"
    Option "Protocol"    "auto" # PS/2 Mouse
    Option "Device"      "/dev/sysmouse"

    Option "ZAxisMapping"   "4 5 6 7"

EndSection
- If it still doesnt work, post the relevant mouse config section in the xorg.conf file
Reply With Quote
  #4   (View Single Post)  
Old 1st May 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Quote:
Originally Posted by syrushcw View Post
See thread here
I narrowed the problem down to X I added this to my rc.conf
moused_enable="YES"
moused_port="/dev/ums0"
and my mouse works in ttyv but not in X, and I do not see where it is configured wrong in X. Tell me what ever info you need and Ill post it.
There's are two ways to access the mouse in X on FreeBSD:
  1. directly, using the mouse device itself (/dev/ums0) in the X config file
  2. indirectly, using the moused device (/dev/sysmouse) in the X config file

Which you use depends on whether or not you want mouse support at the console before X loads.

If you want mouse support at the console, then you need to enable moused in /etc/rc.conf, and use /dev/sysmouse in your X config file.

If you just want mouse support in X, then disable moused in /etc/rc.conf, and use the mouse device (/dev/ums0) in your X config file.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
Reply

Tags
mouse, x11, xorg

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:42 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick