DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 7th June 2010
rtwingfield rtwingfield is offline
Real Name: Ron Wingfield
Port Guard
 
Join Date: Oct 2008
Location: Little Rock, AR USA
Posts: 29
Thanked 0 Times in 0 Posts
Default Apache v2.0 vs. v2.2+ with SSL

I have a working installation of Apache v2.0 with SSL. I am attempting to configure v2.2.11 (also v2.2.4 with the same results). I have created fresh certificates, keys, etc. and the v2.2.11 server prompts for the pass phrase as with v2.0 and starts as expected. Unsecure pages are served nicely via port 80; however, the SSL port 443 complains that the whatever/something.html cannot be found, even though the error message (404) is served via port 443. I have removed all REQUIRE SSL etc. options from the associated .htaccess file, and if I remove the s from the https construct in the URL address as submitted by the browser, then the pages will be served . . .via port 80.

I've basically taken the configuration from the v2.0 ssl.conf file and incorporated into the ./extra/httpd-ssl.conf of v2.2.11. I've discovered a few nuances such as the <VirtualHost _default_:443> construct in v2.0 had to be changed to <VirtualHost 192.168.1.73:443> which is the IP address within the LAN, i.e., inside a NetGear FVX538 VPN Router.

QUESTION: Has anyone dealt with this or a similar problem? . . .got to be something simple, perhaps a default document path in the httpd-ssl.conf file. BTW, I haven't ruled out a firewall problem withing the NetGear router.

Last edited by rtwingfield; 7th June 2010 at 11:48 PM. Reason: spelling and garammar
Reply With Quote
  #2   (View Single Post)  
Old 15th June 2010
3th3r 3th3r is offline
New User
 
Join Date: May 2010
Location: Los Angeles
Posts: 6
Thanked 0 Times in 0 Posts
Default

it would be helpful if you post your httpd.conf and your httpd-ssl.conf files
Reply With Quote
  #3   (View Single Post)  
Old 17th June 2010
rtwingfield rtwingfield is offline
Real Name: Ron Wingfield
Port Guard
 
Join Date: Oct 2008
Location: Little Rock, AR USA
Posts: 29
Thanked 0 Times in 0 Posts
Default

First, thanks for your invitation to submit my httpd configuration. I didn't want to "bother" everyone with the details, but I'm still without a solution. I have combined the httpd.conf, ./extra/httpd-ssl.conf, and ./extra/httpd-vhosts.conf files into one uploaded file, httpd.conf.temp.txt. (the text is noted with breaks, e.g., #==== . . .etc. between the individual conf files. I've also omitted all containers except for two virtual host definitions.)

If you or someone can help me see the error of my ways . . .much appreciated

Again, thanks,
Ron W.
Attached Files
File Type: txt httpd.conf.temp.txt (27.9 KB, 17 views)
File Type: pdf VISIO-httpd22.pdf (5.6 KB, 12 views)
Reply With Quote
  #4   (View Single Post)  
Old 20th June 2010
ohauer ohauer is offline
Port Guard
 
Join Date: May 2008
Location: germany
Posts: 32
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by rtwingfield View Post

I've basically taken the configuration from the v2.0 ssl.conf file and incorporated into the ./extra/httpd-ssl.conf of v2.2.11. I've discovered a few nuances such as the <VirtualHost _default_:443> construct in v2.0 had to be changed to <VirtualHost 192.168.1.73:443> which is the IP address within the LAN, i.e., inside a NetGear FVX538 VPN Router.
From http://devil/doc/apache22/mod/mpm_common.html#listen
Quote:
The Listen directive instructs Apache to listen to only specific IP addresses or ports; by default it responds to requests on all IP interfaces. Listen is now a required directive. If it is not in the config file, the server will fail to start. This is a change from previous versions of Apache.
...
From http://httpd.apache.org/docs/2.2/mod...amevirtualhost
Quote:
Note

Note, that the "main server" and any _default_ servers will never be served for a request to a NameVirtualHost IP address (unless for some reason you specify NameVirtualHost but then don't define any VirtualHosts for that address).
And in your config snippet you have more than one VirtualHosts listen on :443 without defining a different IP.
If you look a little deeper you also see the httpd-vhosts.conf is included before httpd-ssl.conf and has two wildcard ssl vhosts.

Write for your ssl enabled vhosts a dedicated file and include them after the generic httpd-ssl.conf and make sure every SSL vhost has a dedicated IP.

Code:
<VirtualHost *:443>
    DocumentRoot /www/vhosts/Archaxis.net
    ServerName Archaxis.net
    ServerAlias www.Archaxis.net
</VirtualHost>

<VirtualHost *:443>
# Added MAR 2010
    DocumentRoot /www/vhosts/AR042SWRCAP.org
    ServerName AR042SWRCAP.org
    ServerAlias www.AR042SWRCAP.org
</VirtualHost>

<VirtualHost 192.168.1.73:443> # . . .the VPN router address
#   General setup for the virtual host
  ServerName archaxis.net:443
...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache mehaj OpenBSD General 10 4th March 2010 04:16 PM
PHP 5.2.6 and Apache 1.3 dialeight OpenBSD Packages and Ports 1 15th June 2009 03:04 AM
Upgrade Apache 1.3 mod_ssl to Apache 2.2 beandip FreeBSD Ports and Packages 11 26th March 2009 09:12 PM
Apache & PHP themaster FreeBSD General 2 14th June 2008 05:49 PM
Apache SSL mike171562 FreeBSD General 0 5th May 2008 09:41 PM


All times are GMT. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick