DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th June 2010
bsdplus bsdplus is offline
Real Name: Alan Cheng
Port Guard
 
Join Date: Jun 2009
Location: Shanghai, China
Posts: 20
Thanked 0 Times in 0 Posts
Default RAID1 rebuild for softraid

I'm testing softraid on ob 4.7.

The process went fine during set up of the RAID1 using 2 SCSI disks, plus 1 hot spare.

when I intentionally dropped one disk in RAID1, the hot spare was automatically placed into RAID1, rebuild fired up automatically too.

The issue is: rebuild always hung at somepoint. if I reboot the system, it hungs also, after the message "syncing disks ... done" on console (as in attached screenshot). I have to manually power it off and power it back on. after that, everything seems to be fine. RAID rebuild can complete fine.

$ sudo bioctl softraid0
Volume Status Size Device
softraid0 0 Rebuild 1073684480 sd2 RAID1 70% done
0 Online 1073684480 0:0.0 noencl <sd0a>
1 Rebuild 1073684480 0:1.0 noencl <sd1a>

$ sudo bioctl softraid0
Volume Status Size Device
softraid0 0 Rebuild 1073684480 sd2 RAID1 70% done
0 Online 1073684480 0:0.0 noencl <sd0a>
1 Rebuild 1073684480 0:1.0 noencl <sd1a>
Attached Images
File Type: jpg 未命名.JPG (45.7 KB, 38 views)
Reply With Quote
  #2   (View Single Post)  
Old 19th June 2010
bsdplus bsdplus is offline
Real Name: Alan Cheng
Port Guard
 
Join Date: Jun 2009
Location: Shanghai, China
Posts: 20
Thanked 0 Times in 0 Posts
Default

after reboot, RAID1 rebuild completed fine. this test is done in VMware workstation 7.0 . FYI.

$ sudo bioctl softraid0
Volume Status Size Device
softraid0 0 Rebuild 1073684480 sd2 RAID1 97% done
0 Online 1073684480 0:0.0 noencl <sd0a>
1 Rebuild 1073684480 0:1.0 noencl <sd1a>
$ sudo bioctl softraid0
Volume Status Size Device
softraid0 0 Online 1073684480 sd2 RAID1
0 Online 1073684480 0:0.0 noencl <sd0a>
1 Online 1073684480 0:1.0 noencl <sd1a>
$

Last edited by bsdplus; 19th June 2010 at 03:19 PM. Reason: add additional info
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD heads up - softraid metadata change J65nko News 0 26th March 2010 10:27 PM
RAID Boot volume on OpenBSD 4.6 using softraid csc OpenBSD General 2 26th February 2010 03:51 PM
softraid encryption Sunnz OpenBSD Security 6 24th September 2009 04:58 AM
SOFTRAID(4) revzalot OpenBSD Installation and Upgrading 3 27th July 2008 08:40 PM
UPDATING says rebuild all gettext !! HowSoEver; READ yes REPLY maybe just wait jb_daefo FreeBSD Ports and Packages 4 8th June 2008 06:13 AM


All times are GMT. The time now is 10:57 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick