DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 6th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default Multimedia Card Reader

What man page should I read in order to configure my TI Multimedia card reader as it is not configured.

divadgnol67
Reply With Quote
  #2   (View Single Post)  
Old 6th September 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

If the kernel log mentions that a device is not configured, it isn't usually an indication of user error.

All supported drivers are part of the GENERIC kernel image, there are no externally loaded drivers, so there isn't any configuration required on your part.

The message typically means the device is unsupported, none of the available drivers are able to attach to it.. the exact reasons for this are dependent on the device.

Unfortunately a lot of those internal card readers are unsupported, except for some lucky users with sdhc(4) SD card readers.. or internal multicard readers attached to the USB bus.

I can't be completely sure without a dmesg, but this is most likely to be the case.

OpenBSD's device support has improved quite a bit over the years, but, they need access to machines to write drivers.. and if nobody is particularly interested in writing a driver, it won't be done. There is also the issue of available documentation, TI is a common manufacture of these multicard readers.. but surely not the only one, which would make the job much more complicated.

Try finding an external USB device if the data on the card is important, or use a different computer/OS temporarily.

Good luck,
Reply With Quote
  #3   (View Single Post)  
Old 6th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default

@BSDfan666,

Thanks. You have helped me in many ways by helping others on this forum. Often times I just need to search the forums and I find my answer but was unable to find anything this time.

divadgnol67
Reply With Quote
  #4   (View Single Post)  
Old 6th September 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,931
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by divadgnol67 View Post
What man page should I read in order to configure my TI Multimedia card reader as it is not configured.
Posting the output of dmesg(8) might help us to provide more specific advice.
Reply With Quote
  #5   (View Single Post)  
Old 7th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default

@ocicat, Thanks for taking a look at my dmesg but I think BSDfan666 is probably correct.

Code:
OpenBSD 4.7 (GENERIC.MP) #449: Wed Mar 17 20:55:07 MDT 2010
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Genuine Intel(R) CPU T2050 @ 1.60GHz ("GenuineIntel" 686-class) 1.60 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,EST,TM2,xTPR
real mem  = 2137026560 (2038MB)
avail mem = 2061840384 (1966MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 03/09/07, BIOS32 rev. 0 @ 0xfd63d, SMBIOS rev. 2.4 @ 0xdf010 (38 entries)
bios0: vendor Phoenix Technologies LTD version "5.60" date 03/09/2007
bios0: TOSHIBA Satellite A105
acpi0 at bios0: rev 2
acpi0: tables DSDT FACP APIC HPET MCFG TCPA APIC SLIC BOOT SSDT SSDT SSDT SSDT SSDT
acpi0: wakeup devices HDEF(S4) PXS1(S4) PXS2(S4) USB2(S3) USB3(S3) USB7(S3) LANC(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 132MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Genuine Intel(R) CPU T2050 @ 1.60GHz ("GenuineIntel" 686-class) 1.60 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,EST,TM2,xTPR
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 2, remapped to apid 1
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEGP)
acpiprt2 at acpi0: bus 2 (RP01)
acpiprt3 at acpi0: bus 3 (RP02)
acpiprt4 at acpi0: bus 5 (RP03)
acpiprt5 at acpi0: bus 7 (PCIB)
acpiec0 at acpi0
acpicpu0 at acpi0: C2, C1, PSS
acpicpu1 at acpi0: C2, C1, PSS
acpipwrres0 at acpi0: FN00
acpitz0 at acpi0: critical temperature 106 degC
acpitz1 at acpi0: critical temperature 96 degC
acpibtn0 at acpi0: LID_
acpibat0 at acpi0: BAT0 model "PA3399U-2BAS/BRS" serial 042E type Li-ion
acpiac0 at acpi0: AC unit online
acpibtn1 at acpi0: PWRB
acpidock0 at acpi0: DOCK not docked (0)
acpivideo0 at acpi0: VGA_
acpivout0 at acpivideo0: CRT_
acpivout1 at acpivideo0: LCD_
acpivout2 at acpivideo0: TV__
acpivout3 at acpivideo0: DVI_
acpivideo1 at acpi0: GFX0
acpivout4 at acpivideo1: CRT1
acpivout5 at acpivideo1: DTV1
acpivout6 at acpivideo1: LCD_
bios0: ROM list: 0xc0000/0xec00! 0xcf000/0x1800 0xdf000/0x1000! 0xe0000/0x1c00!
cpu0: Enhanced SpeedStep 1596 MHz: speeds: 1600, 1333, 1067, 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82945GM Host" rev 0x03
vga1 at pci0 dev 2 function 0 "Intel 82945GM Video" rev 0x03
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp0 at vga1
agp0 at intagp0: aperture at 0xd0000000, size 0x10000000
inteldrm0 at vga1: apic 1 int 16 (irq 10)
drm0 at inteldrm0
"Intel 82945GM Video" rev 0x03 at pci0 dev 2 function 1 not configured
azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x02: apic 1 int 22 (irq 10)
azalia0: codecs: Realtek ALC861, AT&T/Lucent/0x3026, using Realtek ALC861
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x02: apic 1 int 17 (irq 11)
pci1 at ppb0 bus 2
ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x02: apic 1 int 16 (irq 10)
pci2 at ppb1 bus 3
ppb2 at pci0 dev 28 function 2 "Intel 82801GB PCIE" rev 0x02: apic 1 int 18 (irq 11)
pci3 at ppb2 bus 5
wpi0 at pci3 dev 0 function 0 "Intel PRO/Wireless 3945ABG" rev 0x02: apic 1 int 18 (irq 11), MoW1, address 00:18:de:d1:c3:18
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x02: apic 1 int 23 (irq 11)
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x02: apic 1 int 19 (irq 10)
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x02: apic 1 int 18 (irq 11)
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x02: apic 1 int 16 (irq 10)
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x02: apic 1 int 23 (irq 11)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb3 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xe2
pci4 at ppb3 bus 7
cbb0 at pci4 dev 6 function 0 "TI PCIXX12 CardBus" rev 0x00: apic 1 int 18 (irq 255), CardBus support disabled
"TI PCIXX12 FireWire" rev 0x00 at pci4 dev 6 function 1 not configured
"TI PCIXX12 Multimedia Card Reader" rev 0x00 at pci4 dev 6 function 2 not configured
sdhc0 at pci4 dev 6 function 3 "TI PCIXX12 Secure Data" rev 0x00: apic 1 int 18 (irq 11)
sdmmc0 at sdhc0
fxp0 at pci4 dev 8 function 0 "Intel PRO/100 VM" rev 0x02, i82562: apic 1 int 20 (irq 10), address 00:a0:d1:63:7e:f0
inphy0 at fxp0 phy 1: i82562ET 10/100 PHY, rev. 0
cardslot0 at cbb0 slot 0 flags 0
pcmcia0 at cardslot0
ichpcib0 at pci0 dev 31 function 0 "Intel 82801GBM LPC" rev 0x02: PM disabled
pciide0 at pci0 dev 31 function 2 "Intel 82801GBM SATA" rev 0x02: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <TOSHIBA MK1032GSX>
wd0: 16-sector PIO, LBA48, 95396MB, 195371568 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, DVD-RAM UJ-841S, 1.60> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x02: apic 1 int 19 (irq 10)
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 1GB DDR2 SDRAM non-parity PC2-6400CL5 SO-DIMM
spdmem1 at iic0 addr 0x52: 1GB DDR2 SDRAM non-parity PC2-6400CL5 SO-DIMM
usb1 at uhci0: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb2 at uhci1: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci2: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci3: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
uhidev0 at uhub2 port 2 configuration 1 interface 0 "Microsoft Microsoft Wireless Optical Mouse\M-. 1.00" rev 2.00/0.07 addr 2
uhidev0: iclass 3/1, 23 report ids
ums0 at uhidev0 reportid 17: 3 buttons, Z dir
wsmouse1 at ums0 mux 0
uhid0 at uhidev0 reportid 18: input=0, output=0, feature=1
uhid1 at uhidev0 reportid 19: input=1, output=0, feature=0
uhid2 at uhidev0 reportid 20: input=1, output=0, feature=0
uhid3 at uhidev0 reportid 21: input=3, output=0, feature=0
uhid4 at uhidev0 reportid 23: input=0, output=0, feature=1
uhidev1 at uhub3 port 2 configuration 1 interface 0 "Hewlett-Packard Company HP USB Smart Card Keyboard" rev 2.00/5.35 addr 2
uhidev1: iclass 3/1
ukbd0 at uhidev1: 8 modifier keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
vscsi0 at root
scsibus1 at vscsi0: 256 targets
softraid0 at root
root on wd0a swap on wd0b dump on wd0b

Last edited by ocicat; 7th September 2010 at 02:01 PM. Reason: add closing [/code] tag
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Critical hole closed in Foxit Reader J65nko News 0 10th August 2010 05:51 PM
Kobil smartcard reader hacked J65nko News 0 4th June 2010 12:50 PM
Adobe still distributing old vulnerable Reader J65nko News 0 18th February 2010 03:40 PM
ran make deinstall in /usr/ports/multimedia/ How do I undo this? kasse FreeBSD General 11 5th September 2008 08:22 AM
Made Multimedia Server with FreeBSD 7 mfaridi FreeBSD Installation and Upgrading 6 17th May 2008 08:04 AM


All times are GMT. The time now is 06:46 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick