DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 7th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default Internal Laptop Speakers

Laptop speakers fail to produce sound. I have read 13 – 13.6 but am unable to get sound from my laptop speakers. I’m not sure if the headphone jack works since it’s broken.


This is what I have done so far – created an entry in /etc/fstab for the cdrom drive. I am able to mount the drive and access it as long as it is not a music cd. In other words I can insert the openbsd 4.7 cd and access it with no problem. Also, when I issue cdio play the cd starts to spin but no sound.

Not looking to be spoon fed the answer but a gently nudge in the right direction would be greatly appreciated.

divadgnol67

Last edited by divadgnol67; 7th September 2010 at 07:03 PM. Reason: Solved
Reply With Quote
  #2   (View Single Post)  
Old 7th September 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,906
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by divadgnol67 View Post
...created an entry in /etc/fstab for the cdrom drive.
What happens when you boot without a disc in the drive? Putting optical drives into /etc/fstab is not a common practice -- especially given that audio CD's are typically not mounted.

If your goal is to avoid manually having to issue mount(8) commands when a disc is inserted, look at amd(8).

Yet back to your original question about playing audio CD's, my recommendation is delete the entry in /etc/fstab, reboot, & simply try cdio(1) at the command-line as described in Section 13.3 of the FAQ.
Reply With Quote
  #3   (View Single Post)  
Old 7th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default

@ocicat,

thanks for the advice and the suggestions. will let you know if it works.

divadgnol67
Reply With Quote
  #4   (View Single Post)  
Old 7th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default

ocicat,

I was following this example from the fstab man page

Here is a sample /etc/fstab file:

Quote:
/dev/sd0a / ffs rw 1 1
/dev/sd0e /var ffs rw,nodev,nosuid 1 2
#/dev/sd0f /tmp ffs rw,nodev,nosuid 1 2
swap /tmp mfs rw,nodev,nosuid,-s=153600 0 0
/dev/sd0g /usr ffs rw,nodev 1 2
/dev/sd0h /usr/local ffs rw,nodev 1 2
/dev/sd0i /home ffs rw,nodev,nosuid 1 2
/dev/sd0j /usr/src ffs rw,nodev,nosuid,softdep 1 2
/dev/sd1b none swap sw 0 0
/dev/cd0a /cdrom cd9660 ro,noauto 0 0
server:/export/ports /usr/ports nfs rw,nodev,nosuid,soft,intr 0 0
Reply With Quote
  #5   (View Single Post)  
Old 7th September 2010
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,825
Thanked 214 Times in 189 Posts
Default

Unless the CD drive has a separate analog cable connection, which is getting rare these days, you will need to use "cdio cdplay" option, which reads the CDDA tracks digitally, and converts them to audio.

I have found it helpful to use "mixerctl -a | grep mute" to more easily find all the various things that might be muted, preventing sound output. "mute=on" means "silent"
Reply With Quote
  #6   (View Single Post)  
Old 7th September 2010
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,825
Thanked 214 Times in 189 Posts
Default

Mount commands are for filesystems. Audio CDs don't have them. Audio discs are not mounted.

(Yes, there are such things as hybrid audio and data discs, where one track is data, the other tracks audio. Those are relatively rare.)
Reply With Quote
  #7   (View Single Post)  
Old 7th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default

jggimi,

Thanks for the grep command. Contrary to what people say on distrowatch you guys have been helpful and respectful.

I'm not at my home laptop now but I do remember getting some info when I issued the cdio cdplay command. I think it had something to do with "block device" but not certain. I will check when I get home.

Thanks again,

divadgnol67
Reply With Quote
  #8   (View Single Post)  
Old 7th September 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,906
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by divadgnol67 View Post
Code:
/dev/cd0a /cdrom cd9660 ro,noauto 0 0
For data, this would be fine.
Reply With Quote
  #9   (View Single Post)  
Old 7th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default

Ok, I am now down to one message when I invoke cdio cdplay and it is this "cdio could not configure audio parameters as desired"

I used the previous mentioned grep command to make certain all setting were not a "muted" state. cdio play not cdio cdplay does spin the disk but no sound is being produced from the speakers.

I have left my /etc/fstab entry as /dev/cd0a /cdrom cd9660 ro,noauto 0 0 but will experiement on removing this to see if there is a difference.

divadgnol67
Reply With Quote
Old 7th September 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,906
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by divadgnol67 View Post
I have left my /etc/fstab entry as /dev/cd0a /cdrom cd9660 ro,noauto 0 0 but will experiement on removing this to see if there is a difference
My suspicion is that this is the fundamental problem in your configuration.

However, if upon removal problems still exist, there appears to be two choices:
  • Play with the control settings. Section 13.1 of the FAQ states that the labeling of controls is not standardized, so your guess is likely to be as good as anyone else's.
  • Quote:
    I’m not sure if the headphone jack works since it’s broken.
    We don't know the full extent of whether this is limited simply to the headphones only or a symptom of something much more pervasive.
Reply With Quote
Old 7th September 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

If you're attempting to play an audio CD, ignore the fstab(5) file, it's totally irrelevant in this situation.

OpenBSD's cdio(1) program supports two methods of playing audio CD's.
  • play issues a command to the firmware of the CD-ROM which has it's own native ability to play audio CD's, it requires a small 3 wire cable between the drive and the soundcard, this may or may not be connected in a laptop but the drive firmware may still spin up and appear to be playing the disk, it's also possible the input isn't selected in mixerct(1).
  • cdplay digitally extracts the audio from the disk and uses the sndio(7) library to send the audio data to a listening aucat(1) daemon or directly to an audio(4) device.

Now, in a previous topic you posted your dmesg.. your laptop has one of the azalia(4) devices, these are notoriously complex and it's difficult to pick a default configuration that will work for all cards.

The author of the driver quite frequently deals with people posting to the lists with problems.. so in the 4.8 release the man page has been updated to help end users configure their cards properly, this process is largely trail and error and it's going to take some fiddling with mixerctl(1) to get things working on your system.

If you wish, you can try posting the output of that program here and maybe someone would be willing to help you.. but it's going to require that you be patient, again, these cards are much more sophisticated than most of the audio drivers supported by OpenBSD (..and hence why the FAQ wasn't able to help you).

Good luck,

Last edited by BSDfan666; 7th September 2010 at 06:59 PM.
Reply With Quote
Old 7th September 2010
divadgnol67 divadgnol67 is offline
Fdisk Soldier
 
Join Date: Jul 2009
Posts: 67
Thanked 4 Times in 2 Posts
Default

SOLVED - I installed xine and then changed media settings to /dev/cd0c and now both dvd's and cd's play with no problem. It only seems to work as root at the moment but I suspect this is a permissions issue and no longer a hardware issue.

thanks everyone,

divadgnol67
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
laptop speakers dgulotta OpenBSD General 2 9th August 2010 12:49 AM
Headphones versus built-in speakers ddrx OpenBSD General 6 28th November 2009 05:07 PM
Redirect Internal Network to Internal Website plexter OpenBSD Security 12 12th February 2009 08:00 PM
Speakers not working in Dell Vostro 1400 mc_i2020 FreeBSD General 3 5th August 2008 09:00 PM
2 external NIC + 1 internal NIC AlexV FreeBSD General 7 4th June 2008 08:18 AM


All times are GMT. The time now is 02:55 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick