DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 8th October 2010
Kkb8 Kkb8 is offline
New User
 
Join Date: Oct 2010
Posts: 2
Thanked 0 Times in 0 Posts
Default Cannot reset hardware ath0

Hello everyone,

First of all, I would like to say that this it my first post!
Also, I would like to say that I did search the forums before posting this.

I am no stranger to OpenBSD, but I have just installed it for the first time on an HP laptop. Everything works great as I expected, accept the wireless card. When I configure it to "up" status, I get the error:
"Cannot reset hardware ath0: HAL status: 0"
It seems to give me a different HAL status every time, but HAL status 0 always occurs when setting the interface to "up". I also get the error when setting the IP address.

It's an Atheros AR5007 card.
Reply With Quote
  #2   (View Single Post)  
Old 8th October 2010
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,888
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by Kkb8 View Post
It's an Atheros AR5007 card.
The manpage for ath(4) doesn't list this chipset, so it may be that it resembles enough of what the driver expects that the kernel associates the two together. Perhaps this wasn't enough of an association to be fully correct.

You did not state which version of OpenBSD you are using, but the commit history to the primary file in the ath(4) driver:

http://www.openbsd.org/cgi-bin/cvswe...i/if_ath_pci.c

...shows that the last change committed was in August which is after OpenBSD 4.8 was tagged. You might want to consider installing a snapshot of -current to see if this resolves the matter, but given that the manpage doesn't list this chipset, I wouldn't be very hopeful.
Reply With Quote
  #3   (View Single Post)  
Old 8th October 2010
Oko's Avatar
Oko Oko is offline
Fsck Surgeon
 
Join Date: May 2008
Location: Kosovo, Serbia
Posts: 770
Thanked 36 Times in 32 Posts
Default

man pages

Quote:
DIAGNOSTICS
ath%d: unable to attach hardware; HAL status %u The Hardware Access
Layer was unable to configure the hardware as requested. The status code
is explained in the HAL include file sys/dev/ic/ar5xxx.h.
Looks to me as unsupported chipset. Before making noise on misc@openbsd install the latest snapshot to see if the problem persists.
Reply With Quote
  #4   (View Single Post)  
Old 8th October 2010
Kkb8 Kkb8 is offline
New User
 
Join Date: Oct 2010
Posts: 2
Thanked 0 Times in 0 Posts
Default

I forgot to mention, I'm currently on OpenBSD 4.7.

I would hate to run a line to the laptop, as it would be highly inconvenient. I think I could run FreeBSD on it, not 100% sure though, my experience with FreeBSD is limited as OpenBSD is what I have always used. That laptop always has wireless issues, I'm considering just getting another card for it.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ath0: no carrier FreeBee FreeBSD General 6 9th January 2010 08:59 AM
FreeBSD 7.2@amd64 atheros problem ath0: stuck beacon; resetting (bmiss count 4) asmo FreeBSD General 0 6th June 2009 11:02 AM
Freebsd Ath0 mode monitor mateusrico FreeBSD General 3 8th April 2009 09:34 AM
Hardware recommendation: what hardware to buy for my new FreeBSD desktop? Broodjegehaktmetmayo General Hardware 92 11th February 2009 10:43 PM
Ath0 + wpa, how configure? nesca2in1 FreeBSD General 10 2nd July 2008 04:12 AM


All times are GMT. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick