DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 31st December 2010
Mako_Elite Mako_Elite is offline
BSD_ROCKS
 
Join Date: Nov 2010
Posts: 39
Thanked 0 Times in 0 Posts
Default sound inop when wake up from suspend.

Hello
I am trying to figure out this one with no luck.

After my Thinkpad T23 wakes up from suspend sound is not working when I try
to play DVD or videos from my HD.
When I reboot sound works great as long as I don't put laptop to suspend.

I was looking for a way to manually restart sound server, but I couldn't fine any info on that. Is there a way to restart it manually? Also I noticed that settings in "mixerctl" are slightly different before and after suspend example
mixrctl (outputs.master.mute=on) after suspend, but not after reboot.
I did try to change settings (outputs.master.mute=off) , but sound still inop.

I think it has to do something with sound server.

Any help on this would be greatly appreciated. Here is dmesg file
Attached Files
File Type: txt dmesg_file.txt (4.3 KB, 7 views)
Reply With Quote
  #2   (View Single Post)  
Old 31st December 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

If you're having issues with auich(4) after resume, you should file a bug report.. or at least send the question to the bugs@/misc@ mailing lists.

As for restarting the "sound server", if you're not running aucat(1) in server mode, then there is no sound server.. if the audio driver simply doesn't work after resume, no amount of user configuration will fix the problem.

This laptop is probably older than what's being currently tested these days, from the dmesg it seems you're using apm(4), consider disabling that in UKC/config(8) and seeing if acpi(4)-based suspend/resume works.

Trying a 4.8-current snapshot may also be worthwhile.
Reply With Quote
  #3   (View Single Post)  
Old 31st December 2010
Mako_Elite Mako_Elite is offline
BSD_ROCKS
 
Join Date: Nov 2010
Posts: 39
Thanked 0 Times in 0 Posts
Default

BSDfan666

Thanks for the help. I disabled apm at boot> -c with "disable apm".
It did started with apm disabled. This time it wont suspend when lid closed running on
acpi. I also did commented out machdep.lidsuspend=1 in sysctl.conf.
Is there command for acpi to go to suspend? Fn/F4 key did not work.
I guess I just have to live with it. It is not a big deal if suspend works or not.
If I want to disable apm permanently so I don't have to do it at boot, which files I
need to modify? Here is dmesg after apm disabled

thanks again
Attached Files
File Type: txt dmesg_file_apm_disabled.txt (4.7 KB, 4 views)
Reply With Quote
  #4   (View Single Post)  
Old 31st December 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Yeah, some Fn keys combinations are handled internally by the laptop.. others get translated into keyboard scancodes or ACPI events and require special handling, if you read the dmesg you'll see the acpithinkpad(4) driver does attach when you enable ACPI but the man page indicates it only adds support for the brightness/volume/wifi features on some laptops.

Regardless of whether the kernel apm(4)/acpi(4) drivers are being used, apm(8)/apmd(8) can be used to initiate suspend requests.

Once you've enabled apmd(8) in /etc/rc.conf.local, try running zzz or apm -S/apm -z.

As for the machdep.lidsuspend=1 method, Mark Kettenis just fixed a problem that has been effecting suspend/resume on several laptops.. it may or may not be in the latest available snapshot, so try installing one sometime soon, like if one shows up later today or on January 1st.

http://marc.info/?l=openbsd-cvs&m=129367082717314&w=2
http://marc.info/?t=129366437900006&r=1&w=2

If you want to keep using 4.8, and already have the kernel source extracted, you can try setting the pci_dopm variable to 0 in dev/acpi/acpi.c.. it might fix that problem temporarily.

Let us know how it works out..
Reply With Quote
  #5   (View Single Post)  
Old 31st December 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

Note; I mentioned you can use config(8) to make changes to kernel binaries permanent, instructions have also been given on this forum hundreds of times.
Reply With Quote
  #6   (View Single Post)  
Old 31st December 2010
Mako_Elite Mako_Elite is offline
BSD_ROCKS
 
Join Date: Nov 2010
Posts: 39
Thanked 0 Times in 0 Posts
Default

BSDfan666
I just permanently disabled apm with "config", sleek program I like it. I am new to OpenBSD and learning fast as I can.

Far as Kernel source. I have not extracted yet. I did not venture to the snapshots yet. I will play with this next few days and try pci_dopm set to 0 in dev/acpi/acpi.c and see what happen.

I did try apm -S and -z == no luck.

Thanks again for all that help.

Also latest dmesg after permanently disabling apm.

Happy New Year
Attached Files
File Type: txt dmesg_file_apm_disabled_permanently.txt (4.6 KB, 5 views)
Reply With Quote
  #7   (View Single Post)  
Old 1st January 2011
Mako_Elite Mako_Elite is offline
BSD_ROCKS
 
Join Date: Nov 2010
Posts: 39
Thanked 0 Times in 0 Posts
Default

BSDfan666
Quick question,
I am ready to download sources. Should I go with AnonCVS or CVSync since I am assuming I will need -current to get latest snapshot? I don't think -stable will have the latest updates in it. Is AnonCVS -current the right tree or go with CVSync -stable?

Thanks for any info on that.
Reply With Quote
  #8   (View Single Post)  
Old 1st January 2011
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

That information is in the FAQ.

With 4.8 you would use the sys/src release tarballs from a mirror.. from there you can either apply errata patches or update to the stable tree.

You can't go from release to -current using source "officially", the preferred method is to install or upgrade to a snapshot instead.

http://www.openbsd.org/faq/faq5.html#Flavors
Reply With Quote
  #9   (View Single Post)  
Old 1st January 2011
Mako_Elite Mako_Elite is offline
BSD_ROCKS
 
Join Date: Nov 2010
Posts: 39
Thanked 0 Times in 0 Posts
Default

BSDfan666
Thanks for the super fast respond. I went threw FAQ and also OpenBSD-101
I knew that I can't go from -release to -current. I am going to update regardless.

I guess my question should be where these two updates are located in -stable or -current or simply in CVS regardless.

Quote:
http://marc.info/?l=openbsd-cvs&m=129367082717314&w=2
http://marc.info/?t=129366437900006&r=1&w=2

If you want to keep using 4.8, and already have the kernel source extracted, you can try setting the pci_dopm variable to 0 in dev/acpi/acpi.c.. it might fix that problem temporarily
thanks again and

Happy 2011
Reply With Quote
Old 1st January 2011
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Thanked 193 Times in 184 Posts
Default

The fix I mentioned would not be in the stable tree, only -current and snapshots, the workaround by setting that variable might work on 4.8 until you ready to switch.

This is assuming the problem that was fixed recently is the same one effecting your laptop, I don't know for sure.
Reply With Quote
Old 7th January 2011
Mako_Elite Mako_Elite is offline
BSD_ROCKS
 
Join Date: Nov 2010
Posts: 39
Thanked 0 Times in 0 Posts
Default

Finally I had the time to test latest snapshot 4.8 (i386)as Jan-5-2011 on
Thinkpad A22p

ACPI with (disable apm at boot) would suspend with Fn/F4 key, but it would
freeze on wake up...had to hard reboot. Same problem with apm enabled.

With -release I could suspend with apm enabled, but loose sound after wake up.

I am not really worry about the suspend. I can live without it, especially on older laptops like mine.

Here is dmesg after upgraded to snapshot.
Attached Files
File Type: txt dmesg_snapshot.txt (8.3 KB, 3 views)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD request for testing suspend/resume ocicat News 6 6th August 2010 04:11 AM
Recording sound with external sound card backrow OpenBSD General 5 21st August 2009 08:17 PM
cant wake on lan afer shutdown -p (may be acpi related) edhunter FreeBSD General 7 10th October 2008 07:50 PM
Sound JimC FreeBSD General 9 15th August 2008 06:05 PM
USB not working after suspend stukov Other BSD and UNIX/UNIX-like 5 11th August 2008 06:48 PM


All times are GMT. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick