DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Package System (pkgsrc)

NetBSD Package System (pkgsrc) Installation and upgrading of packages on NetBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th November 2010
jewsofeast jewsofeast is offline
Port Guard
 
Join Date: Nov 2010
Posts: 26
Thanked 0 Times in 0 Posts
Lightbulb gnome configuration in NetBSD 5.1

I've installed gnome desktop in NetBSD 5.1, I can start a gnome-session after console log in. How do I get to gnome desktop by default.

Here are my configuration files -

Quote:
NBSD$ cat ~/.xinitrc
exec gnome-session
Quote:
cat ~/.xsession
#!/bin/sh
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
xmodmap "$usermodmap"
fi

# start some nice programs



gdm &
xclock -geometry 50x50-1+1 &
/usr/X11R7/bin/xterm -geometry 80x50+494+51 &
/usr/X11R7/bin/xterm -geometry 80x20+494-0 &
exec /usr/X11R7/bin/xterm -geometry 80x66+0+0 -name login
exec gdm
Quote:
cat /etc/rc.conf
# $NetBSD: rc.conf,v 1.96 2000/10/14 17:01:29 wiz Exp $
#
# see rc.conf(5) for more information.
#
# Use program=YES to enable program, NO to disable it. program_flags are
# passed to the program on the command line.
#

# Load the defaults in from /etc/defaults/rc.conf (if it's readable).
# These can be overridden below.
#
if [ -r /etc/defaults/rc.conf ]; then
. /etc/defaults/rc.conf
fi

# If this is not set to YES, the system will drop into single-user mode.
#
rc_configured=YES

# Add local overrides below
#
wscons=YES
hostname=NBSD.NetBSD.org
dhclient=YES
defaultroute=192.168.1.1
gdm=YES
famd=YES
rpcbind=YES
dbus=YES
hal=YES
Secondly, I dont see any shutdown, hibernate or suspend option in panel.

How do I fix this.

Best,

David
Reply With Quote
  #2   (View Single Post)  
Old 25th November 2010
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 612
Thanked 9 Times in 9 Posts
Default

I'm confused by the entry to start gdm in your .xsession.

A suggestion is to simplify your .xsession to read the same .your .xinitrc.

Also you do not need to be root to write/edit your .xinitrc/.xsession file
Quote:
$ mv ~/.xsession ~/.xsession_bu
$ ln -s ~/.xinitrc ~/.xession
The gnome display manager should then have an option to select the gnome desktop which you can make permanent.

Congratulations on getting this far. NetBSD has been more challenging as of late to install a desktop compared to OpenBSD or FreeBSD.
Reply With Quote
  #3   (View Single Post)  
Old 26th November 2010
jewsofeast jewsofeast is offline
Port Guard
 
Join Date: Nov 2010
Posts: 26
Thanked 0 Times in 0 Posts
Lightbulb

Quote:
Originally Posted by shep View Post
I'm confused by the entry to start gdm in your .xsession.

A suggestion is to simplify your .xsession to read the same .your .xinitrc.

Also you do not need to be root to write/edit your .xinitrc/.xsession file


The gnome display manager should then have an option to select the gnome desktop which you can make permanent.

Congratulations on getting this far. NetBSD has been more challenging as of late to install a desktop compared to OpenBSD or FreeBSD.
Thanks, I will give it a try. NetBSD is challenging but their documentation is better than OpenBSD.
Reply With Quote
  #4   (View Single Post)  
Old 26th November 2010
jewsofeast jewsofeast is offline
Port Guard
 
Join Date: Nov 2010
Posts: 26
Thanked 0 Times in 0 Posts
Lightbulb

Been there done that -

Code:
$ mv ~/.xsession ~/.xsession_bu
$ ln -s ~/.xinitrc ~/.xsession
Code:
NBSD$ cat ~/.xsession
exec gnome-session
Reply With Quote
  #5   (View Single Post)  
Old 26th November 2010
jewsofeast jewsofeast is offline
Port Guard
 
Join Date: Nov 2010
Posts: 26
Thanked 0 Times in 0 Posts
Default

It doesnt work.
Reply With Quote
  #6   (View Single Post)  
Old 26th November 2010
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 612
Thanked 9 Times in 9 Posts
Default

Quote:
Thanks, I will give it a try. NetBSD is challenging but their documentation is better than OpenBSD.
If you are using
http://www.netbsd.org/docs/guide/en/index.html
I do no believe that it has had much in the way of updating since version 4.01
In point there is no documentation about setting up wireless wpa encryption. I also have tried NetBSD and have run into similiar road blocks.

The OpenBSD FAQ, although, more succint, is rewritten for each release. I have had a much higher success rate with OpenBSD. In your case for Gnome, most of what you need to know is in the gnome-session README.OpenBSD. After installing gnome-session the readme is in
/usr/local/share/doc/gnome-session/README.OpenBSD

http://www.openbsd.org/cgi-bin/cvswe...e=text%2Fplain
Reply With Quote
  #7   (View Single Post)  
Old 27th November 2010
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 612
Thanked 9 Times in 9 Posts
Default

Another thought, have you tried xdm per the NetBSD handbook. If xdm works it would suggest that your .xsession is ok and the problem is with gdm.

http://www.netbsd.org/docs/guide/en/...tml#chap-x-xdm
Reply With Quote
  #8   (View Single Post)  
Old 6th December 2010
fbsduser fbsduser is offline
Shell Scout
 
Join Date: Aug 2008
Posts: 107
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by jewsofeast View Post
I've installed gnome desktop in NetBSD 5.1, I can start a gnome-session after console log in. How do I get to gnome desktop by default.

Here are my configuration files -







Secondly, I dont see any shutdown, hibernate or suspend option in panel.

How do I fix this.

Best,

David
Why do you have two "exec" lines in your .xsession file? Isn't it supposed to allow only the last line as a "exec" line?
Reply With Quote
  #9   (View Single Post)  
Old 10th January 2011
jewsofeast jewsofeast is offline
Port Guard
 
Join Date: Nov 2010
Posts: 26
Thanked 0 Times in 0 Posts
Default

Its fixed, I deinstalled gdm and installed kde with kdm; had same issues. The problem was kdmrc in two locations.

Xserver invocation depends on

Quote:
/usr/pkg/etc/kdm/kdmrc
and there was another kdmrc at
Quote:
usr/pkg/share/kde/config/kdm/kdmrc
Code:
rm /usr/pkg/share/kde/config/kdm/kdmrc
Code:
ln -sv /usr/pkg/etc/kdm/kdmrc /usr/pkg/share/kde/config/kdm/kdmrc
which kdm >> /etc/rc.local
Now I get kdm at boot.

I've have configured gnome-session in kdmrc but I dont see shutdown & reboot options in it.

Can someone help get this sorted?

Best,

Dave
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PF NAT configuration help ikevinjpdev OpenBSD Security 0 7th August 2010 04:41 PM
NetBSD 5 keyboard layout in gnome jaideep_jdof NetBSD Package System (pkgsrc) 1 17th September 2009 03:50 PM
carp configuration ohhcarp OpenBSD General 3 16th April 2009 10:50 PM
k3b, configuration. maxrussell FreeBSD Ports and Packages 4 3rd March 2009 04:23 AM


All times are GMT. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick