DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th July 2011
sepuku's Avatar
sepuku sepuku is offline
Real Name: Vizard Sepuku
Package Pilot
 
Join Date: Jun 2011
Location: Athens & Chania,Greece
Posts: 143
Thanked 0 Times in 0 Posts
Default wireless nwid error

Hello again people,

After finally setting my connection and being able to connect via ethernet,i'm trying to connect using the wireless this time.I installed the wpi-firmware and I have this nwid:

Code:
NetFasteR IAD (PSTN)
So after typing something like this:

Code:
# ifconfig wpi0 nwid NetFasteR IAD (PSTN) wpakey thepassword
i get this error

Code:
ksh: syntax error : `(' unexpected
Is there a trick to make it work without changing to a nwid without `(' ?
Reply With Quote
  #2   (View Single Post)  
Old 25th July 2011
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,834
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by sepuku View Post
Is there a trick to make it work without changing to a nwid without `(' ?
If you look at the wpi(8) manpage, you will see that the expected command-line arguments will take the form:
Code:
# ifconfig wpi0 nwid my_net wpakey passphrase
In other words, the third command-line parameter denotes the network identifier. The embedded spaces & the parenthesis in:
Quote:
NetFasteR IAD (PSTN)
...are thus reeking havoc.

You can try encapsulating this string in single quotes, & if this still doesn't work, try adding a backslash before the opening & closing parenthesis.

Untested.
Reply With Quote
  #3   (View Single Post)  
Old 26th July 2011
sepuku's Avatar
sepuku sepuku is offline
Real Name: Vizard Sepuku
Package Pilot
 
Join Date: Jun 2011
Location: Athens & Chania,Greece
Posts: 143
Thanked 0 Times in 0 Posts
Default

Yeap single quoting worked fine thanx ocicat.
Reply With Quote
Reply

Tags
ifconfig, wifi nwid name

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Troubles divadgnol67 OpenBSD General 6 23rd September 2010 12:12 PM
shc unistd.h:239: error: syntax error before '&' token laraaj OpenBSD General 3 11th September 2010 07:21 AM
wireless not working. bsdnewbie999 OpenBSD General 17 19th July 2009 03:06 AM
Wireless Card on T61 disappearedng FreeBSD General 1 13th July 2008 12:54 AM
Gui for Wireless LAN? PatrickBaer FreeBSD General 2 13th June 2008 12:25 AM


All times are GMT. The time now is 04:45 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick