DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 3rd October 2011
raindog308 raindog308 is offline
Port Guard
 
Join Date: Sep 2011
Posts: 35
Thanked 0 Times in 0 Posts
Default iwn wi-fi - "could not read firmware" - my error?

Looks like I may have spoke too soon on my new little laptop supporting wifi under OpenBSD. Or at least out of the box.

dmesg reports it has an "Intel Wifi Link 100". I did pkg_add the separately-downloaded Intel firmware per the iwn man page.

After doing an

ifconfig iwn0 nwid 'Some Hotel Network'

and then

dhclient iwn0

I see in dmesg:

iwn0: error, 2, could not read firmware iwn-1000

In /etc/firmware, there is an iwn-1000 which is a symlink to iwlwifi-1000-3.ucode (this was setup by pkg_adding the Intel firmware package). The iwlwifi-1000-3.ucode file exists and is 33056 bytes.

Anyone have any advice? I'm wondering if this is more of a user error rather than a driver problem because it's saying it "could not read" - which the man page says "For some reason, the driver was unable to read the firmware image from the filesystem". There is a separate error for "could not load firmware".
Reply With Quote
  #2   (View Single Post)  
Old 3rd October 2011
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,823
Thanked 214 Times in 189 Posts
Default

I don't use iwn(4). When I installed the package just now (on a old 4.7 system I have handy at the moment, in a virtual machine), I don't get symlinks, I get the firmware files themselves loaded into /etc/firmware, using http://firmware.openbsd.org/firmware...rmware-5.6.tgz as the package.

My guess is you are correct, this is user error. But it may not be. Where did you get your package?
Reply With Quote
  #3   (View Single Post)  
Old 4th October 2011
raindog308 raindog308 is offline
Port Guard
 
Join Date: Sep 2011
Posts: 35
Thanked 0 Times in 0 Posts
Default

Installing from firmware.openbsd.org worked.

The 4.9 man page refers to a free.fr site, which may not have worked correctly.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error: "Cannot talk to klauncher" RJPugh FreeBSD General 0 9th September 2011 02:29 AM
"Can't check filesystem" error after installation sepuku OpenBSD Installation and Upgrading 6 22nd July 2011 10:25 AM
Fixed "xinit" after _7 _8, "how" here in case anyones' "X" breaks... using "nvidia" jb_daefo Guides 0 5th October 2009 09:31 PM
"No package available in the PKG_PATH" error Nk2Network OpenBSD Packages and Ports 19 12th January 2009 09:22 PM
dhclient iwi0 "Could not read iwi-bss' error FreeMan OpenBSD General 2 15th May 2008 08:01 PM


All times are GMT. The time now is 01:30 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick