DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 4th October 2011
raindog308 raindog308 is offline
Port Guard
 
Join Date: Sep 2011
Posts: 35
Thanked 0 Times in 0 Posts
Default I can DHCP but after that...nada on the net

So I have a laptop with an re0 (Realtek 8101E). I plugged an ethernet cable in and ran dhclient. I got an address.

However, an attempt to ping the router results in all packets lost. in fact, I can't seem to go anywhere - ssh, etc.

My dhcp'd address is 192.168.1.100 (as an example). netstat -rn -f inet shows 192.168.1.1 as the default gateway (that is the router and correct). The entry for 192.168.1.1 is link#1 aka re0. The entry:

192.168.1.1 (router MAC)

is the one that increases in the Use column when I try to ping.

I ran pfctl -d just to take pf out of the equation.

re0 shows an lladdr of 00:00:00:00:00:00, which is unusual, and dmesg shows an "unknown ASIC". The dhcp'd address, netmask, broadcast, DNS, etc. are all correct.

So I'm wondering if there is something I need to configure further to get networking working (this is my first attempt to set it up on this box and I'm a little rusty on OpenBSD networking).
Reply With Quote
  #2   (View Single Post)  
Old 4th October 2011
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,905
Thanked 190 Times in 160 Posts
Default

Post the output of the ifconfig(8). Redact any public IP addresses displayed.
Reply With Quote
  #3   (View Single Post)  
Old 4th October 2011
raindog308 raindog308 is offline
Port Guard
 
Join Date: Sep 2011
Posts: 35
Thanked 0 Times in 0 Posts
Default

Here is ifconfig -a:

Code:
lo0: flags=8149<UP,LOOPBACK,RUNNING,PROMISC,MULTICAST> mtu 33160
	priority: 0
	groups: lo
	inet6 ::1 prefixlen 128
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
	inet 127.0.0.1 netmask 0xff000000
re0: flags=28843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST,NOINET6> mtu 1500
	lladdr 00:00:00:00:00:00
	priority: 0
	groups: egress
	media: Ethernet autoselect (100baseTX full-duplex)
	status: active
	inet 192.168.1.100 netmask 0xffffff00 broadcast 192.168.1.255
iwn0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
	lladdr 78:92:9c:11:ab:f4
	priority: 4
	groups: wlan
	media: IEEE802.11 autoselect
	status: no network
	ieee80211: nwid ""
enc0: flags=0<>
	priority: 0
	groups: enc
	status: active
pflog0: flags=141<UP,RUNNING,PROMISC> mtu 33160
	priority: 0
	groups: pflog
And here is netstat -rn -f inet:

Code:
Routing tables

Internet:
Destination        Gateway            Flags   Refs      Use   Mtu  Prio Iface
default            192.168.1.1        UGS        0        0     -     8 re0  
127/8              127.0.0.1          UGRS       0        0 33160     8 lo0  
127.0.0.1          127.0.0.1          UH         0        0 33160     4 lo0  
192.168.1/24       link#1             UC         1        0     -     4 re0  
192.168.1.1        00:1c:10:3c:74:f7  UHLc       1       67     -     4 re0  
192.168.1.100      127.0.0.1          UGHS       0        0 33160     8 lo0  
224/4              127.0.0.1          URS        0        0 33160     8 lo0
Reply With Quote
  #4   (View Single Post)  
Old 4th October 2011
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,810
Thanked 214 Times in 189 Posts
Default

Your lladr and unknown asic warning indicate an unsupported physical attachment layer. You can test if a -current version of the OS works by downloading bsd.rd from a snapshot, booting it from the bootloader, and testing your network interface from the shell.

A complete dmesg would have helped,I think.
Reply With Quote
  #5   (View Single Post)  
Old 4th October 2011
raindog308 raindog308 is offline
Port Guard
 
Join Date: Sep 2011
Posts: 35
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jggimi View Post
Your lladr and unknown asic warning indicate an unsupported physical attachment layer. You can test if a -current version of the OS works by downloading bsd.rd from a snapshot, booting it from the bootloader, and testing your network interface from the shell.

A complete dmesg would have helped,I think.
there's one in this thread:

http://www.daemonforums.org/showpost...83&postcount=9
Reply With Quote
  #6   (View Single Post)  
Old 4th October 2011
raindog308 raindog308 is offline
Port Guard
 
Join Date: Sep 2011
Posts: 35
Thanked 0 Times in 0 Posts
Default

Actually, maybe I'm not sure what you mean by physical attachment layer - the chip in use (Realtek 8101E) is listed as supported on the re man page. Is there something more than this that's needed? Please forgive my ignorance.
Reply With Quote
  #7   (View Single Post)  
Old 4th October 2011
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,810
Thanked 214 Times in 189 Posts
Default

Thank you for the pointer!
Code:
re0 at pci1 dev 0 function 0 "Realtek 8101E" rev 0x05: unknown ASIC (0x4080), apic 4 int 16 (irq 11), address 00:00:00:00:00:00
ukphy0 at re0 phy 7: Generic IEEE 802.3u media interface, rev. 2: OUI 0x000732, model 0x0008
Note that your PHY driver is ukphy(4), "generic/unknown IEEE 802.3u Ethernet PHY" -- and this is due to the unknown chip used by the Realtek NIC.

I found a short thread on the misc@ mailing list with a similar message, from 2007, which did not have any resolution noted:

http://marc.info/?l=openbsd-misc&m=119866202617286&w=2

And a more recent comment regarding newer hardware and 4.9 -- again, without resolution:

http://marc.info/?l=openbsd-misc&m=131408424000633&w=2

Please boot a RAMDISK kernel from a recent snapshot, as I advised, and see if -current supports your hardware. If so, you can move to -current and be fully supported.

You might try setting your NIC's Ethernet MAC address to something other than all zeroes, perhaps that will circumvent the issue. This is done with ifconfig(8) and its lladdr option.
Reply With Quote
  #8   (View Single Post)  
Old 4th October 2011
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,810
Thanked 214 Times in 189 Posts
Default

There are multiple chips in use. The "8101E" is Realtek's NIC controller chip. There is a second chip in the NIC, which communicates with the Ethernet network. In this case, it is an ASIC which OpenBSD 4.9 does not know about.

Because that NIC was able to communicate on the Ethernet for DHCP, it may be possible to assign a MAC address (also known as an Ethernet address) in order to permit point to point communication on your LAN. DHCP protocol is conducted via UDP broadcasts, not via specific device addresses.

To test -current, as I've recommended:
  1. Download bsd.rd from your nearest mirror's /pub/OpenBSD/snapshots/i386/
  2. Place that file somewhere convenient for booting. I recommend your root directory, though renamed as something other than bsd.rd so that you do not overlay your 4.9-release version; you might need it. You can name it anything you want, I recommend "bsd.test".
  3. Reboot.
  4. At the "boot>" prompt, just type bsd.test and press Enter.
  5. Select the Shell at the completion of boot.
  6. Inspect your dmesg. Is the ASIC known?
Reply With Quote
  #9   (View Single Post)  
Old 4th October 2011
raindog308 raindog308 is offline
Port Guard
 
Join Date: Sep 2011
Posts: 35
Thanked 0 Times in 0 Posts
Default

So here are the results of the tests you recommended (and thanks for that!):
  • Just setting the MAC with "ifconfig re0 lladdr <some mac>" does not fix the problem
  • Booting off current's bsd.rd worked - no longer an unknown ASIC and I was able to talk off that interface just fine.

So...looks like it's -current for me

Thanks so much again for your help.
Reply With Quote
Old 4th October 2011
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,810
Thanked 214 Times in 189 Posts
Default

Quote:
So...looks like it's -current for me
I'm glad you've got a solution. Installing -current doesn't require more than just installing a snapshot. Though staying -current does. You have two choices: building -current from source every so often, or upgrading to the latest snapshot every so often. Both choices still require reviewing the Following -current FAQ for changes to /etc and /var, as well as key architectural changes that complicate upgrades. Often, there is information in that FAQ on specific ports. You'll find a link to the Following -current FAQ in the left hand sidebar on the FAQ page.

If you've not read it, please review FAQ 5.1 as well on the flavors of OpenBSD and its development cycle, too, which will help you understand what you'll be running.

Lastly, -current packages are made available from time to time on the major architectures, for our convenience. They are likely never going to be in exact sync with your particular -current system; most of the time if your current is within a few days or so of when those packages were built you can use them. But not always; especially when there are library bumps. Expect to have to build a port or two manually once in a while due to a package<>OS sync issue.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
isc dhcp server queshaw OpenBSD Packages and Ports 1 8th February 2011 11:09 AM
W2K DHCP Issue DrJ Other OS 4 25th May 2009 07:19 PM
obtain 2 ips via dhcp dextro FreeBSD General 2 6th February 2009 04:56 AM
Obtaining multiple IPs from ISP via DHCP dextro General software and network 15 9th January 2009 02:36 AM
DHCP Server WeakSauceIII OpenBSD General 1 25th September 2008 03:34 AM


All times are GMT. The time now is 02:00 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick