DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 14th September 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default X window on KDE background?

I've set up KDE 4 (I think...) but when I boot up and then log in, I get the KDE desktop background, but no menu or bar, just one X Window...

Pointers please!
Reply With Quote
  #2   (View Single Post)  
Old 20th September 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default



I get the normal kde login, then I get:

Reply With Quote
  #3   (View Single Post)  
Old 20th September 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

, then I get:
Reply With Quote
  #4   (View Single Post)  
Old 20th September 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

I hate trying to use a hosted image.
Reply With Quote
  #5   (View Single Post)  
Old 24th September 2011
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,051
Thanked 198 Times in 156 Posts
Default

How did you install KDE and how are you starting KDE?

It looks like KDE login manager works fine, but KDE doesn't work at all...
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #6   (View Single Post)  
Old 26th September 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

I *think* I selected KDE at installation time (e.g. when doing the initial install), however I may have subsequently added KDE via a re-run of sysinstall.

What is the best way to check this please?
Reply With Quote
  #7   (View Single Post)  
Old 26th September 2011
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,051
Thanked 198 Times in 156 Posts
Default

# pkg_info -aqo | sort | grep -i kde

From pkg_info(1)

Code:
    -a, --all
	     Show all currently installed packages.

     -q, --quiet
	     Be ``quiet'' in emitting report headers and such, just dump the
	     raw info (basically, assume a non-human reading).

     -o      Show the ``origin'' path recorded on package generation.  This
	     path is the directory name in the FreeBSD Ports Collection of the
	     underlying port from which the package was generated.
Try adding exec startkde in your ~/.xinitrc and use xinit to start KDE, this might give some useful info.
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.

Last edited by Carpetsmoker; 26th September 2011 at 03:22 PM.
Reply With Quote
  #8   (View Single Post)  
Old 29th September 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

I already have the entry for kde4

Quote:
exec usr/local/kde4/bin/startkde
Reply With Quote
  #9   (View Single Post)  
Old 29th September 2011
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,051
Thanked 198 Times in 156 Posts
Default

The screenshots above show you're starting with KDM, not with xinit. Did you try xinit?
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
Old 29th September 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

what is the correct form for xinit please?
Reply With Quote
Old 30th September 2011
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,051
Thanked 198 Times in 156 Posts
Default

What do you mean? Just start FreeBSD, exit kdm if it's started, and type xinit.
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
Old 30th September 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

I can't exit kdm though, it starts after boot?
Reply With Quote
Old 30th September 2011
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,051
Thanked 198 Times in 156 Posts
Default

IIRC you can disable it by editing /etc/rc.conf
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
Old 5th October 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

One thing that would be really helpful first of all - the keymap seems to be wrong for a UK keyboard ; can I change it via a config file?

It is driving me mad trying to work out where a hash is or a slash!

Reply With Quote
Old 13th October 2011
maxrussell maxrussell is offline
Package Pilot
 
Join Date: May 2008
Location: Montrose, Angus
Posts: 181
Thanked 1 Time in 1 Post
Default

Worked out to get a # character, had the US mapping for some reason.

Anyway, commented out that entry, then started x with xinit - it crashed:
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
More background on the US security firm break-in J65nko News 0 17th February 2011 04:43 PM
Grey checkered background before kdm jewsofeast OpenBSD General 5 10th January 2011 02:37 PM
Terminal background goes red stobbard OpenBSD General 5 11th May 2010 09:42 AM
Windomaker and NeXT-like window managers harisman FreeBSD Ports and Packages 3 9th June 2008 01:22 AM
IPF: Packets Out Of Window bram85 FreeBSD Security 9 2nd June 2008 04:09 PM


All times are GMT. The time now is 03:00 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick