DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th February 2012
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default gnome's console is unaware of xterm aliases

Hi everyone !

anyone to help me find out about why gnome's console is unaware of my .profile .. that is .. aliases work on xterm/fvwm but not on console/gnome .. or even xterm when called from gnome console .. of course the same occurs in konsole/kde .. any specific ***rc that I need to have at home or .. no indicative files in .gnome2/ and .gnome2_private/ ..

Thanks for showing me the light ..
Reply With Quote
  #2   (View Single Post)  
Old 25th February 2012
backrow backrow is offline
Real Name: Anthony J. Bentley
Shell Scout
 
Join Date: Jul 2009
Location: Albuquerque, NM
Posts: 116
Thanked 10 Times in 4 Posts
Default

Sounds like the Gnome terminal isn’t triggering a login shell.

From ksh(1):
Code:
     -l      Login shell.  If the basename the shell is called with (i.e.
             argv[0]) starts with `-' or if this option is used, the shell is
             assumed to be a login shell and the shell reads and executes the
             contents of /etc/profile and $HOME/.profile if they exist and are
             readable.
From xterm(1):
Code:
       -ls     This option indicates that the shell that is started in the
               xterm window will be a login shell (i.e., the first character
               of argv[0] will be a dash, indicating to the shell that it
               should read the user's .login or .profile).
-ls seems to be the default behavior for my xterm. The equivalent for Gnome terminal may not be the default.
__________________
Many thanks to the forum regulars who put time and effort into helping others solve their problems.
Reply With Quote
  #3   (View Single Post)  
Old 26th February 2012
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,143
Thanked 182 Times in 149 Posts
Default

The solution is simple:
Code:
$ cat .Xdefaults                                               
XTerm*loginShell:true
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #4   (View Single Post)  
Old 26th February 2012
backrow backrow is offline
Real Name: Anthony J. Bentley
Shell Scout
 
Join Date: Jul 2009
Location: Albuquerque, NM
Posts: 116
Thanked 10 Times in 4 Posts
Default

Quote:
Originally Posted by J65nko View Post
The solution is simple:
Code:
$ cat .Xdefaults                                               
XTerm*loginShell:true
Does this really help Gnome Terminal?
__________________
Many thanks to the forum regulars who put time and effort into helping others solve their problems.
Reply With Quote
  #5   (View Single Post)  
Old 26th February 2012
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default

Hi J65nko ! .. it does dwell in my .Xdefaults ..
Hi Backrow ! it doesn't seem to .. hence my question about : .gnome2/ & .gnome2_private/
Reply With Quote
  #6   (View Single Post)  
Old 26th February 2012
shep shep is offline
ISO Quartermaster
 
Join Date: May 2008
Location: Dry and Dusty
Posts: 589
Thanked 9 Times in 9 Posts
Default

The gnome terminal has a gui option under 'edit' in the title bar. You can check a box to set the login shell.

Get to Know Gnome Terminal
Reply With Quote
  #7   (View Single Post)  
Old 26th February 2012
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default

Thank you shep !! It does work now ..
Terminal > edit > profile preferences > title and command > check 'Run command as a login shell'
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing font size in xterm J65nko Guides 4 4th February 2012 09:05 PM
is there a way to cut and paste text from xterm ? daemonfowl OpenBSD General 6 30th January 2012 08:03 PM
Shell aliases for regular user dbach OpenBSD General 5 30th December 2011 11:41 PM
postfix aliases configuration error xiphias FreeBSD Ports and Packages 5 5th June 2010 05:35 PM
xterm End key graudeejs General software and network 1 24th August 2008 04:55 PM


All times are GMT. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick