DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 8th July 2012
caravel caravel is offline
Port Guard
 
Join Date: Jun 2012
Posts: 25
Thanked 0 Times in 0 Posts
Default Upgraded all ports, now slow and unresponsive X

Running FreeBSD 8.3

I did

Code:
# portsnap fetch
# portsnap extract
Code:
# portmanager -l -u
Which took several hours

The result is that everything works except xorg is extremely slow and unresponsive in both xfce and openbox. I can type text in a web browser or open a program and there is obvious delay - moving the mouse causes all the text to appear at once or the opened program to appear suddenly.

So I tried the nv driver instead of the nvidia driver - no change.

I then decided to remove and reinstall xorg, xserver and drivers - no change.

I also removed and rebuilt cairo - no change. (I did this based on personal experience with libcairo bugs in linux)

I did all of this from the ports tree using

Code:
# cd /directory/for/port
# make deinstall
# make rmconfig
# make clean install
Also I had added the following to /etc/rc.conf

Code:
hald_enable="YES"
dbus_enable="YES"
And this had been working fine, now after upgrade I once again need a mouse section in xorg.conf.

Any help or advice much appreciated.
Reply With Quote
  #2   (View Single Post)  
Old 8th July 2012
jb_daefo jb_daefo is offline
Package Pilot
 
Join Date: May 2008
Posts: 196
Thanked 5 Times in 5 Posts
Default

Code:
 /usr/ports/sysutils/atop ??
might help... unless some driver needs tweaking or some routing is unoptimized... (ipv6...)...
__________________
using /LOOKAT/ with /var/db/pkg files and portmaster/aliases/pipes/find/grep to meteorically speedup port upgrades/installs...
Reply With Quote
  #3   (View Single Post)  
Old 9th July 2012
caravel caravel is offline
Port Guard
 
Join Date: Jun 2012
Posts: 25
Thanked 0 Times in 0 Posts
Default

Thanks for the reply, I'll look into this later.

I also found this thread at the freebsd forums and OP describes the same problem I'm having accurately: http://forums.freebsd.org/showthread.php?t=9611
Reply With Quote
  #4   (View Single Post)  
Old 10th July 2012
caravel caravel is offline
Port Guard
 
Join Date: Jun 2012
Posts: 25
Thanked 0 Times in 0 Posts
Default

Ok, removed ~/.Xauthority ~/.Xresources and ~/.Xdefaults and now it all works fine. The last two files I had created to try and change the cursor theme (without success), I'm not sure they were related, so I'm guessing removing .Xauthority did it.
Reply With Quote
  #5   (View Single Post)  
Old 11th July 2012
caravel caravel is offline
Port Guard
 
Join Date: Jun 2012
Posts: 25
Thanked 0 Times in 0 Posts
Default

Well it's fixed but not that fixed...

The lag has cleared up, but the mouse still does not work in X. Oddly enough however, if I CTRL+ALT+F1 and CTRL+C the x server and restart it, the mouse begins to works normally - odd...

Anyone else had this problem?
Reply With Quote
  #6   (View Single Post)  
Old 12th July 2012
caravel caravel is offline
Port Guard
 
Join Date: Jun 2012
Posts: 25
Thanked 0 Times in 0 Posts
Default

Ok, I think it's really solved this time...

moused, which I wasn't using anyway seems to have been the root cause. Disabled it in /etc/rc.conf and now all is well.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeBSD Complete ports thaw after ports freeze for 7.3 Release J65nko News 0 24th March 2010 11:46 PM
Anyone else getting ./configure failures since libtool was upgraded? TerryP FreeBSD Ports and Packages 0 22nd August 2009 06:06 AM
Reboot loop on 7.0 upgraded to 7.1 EricM FreeBSD Installation and Upgrading 3 25th March 2009 04:25 AM
CD/DVD burner becomes unresponsive after burncd dewarrn1 FreeBSD General 2 23rd October 2008 01:45 AM
Anyone upgraded from Apache 1.3 to 2.2? windependence FreeBSD Ports and Packages 1 15th July 2008 04:04 PM


All times are GMT. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick