DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 1st May 2012
looop looop is offline
Real Name: Lars Nielsen
New User
 
Join Date: Apr 2010
Location: Denmark
Posts: 7
Thanked 0 Times in 0 Posts
Default GHC + Gnome = no go - It act like it is not installed

Hey I am using FVWM as standard GUI on my OpenBSD system and under FVWM I installed GHC, and enjoyed it, but then a girlfriend need to borrow my computer and I installed Gnome, 'cause that is what she is use to.
But we discovered a problem when we in Gnome tries: ghc or ghci in both Gnome Terminal / RXVT / XTerm we get unknown command.
Then we tried booting up in FVWM and no problem with the command, then for testing we installed OpenBox and there was not a problem.
Can anyone explain what is wrong?
I installed GHC with:
Code:
pkg_add -i -vv ghc
Reply With Quote
  #2   (View Single Post)  
Old 1st May 2012
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,687
Thanked 214 Times in 189 Posts
Default

From your problem description, it sounds like the $PATH environment variable is unset or not set correctly. By default, ghc and ghci should be found in /usr/local/bin, and that does not appear to be in $PATH at the time you attempt to issue the command.

I'm not a Gnome user; if you use Google with "gnome" and "$path" as keywords there are plenty of hits and you may find a fix on the first page.
Reply With Quote
  #3   (View Single Post)  
Old 2nd May 2012
looop looop is offline
Real Name: Lars Nielsen
New User
 
Join Date: Apr 2010
Location: Denmark
Posts: 7
Thanked 0 Times in 0 Posts
Default

thank you very much
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pre-installed Groups: What are they for? Greg_Morgan OpenBSD General 5 11th October 2009 01:05 AM
Listing of installed packages cyril OpenBSD Packages and Ports 2 9th June 2009 01:24 AM
Installed 4.3 & No GUI warriors OpenBSD General 24 14th August 2008 11:28 AM
Has anyone installed mod_perl erehwon OpenBSD Packages and Ports 5 23rd June 2008 08:11 PM
Cannot get new installed card to ping other machine Johnny2Bad FreeBSD Installation and Upgrading 2 10th June 2008 08:54 PM


All times are GMT. The time now is 10:18 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick