DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 7th June 2008
AndreyS AndreyS is offline
New User
 
Join Date: Jun 2008
Posts: 1
Thanked 0 Times in 0 Posts
Default pfsense wireless AP - lost packets

Hi,

I'm trying to setup wireless AP using pfSense (which is based on FreeBSD 6.2). I have Win2000 laptop, which connects to my existing Linksys AP without any problems. But when I try to connect to FreeBSD it cannot get IP address.

When I run tcpdump on FreeBSD side and wireshark on W2K I see that association is established, then W2K sends DHCP Discover packet, which reaches FreeBSD. FreeBSD answers with DHCP Offer but I never see it on W2K side.

I realize this is not exactly FreeBSD question, but provided the same W2K machine can connect to another AP I suspect some misconfiguration on FreeBSD side. But I don't understand what to look for.

I asked this question on pfSense forum but didn't get any answer. Also I tried to disable firewall but it didn't help. Anyway if I understand this correctly I wouldn't see this packet in tcpdump if it was blocked by a firewall.

I use PCChips motherboard (Via C3 based) and Edimax EW-7128g wireless card in hostap mode. W2K machine has D-Link DWL-650 Wireless Cardbus Adapter, 802.11b.

Code:
ral0: <Ralink Technology RT2500> mem 0xf3ffc000-0xf3ffdfff irq 11 at device 9.0 on pci0
ral0: MAC/BBP RT2560 (rev 0x04), RF RT2525
Code:
# ifconfig -v ral0
ral0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2290
        inet6 fe80::20e:2eff:fe57:b754%ral0 prefixlen 64 scopeid 0x2
        inet 192.168.44.1 netmask 0xffffff00 broadcast 192.168.44.255
        ether xx:xx:xx:xx:xx:xx
        media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
        status: associated
        ssid Xxxxxx channel 2 (2417) bssid xx:xx:xx:xx:xx:xx
        authmode WPA1+WPA2/802.11i privacy MIXED deftxkey 3
        TKIP 2:128-bit
        TKIP 3:128-bit powersavemode OFF powersavesleep 100 txpowmax 100
        txpower 99 rtsthreshold 2346 mcastrate 1 fragthreshold 2346 bmiss 7
        -pureg protmode RTSCTS -wme -burst ssid SHOW -apbridge dtimperiod 1
        bintval 100 -countermeasures
What could be the problem?

Thank you!

Last edited by AndreyS; 7th June 2008 at 06:30 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD, vpnc and packets forwarding problems Tritone OpenBSD General 3 2nd July 2009 09:59 PM
vr0: rx packet lost tutosun FreeBSD General 4 13th September 2008 10:13 AM
Lost posts graudeejs Feedback and Suggestions 5 3rd August 2008 02:59 PM
Redirecting ESP packets ales OpenBSD Security 2 15th June 2008 09:13 PM
IPF: Packets Out Of Window bram85 FreeBSD Security 9 2nd June 2008 04:09 PM


All times are GMT. The time now is 10:36 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick