DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 3rd June 2008
disappearedng disappearedng is offline
Shell Scout
 
Join Date: May 2008
Posts: 128
Thanked 0 Times in 0 Posts
Default Enable root logins and solving display issues?

Hi
When I try to login as root in the default KDE graphical login manager, I get the following:
Root logins are not allowed.

I tried doing the following command to access network-admin
"
su
/usr/X11R6/bin/xhost +
network-admin
"

but I got the following error:
xhost: unable to open display ""

What is wrong? I came from Linux so is there some sort of sudo that I could use to adjust settings in my Gnome desktop environment?
Reply With Quote
  #2   (View Single Post)  
Old 3rd June 2008
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Old man from scene 24
 
Join Date: Apr 2008
Location: Eindhoven, Netherlands
Posts: 2,080
Thanked 198 Times in 156 Posts
Default

Run xhost as user, not as root.
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote
  #3   (View Single Post)  
Old 3rd June 2008
TerryP's Avatar
TerryP TerryP is offline
Arp Constable
 
Join Date: May 2008
Location: USofA
Posts: 1,547
Thanked 112 Times in 104 Posts
Default

KDE, having some concept of security has root logins disabled by default.

You have to edit the configuration file and set AllowRootLogins to allow it, I think the file is /usr/local/share/config/kdm/kdmrc on FreeBSD (assuming the usual install location of /usr/local)


Running xhost + on your active session will only open the doors of your x server to the whole wide world or something like that >_>.


You can enable root to launch GUI programs on your currently logged in users display via xhost or kdesu.

kdesu programname -> launches a login prompt and then starts programname.

There is a GTK equivalent some where, gtksudo or something like that. The run dialog in kde can do this as well, and gnome as well probably: if there is a run dialog in gnome that is.
__________________
My Journal

Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''.

Last edited by TerryP; 3rd June 2008 at 11:33 PM. Reason: xhost notes & kdesu
Reply With Quote
  #4   (View Single Post)  
Old 4th June 2008
disappearedng disappearedng is offline
Shell Scout
 
Join Date: May 2008
Posts: 128
Thanked 0 Times in 0 Posts
Default

What is the equivalent of this for my GNOME desktop environment?

when I run xhost not being the root, I get the error:
"
unable to open display ""
"

What should I do to configure my video settings? I hear that you can do this using the set command.
But when I use env
i do not get a DISPLAY variable on my screen so I don't really know how I could go about this.

Thanks a lot guys.
Reply With Quote
  #5   (View Single Post)  
Old 4th June 2008
disappearedng disappearedng is offline
Shell Scout
 
Join Date: May 2008
Posts: 128
Thanked 0 Times in 0 Posts
Default

To be precise,
When I do the following

xhost +
su
network-admin => You are not allowed to access the system configuration
kdesu network-admin => You are not allowed to access the system configuration

The error message is
"
Liboobs-warning failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

OObsSession object hasn't connected to the bus cannot register OobsObject

Could send message, OobsSession hasn't connected to the bus

OObssession object hjasnt connected to the bus cannot register OobsObject

Liboobs-CRITICAL oobs_session_get_platform assertion 'priv->connection != NULL ' failed.

"

What is the meaning of this?

Last edited by disappearedng; 4th June 2008 at 02:44 AM.
Reply With Quote
  #6   (View Single Post)  
Old 7th June 2008
phoenix's Avatar
phoenix phoenix is offline
Risen from the ashes
 
Join Date: May 2008
Posts: 699
Thanked 90 Times in 81 Posts
Default

Install sudo (install it as root, then configure it using visudo to enable the %wheel line, and add your user to the wheel group). Then you don't have to mess around with any of this.

Login to X as a normal user. Open a terminal. Run "$ sudo /path/to/app It will ask for your password, then run the app as root. Simple as pie.

There's also gtksudo, gksudo, and kdesudo apps if you need a GUI method for doing the same.
__________________
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HOW do I ENABLE the wireless device?? bforest FreeBSD General 2 30th January 2009 05:54 PM
enable shutdown/reboot xfce4 rex FreeBSD General 16 17th October 2008 02:19 PM
enable telnet access c0mrade Other BSD and UNIX/UNIX-like 3 28th September 2008 10:56 PM
Enable jumbo frames Seb74 OpenBSD General 10 30th June 2008 05:10 PM
boot bug with USB enable nORKy FreeBSD Installation and Upgrading 5 12th June 2008 04:56 PM


All times are GMT. The time now is 02:53 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick