DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 20th August 2012
VoX VoX is offline
New User
 
Join Date: Aug 2012
Posts: 1
Thanked 0 Times in 0 Posts
Default OpenBSD & IP Forwarding & IP Failover

Hello,

It's nice to find a forum about BSD, I hope I will find a solution to my problem...
First, sorry for my english.

I have a dedicated server with ESX 5 running.
1 Public IP, for the ESX.

I have install, for testing, two virtual OpenBSD
The first one, with 2 networks interfaces.
The second with only one network interface

The goal is to run the first BSD as a FW with IP Forwarding.
It as 2 networks interfaces,
em0 ---> IP Failover with virtual Mac address relied to internet
em1 ---> Local network 192.168.1.1

The second BSD
em0 ---> 192.168.1.2

As you can imagine, i want to add several server connected to a local network with a internet connection through the FW OpenBSD with the 2 networks interface..

I already did that, but with real physical server, and it was working well.

Now, with virtual server it do not work

My first problem was to configure on the FW a gateway that is different from the IP Failover subnet.
But i finally did it like that :
route add -host <<IP_gateway>> -link em0 -iface
route add default -ifa <<Failover_IP>> <<IP_gateway>>

And it work, I can ping any internet IP from the FW
I configure the em1 with 192.168.1.1
I activate ipv4 forwarding in sysctl.conf
I had translation rules into pf.conf and pass all simple rules.

From the second BSD server, which has only one interface 192.168.1.2, I can ping the em1 interface from the FW (192.168.1.1)
But I can't access to internet

It seems the IP Forwarding doesn't work.
Is it because on the FW the default gateway is not in the same subnet than the em0 IP address ?

If someone had any idea about what is happening here ?
Sorry if i'm not clear, I you need more information, just ask !

Thanks !
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trunk failover issue toxictrash OpenBSD General 5 26th September 2011 10:00 AM
Lagg failover on FreeBSD 7.0 Dell 1950/Broadcom 5708 NICs rfranzke FreeBSD General 4 14th September 2010 08:06 PM
OpenBSD, vpnc and packets forwarding problems Tritone OpenBSD General 3 2nd July 2009 09:59 PM
x11 forwarding over ssh not working kasse OpenBSD General 14 23rd December 2008 02:21 PM
freeBSD router running openospfd with failover using ifstated dk_netsvil Guides 0 21st May 2008 05:26 PM


All times are GMT. The time now is 04:01 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick