DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 28th August 2012
sw2wolf sw2wolf is offline
λ programmer
 
Join Date: Mar 2012
Location: China
Posts: 89
Thanked 0 Times in 0 Posts
Default Why doesnot OpenBSD run /etc/profile and ~/.profile ?

Both /etc/profile and ~/.profile work ok before using tmux . After executing tmux in ~/.xsession, it seems OpenBSD donot run /etc/profile and ~/.profile.
Code:
$tail ~/.xsession
...
xterm -e ~/bin/tmuxz &
exec /usr/local/bin/dwm

$cat ~/bin/tmuxz
#!/bin/sh

cmd=$(which tmux)
session=$USER@$HOSTNAME

if [ -z $cmd ]; then
  echo "You need to install tmux."
  exit 1
fi

$cmd has -t $session

if [ $? != 0 ]; then
$cmd new -d -n work -s $session "ksh"
  $cmd splitw -v -p 65 -t $session "ksh"
  $cmd select-pane -t 1
fi

$cmd att -t $session
Sincerely!
Reply With Quote
  #2   (View Single Post)  
Old 28th August 2012
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,709
Thanked 214 Times in 189 Posts
Default

You require a login shell. The tmux(1) man page discusses login shells in four places. You should test them all. You might start with the option I've highlighted, since the man page says it is necessary.
Code:
     -c shell-command
                   Execute shell-command using the default shell.  If
                   necessary, the tmux server will be started to retrieve the
                   default-shell option.  This option is for compatibility
                   with sh(1) when tmux is used as a login shell.
Code:
     -l            Behave as a login shell.  This flag currently has no effect
                   and is for compatibility with other shells when using tmux
                   as a login shell.
Code:
             default-command shell-command
                     Set the command used for new windows (if not specified
                     when the window is created) to shell-command, which may
                     be any sh(1) command.  The default is an empty string,
                     which instructs tmux to create a login shell using the
                     value of the default-shell option.
Code:
             default-shell path
                     Specify the default shell.  This is used as the login
                     shell for new windows when the default-command option is
                     set to empty, and must be the full path of the
                     executable.  When started tmux tries to set a default
                     value from the first suitable of the SHELL environment
                     variable, the shell returned by getpwuid(3), or /bin/sh.
                     This option should be configured when tmux is used as a
                     login shell.
Reply With Quote
  #3   (View Single Post)  
Old 28th August 2012
sw2wolf sw2wolf is offline
λ programmer
 
Join Date: Mar 2012
Location: China
Posts: 89
Thanked 0 Times in 0 Posts
Default

I need to add `set-option -g default-shell /bin/ksh` to ~/.tmux.conf.


thanks!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD: modify .profile for PS1 and PAGER J65nko Guides 1 20th January 2010 12:17 AM
when and by what is .profile read? kasse FreeBSD General 8 11th September 2008 08:46 AM
working with .profile and history uptonm OpenBSD Security 1 15th August 2008 12:14 PM
Firefox profile not saving tonywob FreeBSD General 4 20th May 2008 12:20 PM


All times are GMT. The time now is 08:31 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick