DaemonForums  

Go Back   DaemonForums > Other Operating Systems > Solaris

Solaris SUN Solaris & OpenSolaris.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 10th November 2012
mgh21 mgh21 is offline
Real Name: Michael Hill
New User
 
Join Date: Aug 2011
Location: Australia
Posts: 7
Thanked 0 Times in 0 Posts
Default OpenSolaris Fails to Start

Hello,

My OpenSolaris system, which I have been running for quite some time, has stopped working. It gets as far as the splash screen with opensolaris, and the bar that goes from left to right. If I press ESC, I can get to a text login screen, and can log in. One thing I note here, is that /export/home is not mounted.
I have a Sony Vaio VGN-BX295VP. There does not seem to be a hardware problem, as I am currently using it having booted off the OpenSolaris CD, and it is running happily like this.

Any ideas?
Reply With Quote
  #2   (View Single Post)  
Old 12th November 2012
vermaden's Avatar
vermaden vermaden is offline
Administrator
 
Join Date: Apr 2008
Location: pl_PL.lodz
Posts: 1,052
Thanked 118 Times in 93 Posts
Default

Have You tried to use some other/older Boot Environment? (assuming that You created any)
__________________
religions, worst damnation of mankind
"If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds

Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”.
vermaden's: links resources deviantart spreadbsd
Reply With Quote
  #3   (View Single Post)  
Old 12th November 2012
mgh21 mgh21 is offline
Real Name: Michael Hill
New User
 
Join Date: Aug 2011
Location: Australia
Posts: 7
Thanked 0 Times in 0 Posts
Default

Thanks, but, no I don´t have any. (Trying to install updates always fails on this system.)
Reply With Quote
  #4   (View Single Post)  
Old 12th November 2012
mgh21 mgh21 is offline
Real Name: Michael Hill
New User
 
Join Date: Aug 2011
Location: Australia
Posts: 7
Thanked 0 Times in 0 Posts
Default

It does seem to be using c8d0p0 as the root disc. Does anyone know how I can find out what part of this it would use as the home directory?
When I run fsck on /dev/dsk/c8d0s0 1 or 2, it tells me bad super block at 16: magic number wrong.
/etc/vfstabs tells me nothing about physical device names.
Reply With Quote
  #5   (View Single Post)  
Old 12th November 2012
gpatrick gpatrick is offline
Shell Scout
 
Join Date: Nov 2009
Posts: 118
Thanked 0 Times in 0 Posts
Default

prtvtoc /dev/rdsk/c8t0d0
Reply With Quote
  #6   (View Single Post)  
Old 16th November 2012
mgh21 mgh21 is offline
Real Name: Michael Hill
New User
 
Join Date: Aug 2011
Location: Australia
Posts: 7
Thanked 0 Times in 0 Posts
Default

Thank-you for the command.

It tells me:

* First Sector Last
* Partition Tag Flags Sector Count Sector Mount Directory
0 2 00 16065 195302205 195318269
2 5 01 0 195318270 195318269
8 1 01 0 16065 16064

Which, I think, means that everything is in one partition on the disc, so my home directory must have been in there somewhere, but I cannot find it now.
Reply With Quote
  #7   (View Single Post)  
Old 16th November 2012
gpatrick gpatrick is offline
Shell Scout
 
Join Date: Nov 2009
Posts: 118
Thanked 0 Times in 0 Posts
Default

The output doesn't look correct because under the Mount column you should have "/" for the 0 (zero) partition. Partition 2 is the whole disk.

If you had separate filesystems, say /opt on slice (partition) 3, then under the Mount column would be /opt and so on for each separate slice and filesystem. Looks like /home was a directory under / because there is only one slice (partition) which is 0 (zero).
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
7 day with OpenSolaris gkontos Solaris 3 2nd December 2009 03:32 PM
OpenSolaris installation issue BlueJayofEvil Solaris 4 19th August 2008 08:12 PM
where all packages OpenSolaris whispersGhost Solaris 15 11th June 2008 09:55 AM
Xfce on OpenSolaris aleunix Solaris 0 4th June 2008 06:23 AM
Help me boot OpenSolaris again! Nobber Solaris 2 14th May 2008 10:49 PM


All times are GMT. The time now is 01:02 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick