DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th May 2008
dctr dctr is offline
Port Guard
 
Join Date: May 2008
Posts: 30
Thanked 0 Times in 0 Posts
Default Flash / nspluginwrapper & linuxpluginwrapper

I am going by

Quote:
nstall the www/linuxpluginwrapper port. This port requires emulators/linux_base which is a large port. Follow the instructions displayed by the port to set up your /etc/libmap.conf correctly! Example configurations are installed into /usr/local/share/examples/linuxpluginwrapper/ directory.

The next step is to install the www/linux-flashplugin7 port. Once the plugin is installed, start your browser, enter aboutlugins in the location bar and press Enter. A list should appear with all the currently available plugins.

If the Flash plugin is not listed, this is, most of time, caused by a missing symlink. As root, run the following commands:

# ln -s /usr/local/lib/npapi/linux-flashplugin/libflashplayer.so \
/usr/local/lib/browser_plugins/
# ln -s /usr/local/lib/npapi/linux-flashplugin/flashplayer.xpt \
/usr/local/lib/browser_plugins/

If you restart your browser the plugin should now appears in the previously mentioned list.

Note: The linuxpluginwrapper only works on the i386™ system architecture.
from the BSD website.

When trying to install linuxpluginwrapper I get

Code:
r00tr00t# cd /usr/ports/www/linux-flashplugin7
r00tr00t# make install clean
===>  Installing for linux-flashplugin-7.0r73
===>   linux-flashplugin-7.0r73 depends on executable: nspluginwrapper - not fou
nd
===>    Verifying install for nspluginwrapper in /usr/ports/www/nspluginwrapper
===>  Installing for nspluginwrapper-0.9.91.5
===>   nspluginwrapper-0.9.91.5 depends on file: /compat/linux/usr/lib/libgtk-x1
1-2.0.so.0 - found
===>   nspluginwrapper-0.9.91.5 depends on file: /usr/local/libdata/xorg/librari
es - found
===>   nspluginwrapper-0.9.91.5 depends on file: /compat/linux/etc/fedora-releas
e - found
===>   nspluginwrapper-0.9.91.5 depends on executable: pkg-config - found
===>   nspluginwrapper-0.9.91.5 depends on file: /usr/local/lib/gio/modules/libg
iofam.so - not found
===>    Verifying install for /usr/local/lib/gio/modules/libgiofam.so in /usr/po
rts/devel/gio-fam-backend
===>  Building for gio-fam-backend-2.16.3
/bin/sh ../../libtool --tag=CC   --mode=link cc -DG_LOG_DOMAIN=\"GLib-GIO\" -I..
/.. -I../../glib -I../../gmodule -I../../gio -DG_DISABLE_CAST_CHECKS -DGIO_MODUL
E_DIR=\"/usr/local/lib/gio/modules\" -DGIO_COMPILATION -DG_DISABLE_DEPRECATED -O
2 -fno-strict-aliasing -pipe  -Wall -export_dynamic -avoid-version -module -no-u
ndefined -export-symbols-regex '^g_io_module_(load|unload)' -L/usr/local/lib -li
ntl -o libgiofam.la -rpath /usr/local/lib/gio/modules libgiofam_la-fam-helper.lo
 libgiofam_la-fam-module.lo libgiofam_la-gfamdirectorymonitor.lo libgiofam_la-gf
amfilemonitor.lo  -lgio-2.0 -lgobject-2.0 -lglib-2.0  -lfam
rm -fr  .libs/libgiofam.exp
generating symbol list for `libgiofam.la'
/usr/bin/nm -B  .libs/libgiofam_la-fam-helper.o .libs/libgiofam_la-fam-module.o
.libs/libgiofam_la-gfamdirectorymonitor.o .libs/libgiofam_la-gfamfilemonitor.o
| sed -n -e 's/^.*[     ]\([ABCDGIRSTW][ABCDGIRSTW]*\)[         ][      ]*\([_A-
Za-z][_A-Za-z0-9]*\)$/\1 \2 \2/p' | /usr/bin/sed 's/.* //' | sort | uniq > .libs
/libgiofam.exp
/usr/bin/grep -E -e "^g_io_module_(load|unload)" ".libs/libgiofam.exp" > ".libs/                                                                                               libgiofam.expT"
mv -f ".libs/libgiofam.expT" ".libs/libgiofam.exp"
cc -shared  .libs/libgiofam_la-fam-helper.o .libs/libgiofam_la-fam-module.o .lib                                                                                               s/libgiofam_la-gfamdirectorymonitor.o .libs/libgiofam_la-gfamfilemonitor.o  -Wl,                                                                                               --rpath -Wl,/usr/local/lib -Wl,--rpath -Wl,/usr/local/lib -L/usr/local/lib /usr/                                                                                               local/lib/libintl.so -lgio-2.0 /usr/local/lib/libgobject-2.0.so /usr/local/lib/l                                                                                               ibglib-2.0.so /usr/local/lib/libfam.so  -Wl,-soname -Wl,libgiofam.so -Wl,-retain                                                                                               -symbols-file -Wl,.libs/libgiofam.exp -o .libs/libgiofam.so
/usr/bin/ld: cannot find -lgio-2.0
gmake: *** [libgiofam.la] Error 1
*** Error code 2

Stop in /usr/ports/devel/gio-fam-backend.
*** Error code 1

Stop in /usr/ports/www/nspluginwrapper.
*** Error code 1

Stop in /usr/ports/www/linux-flashplugin7.
*** Error code 1

Stop in /usr/ports/www/linux-flashplugin7.
Can anyone help me out here?


Nevermind, I am going to try gnash, if that fails I'll install windows firefox, wine and then flash9. still suggestions are helpful.

Thank you,

dctr

Last edited by dctr; 19th May 2008 at 03:01 AM.
Reply With Quote
  #2   (View Single Post)  
Old 19th May 2008
18Googol2's Avatar
18Googol2 18Googol2 is offline
Real Name: whoami
Spam Deminer
 
Join Date: Apr 2008
Location: pwd
Posts: 283
Thanked 20 Times in 18 Posts
Default

Ah, libgiofam again. Have a look at the similar thread, particularly my post (number 8)

http://daemonforums.org/showthread.php?t=365
__________________
The power of plain text? It can control an entire OS
Reply With Quote
  #3   (View Single Post)  
Old 19th May 2008
dctr dctr is offline
Port Guard
 
Join Date: May 2008
Posts: 30
Thanked 0 Times in 0 Posts
Default

Thank you, that worked to getting the linux-flashplugin7 installed, but does me no good as of yet.

I am now getting

Code:
===>  linuxpluginwrapper-20051113_8 doesn't support ELF symbol versioning, yet..
*** Error code 1
when I execute

Code:
r00tr00t# cd /usr/ports/www/linuxpluginwrapper
r00tr00t# make install clean
Anyone got an answer ;x
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash in FBSD 7.2 Mantazz FreeBSD Ports and Packages 8 5th October 2009 05:37 AM
Flash 10 Oko NetBSD Package System (pkgsrc) 14 9th June 2009 02:23 PM
nspluginwrapper disappearedng FreeBSD General 1 13th September 2008 09:25 PM
firefox, linux-flash, nspluginwrapper, and youtube? neurosis FreeBSD Ports and Packages 16 15th August 2008 06:46 AM
Flash syrushcw FreeBSD Ports and Packages 1 16th May 2008 02:24 PM


All times are GMT. The time now is 09:06 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick