DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 16th February 2013
tehsean tehsean is offline
Custom User
 
Join Date: Aug 2010
Posts: 22
Thanked 1 Time in 1 Post
Default sndio and USB headphones

I have a set of Logitech USB headphones that I am trying to get working. They are detected without issue, and attach to /dev/audio1, /dev/sound1, etc.

I can change links on /dev/audio, /dev/sound, /dev/mixer and /dev/audioctl, and testing the headphones with " cat /dev/urandom > /dev/audio " work. I hear static on the headphones and not the speakers.

Anything that has to do with sndio / sndiod will not play on the headphones.

I have attempted to add the new audio device to sndiod using:
sndiod -f /dev/audio
and
sndiod -f /dev/audio1

And then tried to reference that device in the audio programs I use, for example ogg123:
ogg123 -d sndio -o rsnd:0 ..
ogg123 -d sndio -o snd:0 ...
ogg123 -d sndio -o /dev/audio ...

and many permutations of the above. None of these play on the headphones; they all play on the default speakers. It looks like sndiod doesn't recognize the new headset, even though I've linked it to the default audio device.

Reading the man page on aucat / sndiod, I can't find a way to list the current handles it has loaded. I'm pretty sure it's an issue with how sndiod is configured, but I am lost as to what to do now. Any pointers as to where to look would help me out tremendously.
Reply With Quote
  #2   (View Single Post)  
Old 17th February 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,610
Thanked 214 Times in 189 Posts
Default

Have you been able to use the headset with ogg directly, without sndiod?

An afterthought:

Your snd device names in your ogg123 commands do not appear (to me) to conform the to device name conventions as described in sndio(7).
Reply With Quote
  #3   (View Single Post)  
Old 17th February 2013
tehsean tehsean is offline
Custom User
 
Join Date: Aug 2010
Posts: 22
Thanked 1 Time in 1 Post
Default

Chalk this up to misinterpretation of the man page for ogg123. I revisited this issue with a clear head and the advice of jggimi.

The ogg123 documentation lists the sndio driver options as:
Quote:
sndio OpenBSD SNDIO live output driver. Options:

dev:value
Specifies audio device to use for playback.
I assumed that the device was rsnd or snd and the value was the number instance, and tried the ways shown above. Totally wrong.

In my case, with my headset detected and attached as /dev/audio1, the correct syntax was:
Code:
ogg123 -d sndio -o dev:rsnd/1 http://to.stream.ogg
FWIW, I could not get the sndio driver to use 'snd' devices as described in the sndio documentation, only the raw devices 'rsnd'.

Thanks jggimi for your help with this.
Reply With Quote
  #4   (View Single Post)  
Old 18th February 2013
backrow backrow is offline
Real Name: Anthony J. Bentley
Shell Scout
 
Join Date: Jul 2009
Location: Albuquerque, NM
Posts: 116
Thanked 10 Times in 4 Posts
Default

I have a pair of USB headphones:

Code:
uaudio0 at uhub2 port 1 configuration 1 interface 0 "Logitech Logitech USB Heads
et" rev 2.00/10.13 addr 2
uaudio0: audio rev 1.00, 7 mixer controls
audio1 at uaudio0
All audio gets routed through them with rc.conf.local(8) of:

Code:
sndiod_flags="-f rsnd/1"
__________________
Many thanks to the forum regulars who put time and effort into helping others solve their problems.

Last edited by backrow; 18th February 2013 at 05:22 AM.
Reply With Quote
Reply

Tags
rsnd, snd, sndiod, usb sound

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Headphones versus built-in speakers ddrx OpenBSD General 6 28th November 2009 05:07 PM
Audio & Headphones JMJ_coder General Hardware 3 10th November 2008 05:21 PM
Sound in headphones buba OpenBSD General 3 11th June 2008 01:39 PM


All times are GMT. The time now is 12:53 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick