DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD General

OpenBSD General Other questions regarding OpenBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 16th May 2013
flit flit is offline
New User
 
Join Date: May 2013
Posts: 8
Thanked 0 Times in 0 Posts
Default Slow SSH login

Hi all,

I have OpenBSD 5.1 installed in VMware and when I try to
login into OpenBSD via SSH from a Windows 7 machine, it is
taking almost 2 minutes before the password is prompted.

The error message that I am receiving is:
Server refused keyboard-interactive authentication

Can anyone help me fix this issue?

Thanks in advance.
Reply With Quote
  #2   (View Single Post)  
Old 16th May 2013
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,431
Thanked 214 Times in 189 Posts
Default

Hello, and welcome!

Slow initial login via SSH is a very common issue, so common it is described in the OpenBSD FAQ, section 8.22: Reverse DNS, or Why is it taking so long for me to log in?

While there is no guarantee that your DNS configuration is the problem... it is a 99%+ probability.

See if the /etc/hosts recommendation in the FAQ resolves the problem for you.
Reply With Quote
  #3   (View Single Post)  
Old 16th May 2013
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,116
Thanked 182 Times in 149 Posts
Default

The delay of 2 minutes is caused because the OpenBSD SSH does a double reverse name lookup of the IP address that is connecting to it. See https://en.wikipedia.org/wiki/Double-reverse_DNS

There are several ways of fixing this:
  • The easy lazy insecure coward method:

    Disable this lookup by changing #UseDNS yes into UseDNS no In /etc/ssh/sshd_config
  • Make the double reverse DNS lookup work by:

    1. Configuring a local DNS server, which is not that trivial if you never have done it before
    2. Add a an entry to the OpenBSD /etc/hosts like this:

      Code:
      192.168.222.20  hercules.utp.xnet hercules
      See hosts(5) for a description of that file.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #4   (View Single Post)  
Old 16th May 2013
flit flit is offline
New User
 
Join Date: May 2013
Posts: 8
Thanked 0 Times in 0 Posts
Default

Thanks for the replies. It was a DNS issue. I added some lines to /etc/hosts and the issue has been resolved.

Last edited by flit; 16th May 2013 at 08:39 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anonymous Ftp is too slow daemonfowl OpenBSD General 25 4th August 2012 12:50 AM
Does anyone know why Gnome is so slow on BSD? TerryP General software and network 11 27th August 2010 06:06 PM
Why is FreeBSD dd so slow? sharris FreeBSD General 10 18th June 2010 08:33 AM
slow io from hdd knasbas OpenBSD General 3 25th July 2009 02:51 AM
How to set up ssh login cssgalactic FreeBSD General 12 28th June 2008 06:00 PM


All times are GMT. The time now is 06:47 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick