DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 27th July 2013
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default mplayer in -current denies full screen

My favorite video player mplayer in -current denies me full screen ..
For the time being I'm using kaffeine for a fullscreen.
Reply With Quote
  #2   (View Single Post)  
Old 27th July 2013
ocicat ocicat is offline
Administrator
 
Join Date: Apr 2008
Posts: 2,833
Thanked 190 Times in 160 Posts
Default

Quote:
Originally Posted by daemonfowl View Post
My favorite video player mplayer in -current denies me full screen ..
For the time being I'm using kaffeine for a fullscreen.
Please provide the output of the following at the very minimum:

$ sysctl kern.version

Stating that applications aren't working in -current is far too vague a description. It seems that we ask for clarification time after time after time...


Last edited by ocicat; 27th July 2013 at 04:12 AM. Reason: clarity
Reply With Quote
  #3   (View Single Post)  
Old 27th July 2013
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default

I'm sorry

Code:
kern.version=OpenBSD 5.4 (GENERIC.MP) #38: Sun Jul 21 19:20:15 MDT 2013
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC.MP
dmesg :
Code:
OpenBSD 5.4 (GENERIC.MP) #38: Sun Jul 21 19:20:15 MDT 2013
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Genuine Intel(R) CPU T2250 @ 1.73GHz ("GenuineIntel" 686-class) 1.73 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,SSE3,MWAIT,EST,TM2,xTPR,PDCM,PERF
real mem  = 2145447936 (2046MB)
avail mem = 2098933760 (2001MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 02/13/07, BIOS32 rev. 0 @ 0xfd390, SMBIOS rev. 2.33 @ 0xe3810 (25 entries)
bios0: vendor Acer version "V3.50" date 02/13/2007
bios0: Acer Aspire 5610
acpi0 at bios0: rev 0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC HPET MCFG SLIC DBGP APIC BOOT SSDT SSDT SSDT SSDT SSDT
acpi0: wakeup devices PXS1(S4) PXS2(S4) BCOL(S4) PXS4(S4) USB1(S3) USB2(S3) USB3(S3) USB4(S3) USB7(S3) LANC(S5) MODM(S3) AZAL(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 132MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Genuine Intel(R) CPU T2250 @ 1.73GHz ("GenuineIntel" 686-class) 1.73 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,SSE3,MWAIT,EST,TM2,xTPR,PDCM,PERF
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 2, remapped to apid 1
acpihpet0 at acpi0: 14318179 Hz
acpimcfg0 at acpi0 addr 0xe0000000, bus 0-255
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (PEGP)
acpiprt2 at acpi0: bus 2 (RP01)
acpiprt3 at acpi0: bus 3 (RP02)
acpiprt4 at acpi0: bus 4 (RP03)
acpiprt5 at acpi0: bus 5 (RP04)
acpiprt6 at acpi0: bus 6 (PCIB)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C2, C1, PSS
acpicpu1 at acpi0: C3, C2, C1, PSS
acpitz0 at acpi0: critical temperature is 127 degC
acpitz1 at acpi0: critical temperature is 85 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: SLPB
acpibtn2 at acpi0: PWRB
acpibat0 at acpi0: BAT1 model "GC86503SY90 " type Lion oem "SONY "
acpiac0 at acpi0: AC unit online
acpivideo0 at acpi0: VGA_
acpivideo1 at acpi0: GFX0
bios0: ROM list: 0xc0000/0xe000 0xce000/0x1800 0xe0000/0x1800! 0xe3800/0x800!
cpu0: Enhanced SpeedStep 1729 MHz: speeds: 1733, 1333, 1067, 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82945GM Host" rev 0x03
ppb0 at pci0 dev 1 function 0 "Intel 82945GM PCIE" rev 0x03: apic 1 int 16
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "NVIDIA GeForce 7300 Go" rev 0xa1
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x02: msi
azalia0: codecs: Realtek ALC883, Conexant/0x2c06, using Realtek ALC883
audio0 at azalia0
ppb1 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x02: apic 1 int 17
pci2 at ppb1 bus 2
ppb2 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x02: apic 1 int 16
pci3 at ppb2 bus 3
ppb3 at pci0 dev 28 function 2 "Intel 82801GB PCIE" rev 0x02: apic 1 int 18
pci4 at ppb3 bus 4
ppb4 at pci0 dev 28 function 3 "Intel 82801GB PCIE" rev 0x02: apic 1 int 19
pci5 at ppb4 bus 5
wpi0 at pci5 dev 0 function 0 "Intel PRO/Wireless 3945ABG" rev 0x02: msi, MoW2, address 00:19:d2:28:eb:bc
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x02: apic 1 int 23
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x02: apic 1 int 19
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x02: apic 1 int 18
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x02: apic 1 int 16
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x02: apic 1 int 23
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb5 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xe2
pci6 at ppb5 bus 6
bce0 at pci6 dev 1 function 0 "Broadcom BCM4401B1" rev 0x02: apic 1 int 21, address 00:16:d4:d2:d6:5e
bmtphy0 at bce0 phy 1: BCM4401 10/100baseTX PHY, rev. 0
cbb0 at pci6 dev 4 function 0 "ENE CB-712 CardBus" rev 0x10: apic 1 int 16
"ENE Memory Stick" rev 0x01 at pci6 dev 4 function 1 not configured
sdhc0 at pci6 dev 4 function 2 "ENE SD Controller" rev 0x01: apic 1 int 17
sdmmc0 at sdhc0
"ENE Flash memory" rev 0x01 at pci6 dev 4 function 3 not configured
"ENE SD/MMC" rev 0x01 at pci6 dev 4 function 4 not configured
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 7 device 0 cacheline 0x8, lattimer 0x20
pcmcia0 at cardslot0
ichpcib0 at pci0 dev 31 function 0 "Intel 82801GBM LPC" rev 0x02: PM disabled
pciide0 at pci0 dev 31 function 2 "Intel 82801GBM SATA" rev 0x02: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <TOSHIBA MK5076GSX>
wd0: 16-sector PIO, LBA48, 476940MB, 976773168 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <Optiarc, DVD RW AD-7590A, 1.04> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x02: apic 1 int 19
iic0 at ichiic0
spdmem0 at iic0 addr 0x52: 2GB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
usb1 at uhci0: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb2 at uhci1: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci2: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci3: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pms0: Synaptics touchpad, firmware 6.2
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
uvideo0 at uhub0 port 4 configuration 1 interface 0 "Logitech product 0x09b0" rev 2.00/0.06 addr 2
video0 at uvideo0
vscsi0 at root
scsibus1 at vscsi0: 256 targets
softraid0 at root
scsibus2 at softraid0: 256 targets
root on wd0a (12b0d0062e20d2c9.a) swap on wd0b dump on wd0b
Reply With Quote
  #4   (View Single Post)  
Old 28th July 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,431
Thanked 214 Times in 189 Posts
Default

Quote:
Originally Posted by daemonfowl View Post
My favorite video player mplayer in -current denies me full screen ...
You won't get any assistance with this unless you provide a better explanation.

What do you mean by "denies"? Why haven't you posted your mplayer video options requested/selected? Why haven't you posted a log from mplayer?

If you wan't help, please think about what it is you are asking. "Vir prudens non contraventum mingit."
Reply With Quote
  #5   (View Single Post)  
Old 29th July 2013
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default

gratias agimus tibi .. magister jggimi !
As soon as I get to the box again I'll post that.
Reply With Quote
  #6   (View Single Post)  
Old 30th July 2013
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default

Acer Aspire 5610 running -current
Code:
MPlayer SVN-r35910 (C) 2000-2013 MPlayer Team

Playing Kozure.okami.1x51.Adjutant.Zweier.Fuhrer.avi.
libavformat version 54.63.104 (external)
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [XVID]  512x384  12bpp  25.000 fps  937.0 kbps (114.4 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.4.1 (build 2178/release)
Load subtitles in ./
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 54.92.100 (external)
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, floatle, 108.4 kbit/3.53% (ratio: 13554->384000)
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3 audio)
==========================================================================
AO: [sndio] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0x2035f7c0]Invalid and inefficient vfw-avi packed B frames detected
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [x11] 512x384 => 512x384 Planar YV12 
[swscaler @ 0x21d91ca0]using unscaled yuv420p -> bgra special converter
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
A:  81.8 V:  81.7 A-V:  0.040 ct: -0.056 2044/2044  7% 38%  1.9% 30 0
$ xvinfo
Code:
X-Video Extension version 2.2
screen #0
 no adaptors present
Reply With Quote
  #7   (View Single Post)  
Old 30th July 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,431
Thanked 214 Times in 189 Posts
Default

A suggestion:
Code:
man mplayer
/VIDEO OUTPUT DRIVERS
You will learn how to use the -vo option to select one or more mplayer video output drivers. You do not have Xv -- the X-Video extension -- available on this system, so mplayer has instead used the default x11 driver, which you say "denies full screen".

You may find other video output drivers work better than x11 for you.

Here's the list of video output drivers included in mplayer 20130214p4:
Code:
$ mplayer -vo help
MPlayer SVN-r35910 (C) 2000-2013 MPlayer Team
Available video output drivers:
        xv      X11/Xv
        gl_nosw OpenGL no software rendering
        x11     X11 ( XImage/Shm )
        xover   General X11 driver for overlay capable video output drivers
        sdl     SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
        gl      OpenGL
        gl_tiled        X11 (OpenGL) - multiple textures version
        dga     DGA ( Direct Graphic Access V2.0 )
        matrixview      MatrixView (OpenGL)
        null    Null video output
        mpegpes MPEG-PES file
        yuv4mpeg        yuv4mpeg output for mjpegtools
        png     PNG file
        jpeg    JPEG file
        gif89a  animated GIF output
        tga     Targa output
        pnm     PPM/PGM/PGMYUV file
        md5sum  md5sum of each frame
        mng     MNG file
$

Last edited by jggimi; 30th July 2013 at 07:00 PM. Reason: added link
Reply With Quote
  #8   (View Single Post)  
Old 30th July 2013
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default

shame on me .. sdl works fine ..
Thank you jggimi !
Reply With Quote
  #9   (View Single Post)  
Old 30th July 2013
daemonfowl daemonfowl is offline
bsdstudent
 
Join Date: Jan 2012
Location: DaemonLand
Posts: 834
Thanked 0 Times in 0 Posts
Default

....

There is no caca flavor for mplayer for OpenBSD and I'd like to watch movies in ascii -cool cli way :-) ..
Could anyone help me achieve this ?

Thanks for all suggestions.

Last edited by daemonfowl; 3rd August 2013 at 03:14 AM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues WIth Mplayer and Vlc sepuku OpenBSD Packages and Ports 21 29th August 2011 03:31 AM
Other New better MPlayer, the MPlayer 2, fork of original MPlayer vermaden News 5 26th March 2011 03:37 PM
/usr is full (OpenBSD 4.5 current) valorisa OpenBSD Packages and Ports 7 10th June 2009 01:28 PM
mplayer-1.0rc2p2-sdl.tgz and mplayer-1.0rc2p2.tgz bsdnewbie999 OpenBSD General 1 21st June 2008 06:34 AM
mplayer volume cannot increase. bsdnewbie999 OpenBSD General 3 19th June 2008 03:16 PM


All times are GMT. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick