DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Installation and Upgrading

OpenBSD Installation and Upgrading Installing and upgrading OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 4th November 2013
karl karl is offline
Real Name: Abu Aufa
Port Guard
 
Join Date: Jul 2008
Location: Malaysia
Posts: 12
Thanked 0 Times in 0 Posts
Default 5.4 amd64 on Thinkpad x200: "render error detected" on booting.

Hi,

Machine:
Lenovo Thinkpad X200 (2.40Ghz)
4Gb RAM

I've just upgraded my 5.3-amd64 to 5.4-amd64 yesterday. Upgrading was ok with no issue. The new framebuffer console is very nice. Good stuff.

Today I booted the machine and noticed this "render error detected" in the dmesg. Attached is "dmesg-error.txt". It stated:
Code:
aps0 at isa0 port 0x1600/31
render error detected, EIR: 0x00000010
  IPEIR: 0x00000000
  IPEHR: 0x00000000
  INSTDONE_0: 0xfffffffe
  INSTDONE_1: 0xffffffff
  INSTDONE_2: 0x00000000
  INSTDONE_3: 0x00000000
  INSTPS: 0x00000000
  ACTHD: 0x00000000
page table error
  PGTBL_ER: 0x00000003
error: [drm:pid0:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
So far no issue while using the machine. Even mplayer a Full HD (1080) mkv file is nice and dandy (except it hangs when trying to skip forward). So I think this is not critical issue. Just want to know if anyone here who have the same issue? Thanks.
Attached Files
File Type: txt dmesg-error.txt (6.5 KB, 16 views)

Last edited by ocicat; 4th November 2013 at 01:31 PM. Reason: Please use [code] & [/code] tags when posting command output.
Reply With Quote
  #2   (View Single Post)  
Old 4th November 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,710
Thanked 214 Times in 189 Posts
Default

I just wanted to point out that if problems do occur, you can disable the inteldrm(4) driver per the Upgrade Guide.
Reply With Quote
  #3   (View Single Post)  
Old 5th November 2013
karl karl is offline
Real Name: Abu Aufa
Port Guard
 
Join Date: Jul 2008
Location: Malaysia
Posts: 12
Thanked 0 Times in 0 Posts
Default

jggimi,

Hi thanks for the info. So far no issue with the X at all. Graphic is much better than 5.3. Just want to know if there's thinkpad user who's got the same error message.

So far it looks like I'm the only one who have this. ack!.
Reply With Quote
Reply

Tags
5.4, amd64, error, openbsd, thinkpad

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Securely booting Linux a "difficult" proposition J65nko News 0 22nd January 2012 04:10 PM
"Can't check filesystem" error after installation sepuku OpenBSD Installation and Upgrading 6 22nd July 2011 10:25 AM
OpenBSD BIGMEM default set to "on" for amd64 rocket357 News 4 6th April 2011 02:36 AM
System stops booting after "GEOM_MIRROR: Force device gm0 start due to timeout." indienick FreeBSD General 1 25th March 2010 09:46 PM
Fixed "xinit" after _7 _8, "how" here in case anyones' "X" breaks... using "nvidia" jb_daefo Guides 0 5th October 2009 09:31 PM


All times are GMT. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick