DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 6th December 2013
harishankar harishankar is offline
Port Guard
 
Join Date: Nov 2011
Posts: 31
Thanked 0 Times in 0 Posts
Default Gnome 3.8 + OpenBSD 5.4 - error on login (GDM)

Installed gnome3 on OpenBSD 5.4, i386 both on my desktop system and on virtualbox on my debian laptop, I get this error on the login screen (See screenshot).

Not sure what the issue here is.

I followed the instructions on the /usr/local/share/doc/pkg-readmes/gnome-*

Screenshots attached.

I am sure hardware 3d is not required to work with Gnome 3 in failsafe/fallback mode. So not sure if the log file is the relevant error. On Debian I was able to install GDM + Gnome 3 on the same desktop system (ATI Rage XL video card) and it had no issues (Except gnome works only in failsafe/fallback mode)
Attached Images
File Type: png openbsd.png (47.5 KB, 184 views)
File Type: png openbsd-screenshot2.png (5.8 KB, 141 views)
Reply With Quote
  #2   (View Single Post)  
Old 6th December 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,717
Thanked 214 Times in 189 Posts
Default

From the pkg-readme for the gnome-3.8.3p0 meta package:
Quote:
GNOME requires a 3D accelerated display.
Reply With Quote
  #3   (View Single Post)  
Old 6th December 2013
harishankar harishankar is offline
Port Guard
 
Join Date: Nov 2011
Posts: 31
Thanked 0 Times in 0 Posts
Default

Hmm... strange that OpenBSD requires 3D acceleration in Gnome. It worked without 3d support under Debian (although in failsafe mode) so I assumed it would be the same in OpenBSD.
Reply With Quote
  #4   (View Single Post)  
Old 6th December 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,717
Thanked 214 Times in 189 Posts
Default

I'm not a Gnome user -- although I've installed and configured it in prior years -- the last was for OpenBSD 5.0 and that was Gnome 2.32.1.

You might try operating it without GDM. Create an .xinitrc that executes gnome-session, and use startx(1) instead of a display manager. You may get different results.
Reply With Quote
  #5   (View Single Post)  
Old 6th December 2013
harishankar harishankar is offline
Port Guard
 
Join Date: Nov 2011
Posts: 31
Thanked 0 Times in 0 Posts
Default

Tried that too. Still fails with the same message.

For some reason the gnome-session-fallback executable is not present in Gnome in OpenBSD, but the same executable exists in my Debian installation.

Probably the same was not ported to OpenBSD?

Addendum: apparently the --failsafe flag in gnome-session is not the same as the fallback mode.

Last edited by harishankar; 6th December 2013 at 04:53 PM.
Reply With Quote
  #6   (View Single Post)  
Old 6th December 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,717
Thanked 214 Times in 189 Posts
Default

I note that in http://callfortesting.org/gnome3/ that the Gnome Shell requires it. Per https://forums.freebsd.org/viewtopic...31797&p=191770 it appears that the initial implementation of Gnome 3 on OpenBSD (and only on OpenBSD) could use Fallback mode, and this was corroborated in the CVS logs for gnome-session on OpenBSD, where patch 1.219 for Gnome 3.6.1 mentions it as going away in the next release: http://www.openbsd.org/cgi-bin/cvswe...ssion/Makefile
Reply With Quote
  #7   (View Single Post)  
Old 6th December 2013
harishankar harishankar is offline
Port Guard
 
Join Date: Nov 2011
Posts: 31
Thanked 0 Times in 0 Posts
Default

Hm... apparently there exists the files in /usr/local/share/gnome-session/sessions/* for the fallback mode in OpenBSD as well.

Maybe I should launch gnome-session with those files instead of the default. will give it a try.
Reply With Quote
  #8   (View Single Post)  
Old 7th December 2013
harishankar harishankar is offline
Port Guard
 
Join Date: Nov 2011
Posts: 31
Thanked 0 Times in 0 Posts
Default

It does appear that gnome-panel is missing in 5.4 which was present in 5.3. This means Gnome on OpenBSD 5.4 does not work in fallback/classic mode.

Unfortunate, since I think that it does exist in Gnome 3.8 (i.e. fallback mode)...
Reply With Quote
  #9   (View Single Post)  
Old 7th December 2013
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,717
Thanked 214 Times in 189 Posts
Default

As far as I can tell (by looking through CVS logs), gnome-panel was replaced by gnome-shell and this transition completed with Gnome 3.8, in March of this year (between 5.3 and 5.4).
Reply With Quote
Old 7th December 2013
harishankar harishankar is offline
Port Guard
 
Join Date: Nov 2011
Posts: 31
Thanked 0 Times in 0 Posts
Default

I read in other forums (mainly Linux based ones) that Gnome 3.8 still has the fallback option

It's a pity that functional and feature rich desktops are depending on 3d hardware acceleration when they could well do without it.

Perhaps Xfce is the only hope. Too bad. I use Gnome regularly on Linux and I was happy to see gnome 3 in OpenBSD as well.

On a related note, I did edit the file /usr/local/share/gnome-session/hardware-compatibility file to enable software rasterizer, and gdm loads (though slowly) but gnome-shell still doesn't. The original error was gone, though.

In my search, I did find this page: https://fedoraproject.org/wiki/Featu...ware_rendering

which seems to be of interest, but it is a Linux focussed article on the topic.
Reply With Quote
Old 7th December 2013
LeFrettchen's Avatar
LeFrettchen LeFrettchen is offline
Marveled user
 
Join Date: Aug 2012
Location: Bronvaux, France
Posts: 108
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by harishankar View Post
Perhaps Xfce is the only hope.
Or any Windows Manager : Lxde, Kde, FluxBox...
__________________
In case of emergency
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
D Bus error while starting gnome jewsofeast OpenBSD Packages and Ports 2 21st November 2010 05:37 AM
error message gnome Sam OpenBSD Packages and Ports 14 21st November 2009 02:05 PM
error code 1 whie make install gnome mtm0 NetBSD General 3 4th September 2009 11:56 AM
Error gnome darken FreeBSD Installation and Upgrading 3 27th July 2008 12:21 PM
porting gnome got samba error. bsdnewbie999 OpenBSD General 2 19th June 2008 02:06 AM


All times are GMT. The time now is 12:26 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick