DaemonForums  

Go Back   DaemonForums > NetBSD > NetBSD Installation and Upgrading

NetBSD Installation and Upgrading Have trouble getting NetBSD on your toaster?

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 5 Days Ago
philo_neo71 philo_neo71 is offline
Port Guard
 
Join Date: Jul 2009
Posts: 24
Thanked 0 Times in 0 Posts
Default how to install gnome

Hi,
i try to install gnome desktop on NetBSD 6.0, i have search to google for install gnome, i found this link http://www.zen-tech.info/2009/12/net...lace-de-gnome/, sorry it is the french's blog but you can translate.

I'm very interesing by the command "pkgin" like "apt-get" for debian distribution !

But the blog are effective to version 5.0 or i'm at 6.0 >> how to found sqlite and pkgin for 6.0 version?


Regards
Philippe
Reply With Quote
  #2   (View Single Post)  
Old 5 Days Ago
darktrym's Avatar
darktrym darktrym is offline
New User
 
Join Date: Feb 2011
Location: Germany
Posts: 9
Thanked 0 Times in 0 Posts
Default

You have three ways to install gnome(meta package):
Reply With Quote
  #3   (View Single Post)  
Old 4 Days Ago
philo_neo71 philo_neo71 is offline
Port Guard
 
Join Date: Jul 2009
Posts: 24
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by darktrym View Post
You have three ways to install gnome(meta package):
Thanks darktrym,
i can do the commands "pkgin install gnome" as root's user, but when i do the startx's command i have a "basic desktop" isn't gnome or gdm, how can i to run gnome ?
I have download 800 mega/bits after do install gnome, i can't found "desktop-gnome" !
Can i do pkg_path a necessary ?


Regards
Philippe
Reply With Quote
  #4   (View Single Post)  
Old 4 Days Ago
darktrym's Avatar
darktrym darktrym is offline
New User
 
Join Date: Feb 2011
Location: Germany
Posts: 9
Thanked 0 Times in 0 Posts
Default

It's a long time ago when i installed gnome. Try to start gnome-session.
Reply With Quote
  #5   (View Single Post)  
Old 2 Days Ago
philo_neo71 philo_neo71 is offline
Port Guard
 
Join Date: Jul 2009
Posts: 24
Thanked 0 Times in 0 Posts
Default

Hi,
It is Ok for AMD64 opteron, gnome start !


On another computer, Blade 1500 Sparc64, i have installed NetBSD 6.1.5,
the command "pkgin" is installed, but when i do : pkgin install gnome or xfce4.
I found to install gnome on sparc64, but no i have errors when i do a startx command !

I using XVR-100 video card with ATI Radeon 7000

this the xorg.conf
Code:
-----------------------------------------------------------------
Xorg.conf
----------------------------------------------------------------

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/X11R7/lib/modules"
        FontPath     "/usr/X11R7/lib/X11/fonts/misc/"
        FontPath     "/usr/X11R7/lib/X11/fonts/TTF/"
        FontPath     "/usr/X11R7/lib/X11/fonts/Type1/"
        FontPath     "/usr/X11R7/lib/X11/fonts/75dpi/"
        FontPath     "/usr/X11R7/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
        Load  "dbe"
        Load  "dri"
        Load  "dri2"
        Load  "extmod"
        Load  "glx"
        Load  "record"
       Load  "shadow"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "Protocol" "wskbd"
        Option      "Device" "/dev/wskbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "wsmouse"
        Option      "Device" "/dev/wsmouse"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        Option       "DPMS"
        VendorName   "IBM"
        ModelName    "E74"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"                   # [<bool>]
        #Option     "SWcursor"                  # [<bool>]
        #Option     "Dac6Bit"                   # [<bool>]
        #Option     "Dac8Bit"                   # [<bool>]
        #Option     "BusType"                   # [<str>]
       #Option     "CPPIOMode"                 # [<bool>]
        #Option     "CPusecTimeout"             # <i>
        #Option     "AGPMode"                   # <i>
        #Option     "AGPFastWrite"              # [<bool>]
        #Option     "AGPSize"                   # <i>
        #Option     "GARTSize"                  # <i>
        #Option     "RingSize"                  # <i>
        #Option     "BufferSize"                # <i>
        #Option     "EnableDepthMoves"          # [<bool>]
        #Option     "EnablePageFlip"            # [<bool>]
      #Option     "NoBackBuffer"              # [<bool>]
        #Option     "DMAForXv"                  # [<bool>]
        #Option     "FBTexPercent"              # <i>
        #Option     "DepthBits"                 # <i>
        #Option     "PCIAPERSize"               # <i>
        #Option     "AccelDFS"                  # [<bool>]
        #Option     "IgnoreEDID"                # [<bool>]
        #Option     "CustomEDID"                # [<str>]
        #Option     "DisplayPriority"           # [<str>]
        #Option     "PanelSize"                 # [<str>]
       #Option     "ForceMinDotClock"          # <freq>
        #Option     "ColorTiling"               # [<bool>]
        #Option     "VideoKey"                  # <i>
        #Option     "RageTheatreCrystal"        # <i>
        #Option     "RageTheatreTunerPort"      # <i>
        #Option     "RageTheatreCompositePort"  # <i>
        #Option     "RageTheatreSVideoPort"     # <i>
        #Option     "TunerType"                 # <i>
        #Option     "RageTheatreMicrocPath"     # <str>
        #Option     "RageTheatreMicrocType"     # <str>
#Option     "ScalerWidth"               # <i>
        #Option     "RenderAccel"               # [<bool>]
        #Option     "SubPixelOrder"             # [<str>]
        #Option     "ClockGating"               # [<bool>]
        #Option     "VGAAccess"                 # [<bool>]
        #Option     "ReverseDDC"                # [<bool>]
        #Option     "LVDSProbePLL"              # [<bool>]
        #Option     "AccelMethod"               # <str>
        #Option     "DRI"                       # [<bool>]
        #Option     "ConnectorTable"            # <str>
  #Option     "DefaultConnectorTable"     # [<bool>]
        #Option     "DefaultTMDSPLL"            # [<bool>]
        #Option     "TVDACLoadDetect"           # [<bool>]
        #Option     "ForceTVOut"                # [<bool>]
        #Option     "TVStandard"                # <str>
        #Option     "IgnoreLidStatus"           # [<bool>]
        #Option     "DefaultTVDACAdj"           # [<bool>]
        #Option     "Int10"                     # [<bool>]
        #Option     "EXAVSync"                  # [<bool>]
        #Option     "ATOMTVOut"                 # [<bool>]
 #Option     "R4xxATOM"                  # [<bool>]
        #Option     "ForceLowPowerMode"         # [<bool>]
        #Option     "DynamicPM"                 # [<bool>]
        #Option     "NewPLL"                    # [<bool>]
        #Option     "ZaphodHeads"               # <str>
        Identifier  "ATI Technologies, Inc. Radeon 7000"
        Driver      "ati"
        BusID       "PCI:0:3:0"
        Option      "UseFBDev"  "true"
EndSection
Section "Screen"
        Identifier "Screen0"
        Device     "ATI Technologies, Inc. Radeon 7000"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
       EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
This is the startx command
Code:
-------------------------------------------------------------------------------

startx
-------------------------------------------------------------------------------
usrv-raptor# X

X.Org X Server 1.10.3
Release Date: 2011-07-08
X Protocol Version 11, Revision 0
Build Operating System: NetBSD/sparc64  -
Current Operating System: NetBSD usrv-raptor.workgroup 6.1.5 NetBSD 6.1.5 (GENERIC) sparc64
Build Date: 01 August 2011  01:01:00AM

Current version of pixman: 0.23.2
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct 19 13:58:47 2014
(==) Using config file: "/etc/X11/xorg.conf"
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

usrv-raptor#
this is the /var/log/Xorg.0.log
Code:
------------------------------------------------------------------------------
/var/log/Xorg.0.log
------------------------------------------------------------------------------

[ 12776.107]
X.Org X Server 1.10.3
Release Date: 2011-07-08
[ 12776.109] X Protocol Version 11, Revision 0
[ 12776.110] Build Operating System: NetBSD/sparc64  -
[ 12776.111] Current Operating System: NetBSD usrv-raptor.workgroup 6.1.5 NetBS$
[ 12776.115] Build Date: 01 August 2011  01:01:00AM
[ 12776.115]
[ 12776.115] Current version of pixman: 0.23.2
[ 12776.117]    Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
[ 12776.119] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 12776.122] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct 19 14:05:38 20$
[ 12776.124] (==) Using config file: "/etc/X11/xorg.conf"
[ 12776.125] (==) ServerLayout "X.org Configured"
[ 12776.125] (**) |-->Screen "Screen0" (0)
[ 12776.125] (**) |   |-->Monitor "Monitor0"
[ 12776.126] (**) |   |-->Device "ATI Technologies, Inc. Radeon 7000"
[ 12776.126] (**) |-->Input Device "Mouse0"
[ 12776.126] (**) |-->Input Device "Keyboard0"
[ 12776.126] (==) Not automatically adding devices
[ 12776.126] (==) Not automatically enabling devices
[ 12776.127] (**) FontPath set to:
        /usr/X11R7/lib/X11/fonts/misc/,
        /usr/X11R7/lib/X11/fonts/TTF/,
        /usr/X11R7/lib/X11/fonts/Type1/,
        /usr/X11R7/lib/X11/fonts/75dpi/,
 /usr/X11R7/lib/X11/fonts/100dpi/,
        /usr/X11R7/lib/X11/fonts/misc/,
        /usr/X11R7/lib/X11/fonts/TTF/,
        /usr/X11R7/lib/X11/fonts/Type1/,
        /usr/X11R7/lib/X11/fonts/75dpi/,
        /usr/X11R7/lib/X11/fonts/100dpi/
[ 12776.127] (**) ModulePath set to "/usr/X11R7/lib/modules"
[ 12776.127] (II) Loader magic: 0x4105e0
[ 12776.127] (II) Module ABI versions:
[ 12776.127]    X.Org ANSI C Emulation: 0.4
[ 12776.127]    X.Org Video Driver: 10.0
[ 12776.127]    X.Org XInput driver : 12.2
[ 12776.127]    X.Org Server Extension : 5.0
[ 12776.283] (--) PCI:*(1:0:3:0) 1002:5159:1002:0908 rev 0, Mem @ 0x08000000/13$
[ 12776.309] (II) "extmod" will be loaded. This was enabled by default and also$
[ 12776.309] (II) "dbe" will be loaded. This was enabled by default and also sp$
[ 12776.309] (II) "glx" will be loaded. This was enabled by default and also sp$
[ 12776.309] (II) "record" will be loaded. This was enabled by default and also$
[ 12776.309] (II) "dri" will be loaded. This was enabled by default and also sp$
[ 12776.310] (II) "dri2" will be loaded. This was enabled by default and also s$
[ 12776.310] (II) LoadModule: "dbe"
[ 12776.312] (II) Loading /usr/X11R7/lib/modules/extensions/libdbe.so
[ 12776.312] (II) Module dbe: vendor="X.Org Foundation"
[ 12776.312]    compiled for 1.10.3, module version = 1.0.0
[ 12776.312]    Module class: X.Org Server Extension
[ 12776.312]    ABI class: X.Org Server Extension, version 5.0
[ 12776.312] (II) Loading extension DOUBLE-BUFFER
[ 12776.313] (II) LoadModule: "dri"
[ 12776.314] (II) Loading /usr/X11R7/lib/modules/extensions/libdri.so
[ 12776.315] (II) Module dri: vendor="X.Org Foundation"
[ 12776.315]    compiled for 1.10.3, module version = 1.0.0
[ 12776.315]    ABI class: X.Org Server Extension, version 5.0
[ 12776.315] (II) Loading extension XFree86-DRI
[ 12776.315] (II) LoadModule: "dri2"
[ 12776.317] (II) Loading /usr/X11R7/lib/modules/extensions/libdri2.so
[ 12776.317] (II) Module dri2: vendor="X.Org Foundation"
[ 12776.317]    compiled for 1.10.3, module version = 1.2.0
[ 12776.317]    ABI class: X.Org Server Extension, version 5.0
[ 12776.317] (II) Loading extension DRI2
[ 12776.317] (II) LoadModule: "extmod"
[ 12776.320] (II) Loading /usr/X11R7/lib/modules/extensions/libextmod.so
[ 12776.321] (II) Module extmod: vendor="X.Org Foundation"
[ 12776.321]    compiled for 1.10.3, module version = 1.0.0
[ 12776.321]    Module class: X.Org Server Extension
[ 12776.321]    ABI class: X.Org Server Extension, version 5.0
[ 12776.321] (II) Loading extension MIT-SCREEN-SAVER
[ 12776.321] (II) Loading extension XFree86-VidModeExtension
[ 12776.321] (II) Loading extension XFree86-DGA
[ 12776.321] (II) Loading extension DPMS
[ 12776.321] (II) Loading extension XVideo
[ 12776.321] (II) Loading extension XVideo-MotionCompensation
[ 12776.321] (II) Loading extension X-Resource
[ 12776.321] (II) LoadModule: "glx"
[ 12776.324] (II) Loading /usr/X11R7/lib/modules/extensions/libglx.so
[ 12776.324] (II) Module glx: vendor="X.Org Foundation"
[ 12776.324]    compiled for 1.10.3, module version = 1.0.0
[ 12776.324]    ABI class: X.Org Server Extension, version 5.0
[ 12776.324] (==) AIGLX enabled
[ 12776.325] (II) Loading extension GLX
[ 12776.325] (II) LoadModule: "record"
[ 12776.327] (II) Loading /usr/X11R7/lib/modules/extensions/librecord.so
[ 12776.327] (II) Module record: vendor="X.Org Foundation"
[ 12776.327]    compiled for 1.10.3, module version = 1.13.0
[ 12776.327]    Module class: X.Org Server Extension
[ 12776.327]    ABI class: X.Org Server Extension, version 5.0
[ 12776.327] (II) Loading extension RECORD
[ 12776.328] (II) LoadModule: "shadow"
[ 12776.330] (II) Loading /usr/X11R7/lib/modules/extensions/libshadow.so
[ 12776.330] (II) Module shadow: vendor="X.Org Foundation"
[ 12776.330]    compiled for 1.10.3, module version = 1.1.0
[ 12776.330]    ABI class: X.Org ANSI C Emulation, version 0.4
[ 12776.330] (II) LoadModule: "ati"
[ 12776.331] (II) Loading /usr/X11R7/lib/modules/drivers/ati_drv.so
[ 12776.332] (II) Module ati: vendor="X.Org Foundation"
[ 12776.332]    compiled for 1.10.3, module version = 6.14.6
[ 12776.332]    Module class: X.Org Video Driver
[ 12776.332]    ABI class: X.Org Video Driver, version 10.0
[ 12776.332] (II) LoadModule: "mouse"
[ 12776.333] (II) Loading /usr/X11R7/lib/modules/drivers/mouse_drv.so
[ 12776.334] (II) Module mouse: vendor="X.Org Foundation"
[ 12776.334]    compiled for 1.10.3, module version = 1.7.1
[ 12776.334]    Module class: X.Org XInput Driver
[ 12776.334]    ABI class: X.Org XInput driver, version 12.2
[ 12776.334] (II) LoadModule: "kbd"
[ 12776.335] (II) Loading /usr/X11R7/lib/modules/drivers/kbd_drv.so
[ 12776.335] (II) Module kbd: vendor="X.Org Foundation"
[ 12776.335]    compiled for 1.10.3, module version = 1.6.0
[ 12776.335]    Module class: X.Org XInput Driver
[ 12776.335]    ABI class: X.Org XInput driver, version 12.2
[ 12776.335] (EE) No drivers available.
[ 12776.336]
Fatal server error:
[ 12776.337] no screens found
[ 12776.338]
Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
[ 12776.342] Please also check the log file at "/var/log/Xorg.0.log" for additi$
[ 12776.343]
Also on the Blade there no repertory "/usr/pkgsrc/", i could not to "make install" !

Regards
Philippe

Last edited by philo_neo71; 1 Day Ago at 05:47 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome install on freebsd 9 barti FreeBSD Ports and Packages 0 3rd September 2012 05:24 PM
How - To install GNOME vile I install OpenBSD ? looop OpenBSD Installation and Upgrading 6 24th April 2010 08:58 PM
Links for softwares after install (kde, gnome, firefox) ahlsner NetBSD General 14 12th August 2009 10:46 PM
New User - Ports Install and GNOME Pkg problems IronForge OpenBSD Packages and Ports 9 14th July 2009 08:34 PM
Full install of Gnome on OpenBSD 4.4 mfaridi OpenBSD Installation and Upgrading 17 9th November 2008 01:54 PM


All times are GMT. The time now is 01:14 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick