DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 25th June 2014
vale_shine vale_shine is offline
New User
 
Join Date: Jun 2014
Posts: 2
Thanked 0 Times in 0 Posts
Default I can't use multicast on OpenBSD

Hi group I'm a newbie of OpenBSD systems and I have the following problem:
I'm interested in working with my openBSD virtual machine (under virtualbox) as a router but, when I use quagga, its routing deamons (ripd and ospfd) don't work.
it gives me the following output in /var/log/quagga/rip.log:
can't setsockopt ip_add_membership can't assign requested address
multicast join failed, interface em2 not running

but em2 is active and running!!

even if I try to start mrouted -d I receive the error:
can't enable multicast routing kernel: address already in use

I googled a little searching a solution for both problems and I found this link about the first error:
openbsd.7691.n7.nabble.com/quagga-0-99-20-1p0-multicast-broken-on-5-2-patch-included-td221123.html

but I don't have the skills to do what they suggest to.

and I couldn't find anything about the second output

do you have any suggestions ?? thanks and sorry for my english
Reply With Quote
  #2   (View Single Post)  
Old 25th June 2014
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,825
Thanked 214 Times in 189 Posts
Default

Hello, and welcome!

The discussion of quagga on the ports@ mailing list you cited, from January 1-3 in 2013, resulted in changes to the net/quagga port on January 4 of that year. This change was included in OpenBSD 5.3. If you are using 5.3 or a later release, and its matching quagga package, you have this change in your system.

Double check that you've enabled multicast routing. It is not enabled by default. You need to set multicast_router=YES in /etc/rc.conf.local to enable the appropriate sysctl values.
Reply With Quote
  #3   (View Single Post)  
Old 25th June 2014
vale_shine vale_shine is offline
New User
 
Join Date: Jun 2014
Posts: 2
Thanked 0 Times in 0 Posts
Default

hello jggimi and thanks very much for your reply.
I use OpenBSD 5.5 with the matching quagga (installed with the pkg_add command)

I already set multicast_router=YES in /etc/rc.conf.local but it still doesn't work.

I've also uncommented all the rows in sysctl.conf about forwarding ipv4 and multicast ipv4 packets

what should I do?
Reply With Quote
  #4   (View Single Post)  
Old 25th June 2014
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 3,825
Thanked 214 Times in 189 Posts
Default

I recommend posting to the ports@ mailing list, requesting guidance on quagga usage. As there may be a problem, I would treat your request like a problem report and include 1) your dmesg, 2) your rc.conf.local file, 3) your changes to the /etc/sysctl.conf file, and 4) your quagga configuration settings.

http://www.openbsd.org/mail.html
http://www.openbsd.org/report.html
Reply With Quote
Reply

Tags
multicast, quagga

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD multicast unkmail Programming 4 20th May 2013 08:07 PM
Playing IPTV Multicast stream tomageeni OpenBSD General 2 18th July 2010 09:28 PM


All times are GMT. The time now is 07:33 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick