DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 15th June 2008
Marred Marred is offline
Real Name: Hutchinson
HUTCHY
 
Join Date: Jun 2008
Location: MY-HUMBLE-ABODE
Posts: 14
Thanked 0 Times in 0 Posts
Lightbulb Do I need to Upgrade my Kernel yet

Hi, Just Lately I have been having some trouble upgrading my pkgs, I have been running BSD-6.3 for a fair while now & have been able to keep my system always up to date til now .

AnyWay I am now wondering if my system is now telling me I need to upgrade my Kernel if I want to have an up to date system.
I have picked this error out to give as an example & was hoping if someone could tell what it means or what I need to do as I am a little bit nervous about upgrading kernel etc & was hoping it might not mean I needto just yet.
Thanks anyOne
Reply With Quote
  #2   (View Single Post)  
Old 15th June 2008
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,116
Thanked 182 Times in 149 Posts
Default

Without the text of the error message it is difficult to pinpoint the problem and to help you.

Which procedure(s) have you been using to keep your FBSD system up to date?
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #3   (View Single Post)  
Old 16th June 2008
Marred Marred is offline
Real Name: Hutchinson
HUTCHY
 
Join Date: Jun 2008
Location: MY-HUMBLE-ABODE
Posts: 14
Thanked 0 Times in 0 Posts
Default

Sorry ' I just realised I didnt finish of my Question by adding the error ,I must of been working ahead of myself.
AnyWay I am re Running the software to try & get the error Back so I can Repost as I was sure I saved a Copy of error like i usually do but cant Find it.
I will hopefully be back shortly with info.
Thanks
Reply With Quote
  #4   (View Single Post)  
Old 17th June 2008
Marred Marred is offline
Real Name: Hutchinson
HUTCHY
 
Join Date: Jun 2008
Location: MY-HUMBLE-ABODE
Posts: 14
Thanked 0 Times in 0 Posts
Cool

It Turns out I actually did save the error but to a different new folder , I forgot I created it as I play between 2 PC's .
AnyWay Before I found the original error I Updated PortSnap with "#portsnap fetch update"
then "# portsdb -Uu"
then "#cd /usr/ports"
then "# make fetchindex"
then "#pkgdb -uF

And then ran "portmanager -u" & it was looking real good til it got to around 40% & then came similar errors.But slightly different.
So I did get to upgrade some pkgs which shortned the list a bit.
The first error is the one I was to originally show before I ran Portmanager but didnt show up on errors this time.
And second is after trying to upgrade with Portmanager -u.
I would appreciate any help as I have found in past it hard to uninstall some pkgs that belong to another pkg but I will have to learn how it seems.


##2nd Error
00983 have:deluge-0.5.9.1_1 /net-p2p/deluge CURRENT
00984 have:fluxconf-0.9.9_3 /x11-wm/fluxconf CURRENT
00985 have:selectwm-0.4.1_5 /x11-wm/selectwm CURRENT
00986 have:avahi-gtk-0.6.22_1 /net/avahi-gtk CURRENT
00987 havey25-avahi-0.6.22_2 /net/py-avahi CURRENT
================================================== ======================
skipping cups-base-1.3.7_3 /print/cups-base until dependency avahi-libdns-0.6.22_1 updated
skipping avahi-libdns-0.6.22_1 /net/avahi-libdns marked IGNORE reason: conflicts with another installed port
skipping arts-1.5.8_1,1 /audio/arts until dependency qt-copy-3.3.8_9 updated
skipping qt-copy-3.3.8_8 /x11-toolkits/qt33 until dependency cups-base-1.3.7_3 updated
skipping kdelibs-3.5.8 /x11/kdelibs3 until dependency qt-copy-3.3.8_9 updated
skipping kdeaccessibility-3.5.8 /accessibility/kdeaccessibility until dependency qt-copy-3.3.8_9 updated
skipping dbus-qt3-0.70_2 /devel/dbus-qt3 until dependency qt-copy-3.3.8_9 updated
skipping kdebase-kompmgr-3.5.8 /x11-wm/kompmgr until dependency qt-copy-3.3.8_9 updated
skipping kdebase-3.5.8_1 /x11/kdebase3 until dependency qt-copy-3.3.8_9 updated
skipping amarok-1.4.8_4 /audio/amarok until dependency qt-copy-3.3.8_9 updated
skipping libxine-1.1.12 /multimedia/libxine until dependency arts-1.5.8_1,1 updated
skipping nvidia-driver-100.14.19 /x11/nvidia-driver marked IGNORE reason: failed during make
skipping kdepim-3.5.8 /deskutils/kdepim3 until dependency qt-copy-3.3.8_9 updated
skipping kdesdk-3.5.8 /devel/kdesdk3 until dependency qt-copy-3.3.8_9 updated
skipping kdevelop-3.5.0 /devel/kdevelop until dependency kdesdk-3.5.8_1 updated
skipping openoffice.org-2.4.0_5 /editors/openoffice.org-2 until dependency cups-base-1.3.7_3 updated
skipping kdegames-3.5.8 /games/kdegames3 until dependency qt-copy-3.3.8_9 updated
skipping libkdcraw-0.1.4 /graphics/libkdcraw until dependency qt-copy-3.3.8_9 updated
skipping libkipi-0.1.6 /graphics/libkipi until dependency qt-copy-3.3.8_9 updated
skipping digikam-0.9.3_2 /graphics/digikam until dependency qt-copy-3.3.8_9 updated
skipping libkexiv2-0.1.7 /graphics/libkexiv2 until dependency qt-copy-3.3.8_9 updated
skipping poppler-qt-0.6.4 /graphics/poppler-qt until dependency qt-copy-3.3.8_9 updated
skipping kdegraphics-3.5.8_1 /graphics/kdegraphics3 until dependency qt-copy-3.3.8_9 updated
skipping kdegraphics-kuickshow-3.5.8_1 /graphics/kuickshow until dependency qt-copy-3.3.8_9 updated
skipping kdegraphics-kamera-3.5.8_1 /graphics/kamera until dependency qt-copy-3.3.8_9 updated
skipping kdegraphics-kooka-3.5.8_1 /graphics/kooka until dependency qt-copy-3.3.8_9 updated
skipping konversation-1.0.1_1 /irc/konversation until dependency qt-copy-3.3.8_9 updated
skipping k3b-i18n-1.0.4 /misc/k3b-i18n until dependency qt-copy-3.3.8_9 updated
skipping kdeedu-3.5.8 /misc/kdeedu3 until dependency qt-copy-3.3.8_9 updated
skipping kdeutils-3.5.8 /misc/kdeutils3 until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-kfile-plugins-3.5.8 /misc/kfile-plugins until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-kicker-applets-3.5.8 /misc/kicker-applets until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-konq-plugins-3.5.8 /misc/konq-plugins until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-renamedlg-plugins-3.5.8 /misc/renamedlgplugins until dependency qt-copy-3.3.8_9 updated
skipping kdemultimedia-3.5.8_1 /multimedia/kdemultimedia3 until dependency qt-copy-3.3.8_9 updated
skipping kdemultimedia-xine_artsplugin-3.5.8 /multimedia/xine_artsplugin until dependency qt-copy-3.3.8_9 updated
skipping kdemultimedia-mpeglib_artsplug-3.5.8 /audio/mpeglib_artsplug until dependency qt-copy-3.3.8_9 updated
skipping vlc-0.8.6.f_3,2 /multimedia/vlc until dependency arts-1.5.8_1,1 updated
skipping mplayer-0.99.11_4 /multimedia/mplayer until dependency arts-1.5.8_1,1 updated
skipping kdenetwork-3.5.8 /net/kdenetwork3 until dependency qt-copy-3.3.8_9 updated
skipping desktopbsd-tools-1.6 /sysutils/desktopbsd-tools until dependency qt-copy-3.3.8_9 updated
skipping filelight-1.0_1 /sysutils/filelight until dependency qt-copy-3.3.8_9 updated
skipping kdewebdev-3.5.8,2 /www/kdewebdev until dependency kdesdk-3.5.8_1 updated
skipping kdetoys-3.5.8 /x11-clocks/kdetoys3 until dependency qt-copy-3.3.8_9 updated
skipping clearlooks-themes-0.6.2_6 /x11-themes/clearlooks-themes marked IGNORE reason: conflicts with another installed port
skipping kde-style-lipstik-2.2.3 /x11-themes/kde-style-lipstik until dependency qt-copy-3.3.8_9 updated
skipping kdeartwork-3.5.8 /x11-themes/kdeartwork3 until dependency qt-copy-3.3.8_9 updated
skipping moodin-0.4.2_1 /x11-themes/moodin until dependency qt-copy-3.3.8_9 updated
skipping kaffeine-0.8.6 /multimedia/kaffeine until dependency qt-copy-3.3.8_9 updated
skipping kde-windeco-activeheart-1.1_2 /x11-themes/kde-windeco-activeheart until dependency qt-copy-3.3.8_9 updated
skipping kde-style-tiblit-1.2_4 /x11-themes/kde-style-tiblit until dependency qt-copy-3.3.8_9 updated
skipping xine-0.99.5 /multimedia/xine until dependency libxine-1.1.12_1 updated
skipping qscintilla-1.7.1_3 /x11-toolkits/qscintilla until dependency qt-copy-3.3.8_9 updated
skipping kde-windeco-neos-0.2b_4 /x11-themes/kde-windeco-neos until dependency qt-copy-3.3.8_9 updated
skipping kde-windeco-crystal-1.0.5 /x11-themes/kde-windeco-crystal until dependency qt-copy-3.3.8_9 updated
skipping py25-qt-3.17.4,2 /x11-toolkits/py-qt until dependency qt-copy-3.3.8_9 updated
skipping py25-kde-3.16.1,1 /x11-toolkits/py-kde until dependency py25-qt-3.17.4_1,2 updated
skipping mimms-2.0.1 /multimedia/mimms marked IGNORE reason: failed during make
skipping katchtv-1.0_1 /multimedia/katchtv until dependency py25-kde-3.16.1_1,1 updated
skipping krusader-1.90.0 /x11-fm/krusader until dependency qt-copy-3.3.8_9 updated
skipping qnxstyle-0.2_4 /x11-themes/qnxstyle until dependency qt-copy-3.3.8_9 updated
skipping qinx-1.4_2 /x11-themes/qinx until dependency qt-copy-3.3.8_9 updated
skipping kmplayer-0.10.0c,2 /multimedia/kmplayer until dependency mplayer-0.99.11_5 updated
skipping kdmtheme-1.1.3_1 /x11-themes/kdmtheme until dependency qt-copy-3.3.8_9 updated
skipping mencoder-0.99.11_1 /multimedia/mencoder until dependency mplayer-0.99.11_5 updated
skipping devede-3.01_3 /multimedia/devede until dependency mencoder-0.99.11_2 updated
skipping metabar-0.8_3 /deskutils/metabar until dependency qt-copy-3.3.8_9 updated
skipping knemo-0.4.1_1 /net/knemo until dependency qt-copy-3.3.8_9 updated
skipping gnustep-back-0.12.1_1 /x11-toolkits/gnustep-back until dependency gnustep-gui-0.12.2 updated
skipping gnustep-gui-0.12.1_1 /x11-toolkits/gnustep-gui until dependency cups-base-1.3.7_3 updated
skipping gmastermind-0.2_1 /games/gmastermind until dependency gnustep-back-0.12.2 updated
skipping tmake-1.7_3 /devel/tmake until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-kate-plugins-3.5.8 /editors/kate-plugins until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-ksig-3.5.8 /misc/ksig until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-kaddressbook-plugins-3.5.8 /misc/kaddressbook-plugins until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-knewsticker-scripts-3.5.8 /misc/knewsticker-scripts until dependency qt-copy-3.3.8_9 updated
skipping kde-windeco-knifty-0.4.2_4 /x11-themes/kde-windeco-knifty until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-atlantikdesigner-3.5.8 /games/atlantikdesigner until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-noatun-plugins-3.5.8 /multimedia/noatun-plugins until dependency qt-copy-3.3.8_9 updated
skipping kdeaddons-3.5.8 /misc/kdeaddons3 until dependency kdeaddons-atlantikdesigner-3.5.8_1 updated
skipping kleansweep-0.2.9 /sysutils/kleansweep until dependency qt-copy-3.3.8_9 updated
skipping dolphin-0.8.2_1 /x11-fm/dolphin until dependency qt-copy-3.3.8_9 updated
skipping samba-3.0.28a_1,1 /net/samba3 until dependency cups-base-1.3.7_3 updated
skipping kdenetwork-lanbrowsing-3.5.8 /net/lanbrowsing until dependency samba-3.0.28a_2,1 updated
skipping k3b-1.0.4_1 /sysutils/k3b until dependency qt-copy-3.3.8_9 updated
skipping doxygen-1.5.6 /devel/doxygen until dependency qt-copy-3.3.8_9 updated
skipping kbfx-0.4.9.3.1,1 /misc/kbfx until dependency qt-copy-3.3.8_9 updated
skipping avahi-qt3-0.6.22_1 /net/avahi-qt3 until dependency qt-copy-3.3.8_9 updated
------------------------------------------------------------------------
portmanager 0.4.1_9 INFO: finished with some ports not updated if --log was used see /var/log/portmanager.log
------------------------------------------------------------------------




##The First Error

install -o root -g wheel -m 444 /usr/ports/audio/pulseaudio/work/pulseaudio-0.9.10/src/client.conf /usr/local/etc/pulse/client.conf-dist
pulse-rt:*:557:
You already have a group "pulse-rt", so I will use it.
pulse:*:563:
You already have a group "pulse", so I will use it.
pulse-access:*:564:
You already have a group "pulse-access", so I will use it.
pulse:*:563:563::0:0:PulseAudio System User:/nonexistent:/sbin/nologin
You already have a user "pulse", so I will use it.

===>
Pulseaudio is designed to run in realtime, to achieve this pulseaudio is
marked SUID root by default. To take advantage of pulseaudio's realtime
functionality you must be a member of the 'pulse-rt' group.

ie: 'pw mod group pulse-rt -m [USERNAME]'
===> Compressing manual pages for pulseaudio-0.9.10_2
===> Running ldconfig
/sbin/ldconfig -m /usr/local/lib
===> Registering installation for pulseaudio-0.9.10_2
===> SECURITY REPORT:
This port has installed the following binaries which execute with
increased privileges.
/usr/local/bin/pulseaudio

This port has installed the following files which may act as network
servers and may therefore pose a remote security risk to the system.
/usr/local/lib/pulse-0.9/modules/libsocket-server.so

If there are vulnerabilities in these programs there may be a security
risk to the system. FreeBSD makes no guarantee about the security of
ports included in the Ports Collection. Please type 'make deinstall'
to deinstall the port if this is a concern.

For more information, and contact details about the security
status of this software, see the following webpage:
http://pulseaudio.org/
===> Cleaning for pulseaudio-0.9.10_2

===>>> Updating package dependency entry for each dependent port

===>>> Upgrade of pulseaudio-0.9.10_1 to pulseaudio-0.9.10_2 succeeded

===>>> Returning to dependency check for multimedia/libxine
===>>> Launching child to update nvidia-driver-100.14.19
kaffeine-0.8.6 >> libxine-1.1.12 >> nvidia-driver-100.14.19

===>>> Port directory: /usr/ports/x11/nvidia-driver
===>>> Starting check for build dependencies
===>>> Gathering dependency list for x11/nvidia-driver from ports
===>>> Starting dependency check
===>>> Dependency check complete for x11/nvidia-driver
kaffeine-0.8.6 >> libxine-1.1.12 >> nvidia-driver-100.14.19

===> Cleaning for nvidia-driver-173.14.05

===> Found saved configuration for nvidia-driver-100.14.19
===> Extracting for nvidia-driver-173.14.05
=> MD5 Checksum OK for NVIDIA-FreeBSD-x86-173.14.05.tar.gz.
=> SHA256 Checksum OK for NVIDIA-FreeBSD-x86-173.14.05.tar.gz.
===> Patching for nvidia-driver-173.14.05
===> Applying FreeBSD patches for nvidia-driver-173.14.05
===> nvidia-driver-173.14.05 depends on shared library: m.3 - found
===> nvidia-driver-173.14.05 depends on shared library: GL.1 - found
===> Configuring for nvidia-driver-173.14.05
===> Building for nvidia-driver-173.14.05
===> src (all)
@ -> /usr/src/sys
machine -> /usr/src/sys/i386/include
awk -f @/tools/makeobjops.awk @/kern/device_if.m -h
awk -f @/tools/makeobjops.awk @/kern/bus_if.m -h
awk -f @/tools/makeobjops.awk @/dev/pci/pci_if.m -h
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -p
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -q
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -h
cc -O2 -fno-strict-aliasing -pipe -DNV_VERSION_STRING=\"173.14.05\" -D__KERNEL__ -DNVRM -UDEBUG -U_DEBUG -DNDEBUG -O -Werror -D_KERNEL -DKLD_MODULE -std=c99 -nostdinc -I/src -I. -I@ -I@/contrib/altq -finline-limit=8000 --param inline-unit-growth=100 --param large-function-growth=1000 -fno-common -mno-align-long-strings -mpreferred-stack-boundary=2 -mno-mmx -mno-3dnow -mno-sse -mno-sse2 -mno-sse3 -ffreestanding -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual -Wundef -Wno-pointer-sign -fformat-extensions -c nvidia_ctl.c
cc1: error: unrecognized command line option "-Wno-pointer-sign"
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86-173.14.05/src.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86-173.14.05.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver.

===>>> make failed for x11/nvidia-driver
===>>> Aborting update

===>>> Update for nvidia-driver-100.14.19 failed
===>>> Aborting update

===>>> Update for libxine-1.1.12 failed
===>>> Aborting update

===>>> Update for kaffeine-0.8.6 failed
===>>> Aborting update

===>>> There are messages from installed ports to display,
but first take a moment to review the error messages
above. Then press Enter when ready to proceed.

===>>> pkg-message for openldap-client-2.3.42

############

I havnt been able to upgrade Nvidia driver for a long time .

Thanks AnyOne who can understand the way I have written this problem as well as errors.

Last edited by Marred; 17th June 2008 at 01:30 AM.
Reply With Quote
  #5   (View Single Post)  
Old 17th June 2008
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

Ok, just a couple of notes.

If you are using portsnap, it keeps the INDEXes up to date. There is no reason for a seperate make fetchindex.

If you are using portmanager, you do not need to use pkgdb and portsdb, which are part of the portupgrade suite. portmanager does not use pkgdb or portsdb, as it relies on the systems database files, which the ports system keeps up to date.

Lastly, keeping your FreeBSD kernel and world up to date is not difficult. You will need the source tree (/usr/src) which you should install from your disk or a downloaded package, csup to update it, and then to do a buildworld cycle to finish it. A little bit of knolwedge about your system is an advantage. Normally I'd just point you to the handbook chapter, but the handbook is somewhat over-complex.
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
  #6   (View Single Post)  
Old 17th June 2008
Marred Marred is offline
Real Name: Hutchinson
HUTCHY
 
Join Date: Jun 2008
Location: MY-HUMBLE-ABODE
Posts: 14
Thanked 0 Times in 0 Posts
Default

Thanks for pointing those things out about PortManager etc as it can be hard to pick up on those types of things until you properly understand & work out the differences between pkg managers.
I actually deliberatly typed in those commands hoping someone might point out anything noticable.
I actually would always start off using "portupgrade" for upgrading pkgs etc first & then when an error forced portupgrade to stop I would turn to one of the other pkg managers like "portmaster & portmanager" to see if they fix the error because they do things differently & alot of the times they saved the day , but this time neither fully got me through all the upgrades but did help .

BSD is the longest I have had any Desktop stay on my PC while constantly keeping my system up to date & I dont want to lose it so I will hopefully upgrade my Kernel properly when I do give it ago.
I actually thought BSD-unix would break the quickest of all the Linux-Unix distro's I have tried but has been nothing but the greatest Joy & success over the few years using Computers & Linux-Unix.
The other problem with one of the errors is it says
"avahi-libdns-0.6.22_1 /net/avahi-libdns marked IGNORE reason: conflicts with another installed port" But doesnt seem to explain whick pkg it conflicks with- & as I explained above-you cant always delete a pkg as it wont let you because of dependencies etc.

& Also

error: unrecognized command line option "-Wno-pointer-sign"
*** Error code 1
which is what originally I think caused me to think I needed to upgrade Kernel.
AnyWay
Reply With Quote
  #7   (View Single Post)  
Old 17th June 2008
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
 
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366
Thanked 40 Times in 39 Posts
Default

(Another thing is that we do not generally speak of "upgrading the kernel". FreeBSD is an entire operating system, and the kernel is part of it. You will be upgrading the entire base system - to be precise, everything that you did not install using ports)

Secondly, choose a package manager and stick to it. portmaster is probably better, but portupgrade is better supported for the present.

Now, more questions: Do you have anything in your /etc/make.conf? Many persons from a Linux background tend to put all sorts of rubbish in there(for instance, options from a newer gcc version), and it does cause problems.

Errors like these can be caused by out of date gcc versions, but the ports collection is very good at detecting and flagging them before it gets to the stage of bombing out.

avahi-libdns conflicts with mDNSresponder. (I found that by looking int net/avahi-libdns/Makefile, and finding the CONFLICTS entry.) They do the same job, by the looks of it, so either can probably be used.
Both portmaster and portupgrade have a -o option to cover these cases - something like# portupgrade -o net/avahi-libdns mDNSresponder\* should replace mDNSresponder with avadi-libdns, healing all orphaned dependencies along the way.
__________________
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
  #8   (View Single Post)  
Old 17th June 2008
Weaseal's Avatar
Weaseal Weaseal is offline
Package Pilot
 
Join Date: May 2008
Location: East Coast, US
Posts: 177
Thanked 7 Times in 7 Posts
Default

He clearly has modified CFLAGS in make.conf by that compile line... Please see http://gentoo-wiki.com/Safe_Cflags and ensure that you are using safe CFLAGS for your processor. If it still breaks, remove all of them and try again.
__________________
FreeBSD addict since 4.2-RELEASE.
My FreeBSD wiki.
Reply With Quote
  #9   (View Single Post)  
Old 18th June 2008
Marred Marred is offline
Real Name: Hutchinson
HUTCHY
 
Join Date: Jun 2008
Location: MY-HUMBLE-ABODE
Posts: 14
Thanked 0 Times in 0 Posts
Default

It sounds a good idea theoretically to stick with one package manager & I seriously considered it .
But because I mainly use Portupgrade I decided to give it another go without adjusting anything after running both Portmanager & portmaster as I explained earlier, -which upgraded pkgs portupgrade complained about.
& now all the pkgs that were left over which master & manager didn't do are now been upgraded by portupgrade & all the problems listed above with the errors are fixed & this is the method I have been using for a while now.

I have added my make.conf to show if anything is unusual,
as its alot different to using Gentoo it seems.
As I read that using portmaster properly may mean changing your make.conf to get proper value from it etc.

I am hoping to stick with one Manager as I keep picking up more tips along the way.

My "make.conf"

# Disable VuXML checks, vulnerable ports are marked FORBIDDEN anyway and
# this prevents installing with non-vulnerable options (see win32-codecs)
DISABLE_VULNERABILITIES=yes

# Compile with cups support
WITH_CUPS=yes

# Makes cups shadow printing support in the base system
CUPS_OVERWRITE_BASE=yes

# Use Firefox's gecko engine since it's preinstalled
WITH_MOZILLA=firefox
WITH_GECKO=firefox

Thanks All

Last edited by Marred; 18th June 2008 at 05:48 PM.
Reply With Quote
Old 18th June 2008
richardpl richardpl is offline
Spam Deminer
 
Join Date: May 2008
Location: Croatia
Posts: 284
Thanked 25 Times in 24 Posts
Default

You can always delete packages (via make deinstall in port leaf of ports tree) or via pkg_delete -xf

Ports are not for everyone, and if you do not know what are you doing and/or what is going on it is much much better to stick with packages : pkg_add -r.

To answer your question:
No, you clearly do not need to update/upgrade kernel.
Reply With Quote
Old 19th June 2008
Marred Marred is offline
Real Name: Hutchinson
HUTCHY
 
Join Date: Jun 2008
Location: MY-HUMBLE-ABODE
Posts: 14
Thanked 0 Times in 0 Posts
Default

Thanks, -I actually should of explained that I am using the
" DesktopBSD pkg manager " which uses "portupgrade" & is a fantastic tool ,& has a section for unistalling or deleting software you installed after installing your OS.
But anything else that has dependencies etc it doesnt seem to let you delete.
AnyWay I will look further into ways to delete pkgs etc as you explained as I remember being able to delete pkgs some years ago when I first tried FreeBSD but forgot the routines,
As I found when I tried deleting from console recently a couple of times it complained about dependencies etc as I forgot there are options you can use with pkg_delete & others as you pointed out like "pkg_delete -xf".

The one thing I have started using more often now are the "man pages"
Thanks

Last edited by Marred; 19th June 2008 at 05:43 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem during kernel-build for a 6.x-to-7 upgrade clevershark FreeBSD Installation and Upgrading 2 1st February 2009 10:45 PM
Upgrade FreeBSD7.0 to 7.1 Ofloo FreeBSD Installation and Upgrading 2 10th October 2008 03:24 AM
How do I upgrade? wubrgamer FreeBSD Ports and Packages 2 27th August 2008 07:18 PM
v4l - dtv device stops working after kernel upgrade robbak Other BSD and UNIX/UNIX-like 0 14th June 2008 11:29 PM
upgrade from 5.5 to 6.3 keithlybsd FreeBSD Installation and Upgrading 9 27th May 2008 06:21 PM


All times are GMT. The time now is 10:45 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick