DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 16th June 2008
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default Problem with PiTiVi

Avidemux don't function so i would like trie this alternative video editor.

When i launch configure i obtain this error:
Code:
.....
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
.....
Code:
$ /usr/bin/perl -e "require XML::Parser"       
Can't locate XML/Parser.pm in @INC 
(@INC contains: /usr/libdata/perl5/i386-openbsd/5.8.8 
/usr/local/libdata/perl5/i386-openbsd/5.8.8 
/usr/libdata/perl5 /usr/local/libdata/perl5 
/usr/local/libdata/perl5/site_perl/i386-openbsd 
/usr/libdata/perl5/site_perl/i386-openbsd 
/usr/local/libdata/perl5/site_perl 
/usr/libdata/perl5/site_perl 
/usr/local/lib/perl5/site_perl .) at -e line 1.
I have tried to copy the file Paser.pm as follow without result:
/usr/libdata/perl5/i386-openbsd/5.8.8/XML/Parser.pm

Last edited by aleunix; 16th June 2008 at 05:01 PM.
Reply With Quote
  #2   (View Single Post)  
Old 16th June 2008
cubo cubo is offline
Real Name: Luca
Port Guard
 
Join Date: May 2008
Location: Italy - Torino
Posts: 21
Thanked 0 Times in 1 Post
Default

Quote:
Originally Posted by aleunix View Post
Avidemux don't function so i would like trie this alternative video editor.

When i launch configure i obtain this error:
Code:
.....
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
.....
Install the package:

p5-XML-Parser
Reply With Quote
  #3   (View Single Post)  
Old 16th June 2008
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

Tanks the first problem is resolved.

Now i have another problem.


$ sudo make
Code:
Making all in bin
Making all in pitivi
make  all-recursive
Making all in ui
Making all in elements
Making all in pixmaps
Making all in timeline
Making all in common
Making all in m4
Making all in po
Making all in tests
if test -d po; then  cd po;  make datadir=../. install;  fi
/bin/sh /home/aleopenbsd/pitivi-0.10.3/install-sh -d .././locale
if test -n ""; then  linguas="";  else  linguas="";  fi;  for lang in $linguas; do  dir=.././locale/$lang/LC_MESSAGES;  /bin/sh /home/aleopenbsd/pitivi-0.10.3/install-sh -d $dir;  if test -r $lang.gmo; then  /usr/bin/install -c -m 644 $lang.gmo $dir/pitivi.mo;  echo "installing $lang.gmo as $dir/pitivi.mo";  else  /usr/bin/install -c -m 644 ./$lang.gmo $dir/pitivi.mo;  echo "installing ./$lang.gmo as"  "$dir/pitivi.mo";  fi;  if test -r $lang.gmo.m; then  /usr/bin/install -c -m 644 $lang.gmo.m $dir/pitivi.mo.m;  echo "installing $lang.gmo.m as $dir/pitivi.mo.m";  else  if test -r ./$lang.gmo.m ; then  /usr/bin/install -c -m 644 ./$lang.gmo.m  $dir/pitivi.mo.m;  echo "installing ./$lang.gmo.m as"  "$dir/pitivi.mo.m";  else  true;  fi;  fi;  done
$ sudo make install
Code:
Making install in bin
test -z "/usr/local/bin" || .././install-sh -c -d "/usr/local/bin"
 /usr/bin/install -c 'pitivi' '/usr/local/bin/pitivi'
Making install in pitivi
make  install-recursive
Making install in ui
test -z "/usr/local/lib/pitivi/python/pitivi/ui" || ../.././install-sh -c -d "/usr/local/lib/pitivi/python/pitivi/ui"
 /usr/bin/install -c -m 644 'actions.xml' '/usr/local/lib/pitivi/python/pitivi/ui/actions.xml'
 /usr/bin/install -c -m 644 'elementsettingsdialog.glade' '/usr/local/lib/pitivi/python/pitivi/ui/elementsettingsdialog.glade'
 /usr/bin/install -c -m 644 'encodingdialog.glade' '/usr/local/lib/pitivi/python/pitivi/ui/encodingdialog.glade'
 /usr/bin/install -c -m 644 'exportsettingswidget.glade' '/usr/local/lib/pitivi/python/pitivi/ui/exportsettingswidget.glade'
 /usr/bin/install -c -m 644 'filelisterrordialog.glade' '/usr/local/lib/pitivi/python/pitivi/ui/filelisterrordialog.glade'
 /usr/bin/install -c -m 644 'projectsettings.glade' '/usr/local/lib/pitivi/python/pitivi/ui/projectsettings.glade'
test -z "/usr/local/lib/pitivi/python/pitivi/ui" || ../.././install-sh -c -d "/usr/local/lib/pitivi/python/pitivi/ui"
 /usr/bin/install -c -m 644 '__init__.py' '/usr/local/lib/pitivi/python/pitivi/ui/__init__.py'
 /usr/bin/install -c -m 644 'complexlayer.py' '/usr/local/lib/pitivi/python/pitivi/ui/complexlayer.py'
 /usr/bin/install -c -m 644 'complexsource.py' '/usr/local/lib/pitivi/python/pitivi/ui/complexsource.py'
 /usr/bin/install -c -m 644 'complextimeline.py' '/usr/local/lib/pitivi/python/pitivi/ui/complextimeline.py'
 /usr/bin/install -c -m 644 'complexinterface.py' '/usr/local/lib/pitivi/python/pitivi/ui/complexinterface.py'
 /usr/bin/install -c -m 644 'exportsettingswidget.py' '/usr/local/lib/pitivi/python/pitivi/ui/exportsettingswidget.py'
 /usr/bin/install -c -m 644 'filelisterrordialog.py' '/usr/local/lib/pitivi/python/pitivi/ui/filelisterrordialog.py'
 /usr/bin/install -c -m 644 'glade.py' '/usr/local/lib/pitivi/python/pitivi/ui/glade.py'
 /usr/bin/install -c -m 644 'gstwidget.py' '/usr/local/lib/pitivi/python/pitivi/ui/gstwidget.py'
 /usr/bin/install -c -m 644 'mainwindow.py' '/usr/local/lib/pitivi/python/pitivi/ui/mainwindow.py'
 /usr/bin/install -c -m 644 'projectsettings.py' '/usr/local/lib/pitivi/python/pitivi/ui/projectsettings.py'
 /usr/bin/install -c -m 644 'sourcefactories.py' '/usr/local/lib/pitivi/python/pitivi/ui/sourcefactories.py'
 /usr/bin/install -c -m 644 'timeline.py' '/usr/local/lib/pitivi/python/pitivi/ui/timeline.py'
 /usr/bin/install -c -m 644 'timelineobjects.py' '/usr/local/lib/pitivi/python/pitivi/ui/timelineobjects.py'
 /usr/bin/install -c -m 644 'viewer.py' '/usr/local/lib/pitivi/python/pitivi/ui/viewer.py'
 /usr/bin/install -c -m 644 'ruler.py' '/usr/local/lib/pitivi/python/pitivi/ui/ruler.py'
 /usr/bin/install -c -m 644 'layerwidgets.py' '/usr/local/lib/pitivi/python/pitivi/ui/layerwidgets.py'
 /usr/bin/install -c -m 644 'tracklayer.py' '/usr/local/lib/pitivi/python/pitivi/ui/tracklayer.py'
 /usr/bin/install -c -m 644 'infolayer.py' '/usr/local/lib/pitivi/python/pitivi/ui/infolayer.py'
 /usr/bin/install -c -m 644 'plumber.py' '/usr/local/lib/pitivi/python/pitivi/ui/plumber.py'
../../py-compile[120]: python: not found
*** Error code 127

Stop in /home/aleopenbsd/pitivi-0.10.3/pitivi/ui (line 276 of Makefile).
*** Error code 1

Stop in /home/aleopenbsd/pitivi-0.10.3/pitivi/ui (line 366 of Makefile).
*** Error code 1

Stop in /home/aleopenbsd/pitivi-0.10.3/pitivi (line 342 of Makefile).
*** Error code 1

Stop in /home/aleopenbsd/pitivi-0.10.3/pitivi (line 497 of Makefile).
*** Error code 1

Stop in /home/aleopenbsd/pitivi-0.10.3 (line 356 of Makefile).
$ pkg_info -Q python
dbus-python-0.82.2p1 (installed)
python-2.5.2 (installed)
....
Attached Files
File Type: txt Makefile.txt (26.2 KB, 2 views)
File Type: txt Makefile_pitivi.txt (21.1 KB, 3 views)
File Type: txt Makefile_pitivi_ui.txt (16.1 KB, 2 views)

Last edited by aleunix; 16th June 2008 at 06:40 PM.
Reply With Quote
  #4   (View Single Post)  
Old 16th June 2008
cubo cubo is offline
Real Name: Luca
Port Guard
 
Join Date: May 2008
Location: Italy - Torino
Posts: 21
Thanked 0 Times in 1 Post
Default

Code:
$ cat /var/db/pkg/python-2.5.2/+DISPLAY
If you want to use this package as your default system python, as root
create symbolic links like so (overwriting any previous default):
 ln -sf /usr/local/bin/python2.5 /usr/local/bin/python
 ln -sf /usr/local/bin/pydoc2.5  /usr/local/bin/pydoc
Reply With Quote
  #5   (View Single Post)  
Old 16th June 2008
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

Thanks.

After i have installed:
py-gstreamer

Another problem when i tried to start the applications:

$ pitivi
Couldn't set locale !, reverting to C locale

I have a screen with this message:
gnonlin plugin not found

$ pkg_info | grep gstreamer
gstreamer-0.10.12p0 streaming media framework - core
gstreamer-plugins-base-0.10.12p0 multimedia framework - plugins base
py-gstreamer-0.10.9 Python bindings for gstreamer

Now i install gstreamer-plugins-good-0.10.5p2 and i have this error:
Make sure you have installed gst-plugins-good

Last edited by aleunix; 16th June 2008 at 07:13 PM.
Reply With Quote
  #6   (View Single Post)  
Old 17th June 2008
cubo cubo is offline
Real Name: Luca
Port Guard
 
Join Date: May 2008
Location: Italy - Torino
Posts: 21
Thanked 0 Times in 1 Post
Default

As it is written on the homepage of the project (http://www.pitivi.org/wiki/0.11.1) dependencies are:

Code:
Requirements:
    * gstreamer >= 0.10.14
    * gst-python >= 0.10.6
    * gnonlin >= 0.10.9
    * pygtk >= 2.8.0
    * zope-interface
    * python setuptools
gnonlin must be installed from source. Try google to find it.
Reply With Quote
  #7   (View Single Post)  
Old 17th June 2008
aleunix aleunix is offline
Real Name: Alessandro
Spam Deminer
 
Join Date: May 2008
Location: Italy
Posts: 224
Thanked 3 Times in 3 Posts
Default

I must compiling gstreamer and other packages.

Ok I will not continue the installation while i will try to erase what installed using sources.

Last edited by aleunix; 17th June 2008 at 01:56 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot problem. Geometry problem? gulanito FreeBSD Installation and Upgrading 0 3rd July 2009 03:03 AM


All times are GMT. The time now is 04:29 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick