DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD General

FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 19th June 2008
anomie's Avatar
anomie anomie is offline
Local
 
Join Date: Apr 2008
Location: Texas
Posts: 446
Thanked 69 Times in 46 Posts
Default portmaster: "Terminated" messages

I am seeing a problem with portmaster on one of my FreeBSD 6.3 workstations. Here's an example from an attempted upgrade of abiword-gnome:
Code:
# portmaster -u abiword-gnome
===>>> Gathering distinfo list for installed ports

===>>> Currently installed version: abiword-gnome-2.4.6_3
===>>> Port directory: /usr/ports/editors/abiword
===>>> Launching 'make checksum' for editors/abiword in background
===>>> Gathering dependency list for editors/abiword from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update unzip-5.52_3
        abiword-gnome-2.4.6_3 >> unzip-5.52_3

===>>> Port directory: /usr/ports/archivers/unzip
===>>> Launching 'make checksum' for archivers/unzip in background
===>>> Gathering dependency list for archivers/unzip from ports
===>>> No dependencies for archivers/unzip
===>>> Continuing 'make config' dependency check for editors/abiword
===>>> Launching child to update devel/goffice04
        abiword-gnome-2.4.6_3 >> devel/goffice04

===>>> Port directory: /usr/ports/devel/goffice04
===>>> Launching 'make checksum' for devel/goffice04 in background
===>>> Gathering dependency list for devel/goffice04 from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update gnome-vfs-2.20.1
        abiword-gnome-2.4.6_3 >> devel/goffice04 >> gnome-vfs-2.20.1

===>>> Port directory: /usr/ports/devel/gnome-vfs
===>>> Launching 'make checksum' for devel/gnome-vfs in background
===>>> Gathering dependency list for devel/gnome-vfs from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update avahi-app-0.6.22_1
        abiword-gnome-2.4.6_3 >> devel/goffice04 >> gnome-vfs-2.20.1 >> avahi-app-0.6.22_1

===>>> Port directory: /usr/ports/net/avahi-app
===>>> Launching 'make checksum' for net/avahi-app in background
===>>> Gathering dependency list for net/avahi-app from ports
===>>> Starting recursive 'make config' check
Terminated
Terminated

===>>> Update for gnome-vfs-2.20.1 failed
===>>> Aborting update

===>>> Update for /usr/ports/devel/goffice04 failed
===>>> Aborting update
[ Note that I ran make checksum & make config from /usr/ports/net/avahi-app manually; both worked fine. ]

The problem does not appear to be limited to abiword-gnome. I ran into a very similar issue when attempting to upgrade gettext a few days ago, and I had to install and use portupgrade just to get it upgraded properly.

Some facts about the problem:
  • I have two FreeBSD 6.3 workstations running the same portmaster version and with similar (but not identical) application environments. Only one of the workstations is having the problem.
  • The portmaster version I'm using is the latest available in ports now - v2.5.
  • My /etc/make.conf consists only of this:
    Code:
    PERL_VER=5.8.8
    PERL_VERSION=5.8.8
  • I am not using a portmaster.rc / .portmasterrc file and I am not setting any of the portmaster-related environment variables in root's shell environment.

My friend google pointed me to this (loosely related) email thread: http://lists.freebsd.org/pipermail/f...ch/047557.html. The most useful thing I gleaned from that was a script to test whether root's shell is allowing lots of children to spawn. (And, yes, it is. I ran the script and spawned > 100 children.)

Has anyone run into this with portmaster? Any ideas for troubleshooting further?
__________________
Kill your t.v.

Last edited by anomie; 19th June 2008 at 08:57 PM. Reason: included entire portmaster dialog.
Reply With Quote
  #2   (View Single Post)  
Old 20th June 2008
chill's Avatar
chill chill is offline
Fdisk Soldier
 
Join Date: Jun 2008
Location: Federal Republic of the US
Posts: 74
Thanked 6 Times in 6 Posts
Default

Hi anomie. You said you had the same problem with gettext. UPDATING recommended to rebuild all upward and downward dependencies for the latest version of gettext with portmaster because some library changed that it was dependent upon.

Did you try
portmaster -rf abiword-gnome
Reply With Quote
  #3   (View Single Post)  
Old 20th June 2008
Weaseal's Avatar
Weaseal Weaseal is offline
Package Pilot
 
Join Date: May 2008
Location: East Coast, US
Posts: 177
Thanked 7 Times in 7 Posts
Default

From /usr/ports/UPDATING:
Code:
# portmaster -r gettext\*
Did you give that a shot?
__________________
FreeBSD addict since 4.2-RELEASE.
My FreeBSD wiki.
Reply With Quote
  #4   (View Single Post)  
Old 20th June 2008
anomie's Avatar
anomie anomie is offline
Local
 
Join Date: Apr 2008
Location: Texas
Posts: 446
Thanked 69 Times in 46 Posts
Default

@chill: using the -rf option results in a similar problem -- it just breaks at a slightly different place.
Code:
...
...
===>>> Port directory: /usr/ports/textproc/libxml2
===>>> Launching 'make checksum' for textproc/libxml2 in background
===>>> Gathering dependency list for textproc/libxml2 from ports
Terminated
Terminated

===>>> Update for gnome-vfs-2.20.1 failed
===>>> Aborting update

===>>> Update for /usr/ports/devel/goffice04 failed
===>>> Aborting update
@Weaseal: Yes, I tried the advice in /usr/ports/UPDATING for gettext. (I should have mentioned it earlier.) Same "Terminated" messages.

Thanks for the replies. I think some aspect of my portmaster 'environment' has become broken.
__________________
Kill your t.v.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fixed "xinit" after _7 _8, "how" here in case anyones' "X" breaks... using "nvidia" jb_daefo Guides 0 5th October 2009 09:31 PM
"Thanks" and "Edit Tags". diw Feedback and Suggestions 2 29th March 2009 12:06 AM
Scripted sysinstall fails with "Command 'system' failed" PeterSteele FreeBSD Installation and Upgrading 0 13th November 2008 11:31 PM
Newbie-friendly "printing in OpenBSD" guide wanted Shagbag OpenBSD Packages and Ports 5 7th July 2008 09:26 PM


All times are GMT. The time now is 08:37 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick