View Single Post
  #3   (View Single Post)  
Old 15th August 2008
Carpetsmoker's Avatar
Carpetsmoker Carpetsmoker is offline
Real Name: Martin
Tcpdump Spy
 
Join Date: Apr 2008
Location: Netherlands
Posts: 2,241
Default

You don't need a patch, and /usr/local/etc/pkgtools.conf only works for portupgrade and family, several more portable solutions would be:

At the commandline you can just use:
# make CONFIGURE_ARGS=--disable-swscale

And you can of course put this in /etc/make.conf:
Code:
.if ${.CURDIR:M*/multimedia/ffmpeg}
CONFIGURE_ARGS=--disable-swscale
.endif
Or in /usr/ports/multimedia/ffmpeg/Makefile.local:
Code:
CONFIGURE_ARGS+=--disable-swscale
@corey_james, I think you have an old reversion of the port? The current revision (1.87) explicitly enables swscale in the CONFIGURE_ARGS...
In any case, using OPTIONS would be better anyway...
__________________
UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things.
Reply With Quote