View Single Post
  #1   (View Single Post)  
Old 9th May 2008
lil_elvis2000 lil_elvis2000 is offline
Port Guard
Join Date: May 2008
Location: The armpit of England
Posts: 21
Default SOLVED: Boot abort with gmirror problem

I'm new to FreeBSD. I chose it because from what I have read it is fast and solid. I wanted to build a RAID 1 file server for our office.
- I have managed after a couple of tries to get 7.0-RELEASE installed.
The system has
ad2s1b / approx 8G IDE
ad2s1c SWAP approx 1.5G
ad4s1e /home approx 300G SATA
ad6 approx 300G identical drive to SATA

I then followed instructions found on the internet
gmirror label -v -b round-robin gm0 /dev/ad4
gmirror load
gmirror insert gm0 /dev/ad6

I then altered the /boot/loader.conf
and /etc/fstab as instructed.

I checked the gmirror status which reported DEGRADED. I decided
at that point to reboot. I thought the syncing process would restart
after the reboot. I was soon to be mistaken.

Upon reboot BSD reported a error
Can't stat /dev/mirror/gm01sd : no such file or directory
and the boot aborted to be left to single user mode.

I did a gmirror status which reported nothing. So what have I done wrong?
it almost seems as if gmirror is not starting properly. I assumed the resync. would continue after boot..perhaps I was mistaken? I could not edit any files as it seems the file system was set to read-only. I don't know how to get around that.

So I :
gmirror unload
gmirror load
gmirror label -v -b round-robin gm0 /dev/ad4
gmirror insert gm0 /dev/ad6

I've let it resync. overnight as it was now 5pm. Find out in the morning if it works and if it will reboot.

So far I've spent two days getting FreeBSD to this point - I originally tried to create the mirror at install time like you can do with some Linux distros. That took a day for me to give up. Then when I did redid the install I forgot to mark a partition as boot (hello install team).

Any ideas what could be going wrong?

Last edited by lil_elvis2000; 9th May 2008 at 08:08 PM.
Reply With Quote