View Single Post
  #9   (View Single Post)  
Old 13th June 2008
gosha gosha is offline
Spam Deminer
Join Date: Jun 2008
Location: China
Posts: 256
Default still stuck

I think I've tried them all. But the situation does not change.
Now I can input chinese in mlterm but not in xterm or uxterm, although uim is started in .xinitrc. At the same time in mlterm still cannot input either russian or different characters (but I can display them, for example, if I go to a russian website with w3m it is displayed, but I cannot make a search using cyrillic).
I tried to install mlterm's termcap and terminfo from source. I've tried to make a similar line for ksh in .Xdefaults for mlterm. I've tried to put in ~/.mlterm/main this line: use_login_shell = true. I've tried to change fonts, or encodings.
Nothing works.
If I use xemacs from mlterm, it can input russian, but with the old keyboard layout, not with winkeys like I put in my xorg.conf, so I guess emacs is using its own input? As I said, the only application so far that behaves as expected is firefox where I can input chinese, cyrillic or accented characters all according to my settings.
It must be a misconfiguration of mine, but I already have no idea where to look for an aswer.
Any help will be greatly appreciated.
Reply With Quote