DaemonForums  

Go Back   DaemonForums > OpenBSD > OpenBSD Packages and Ports

OpenBSD Packages and Ports Installation and upgrading of packages and ports on OpenBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 3rd December 2022
talos4 talos4 is offline
Real Name: morty mcfly
Port Guard
 
Join Date: Sep 2022
Location: stuck on earth, in the timeline of Yesterday's Enterprise
Posts: 10
Default pkg_add fails b/c it can't find a dependency

Hi, all.

What does "minor is tool small" mean? And why doesn't pkg_add not notice the existing sqlite3 ?

Quote:

# pkg_add racket-minimal
pkg_add racket-minimal
quirks-6.42 signed on 2022-12-02T20:18:53Z
Can't install racket-minimal-8.6p4 because of libraries
|library sqlite3.37.20 not found
| /usr/local/lib/libsqlite3.so.37.15 (sqlite3-3.38.3): minor is too small
Direct dependencies for racket-minimal-8.4p0->8.6p4 resolve to ossp-uuid-1.6.2p6 lz4-1.9.4 libiconv-1.17 mpfr-4.1.0 libffi-3.4.2 sqlite3-3.38.3
Full dependency tree is mpfr-4.1.0 sqlite3-3.38.3 ossp-uuid-1.6.2p6 libiconv-1.17 libffi-3.4.2 lz4-1.9.4 gmp-6.2.1p0
Couldn't find updates for racket-minimal-8.4p0
Couldn't install racket-minimal-8.6p4

# sqlite3 --version
sqlite3 --version
3.38.3 2022-04-27 12:03:15 9547e2c38a1c6f751a77d4d796894dec4dc5d8f5d79b1cd39e 1ffc50df7b3be4

# uname -a
uname -a
OpenBSD myhost 7.2 GENERIC.MP#2 amd64
Sorry if I've failed to provide more info or posted this in the wrong forum. This is the very first time I'm requesting support somewhere regarding an OS.
Reply With Quote
  #2   (View Single Post)  
Old 3rd December 2022
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 7,838
Default

Quote:
Originally Posted by talos4 View Post
Hi, all.

What does "minor is tool small" mean? And why doesn't pkg_add not notice the existing sqlite3 ?
OpenBSD structures all libraries with a numbering system known as "major.minor". Minor updates are revisions to a library that can add functionality but do not otherwise disturb existing interfaces, while major updates do.

The version of racket-minimal you are trying to install was built with a higher revision of sqlite3 than you have installed. It requires version 37.20, and you have version 37.15 installed.

It looks to me like you are attempting to install a 7.2-release application package, *before* you have updated your previously installed packages to 7.2. Version 37.15 of sqlite3 was at 7.1-release. The 7.2 Upgrade Guide recommends updating your packages after you upgrade, where it said, "Finish up by upgrading the packages using pkg_add -u."
Quote:
Sorry if I've failed to provide more info or posted this in the wrong forum. This is the very first time I'm requesting support somewhere regarding an OS.
No need to apologize, and there was enough info here for me to figure out what probably happened.
Reply With Quote
  #3   (View Single Post)  
Old 4th December 2022
talos4 talos4 is offline
Real Name: morty mcfly
Port Guard
 
Join Date: Sep 2022
Location: stuck on earth, in the timeline of Yesterday's Enterprise
Posts: 10
Default

Thanks, jggimi!
Reply With Quote
  #4   (View Single Post)  
Old 4th December 2022
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 7,838
Default

You're welcome. For clarity:
  • These version numbers I mention are the library version numbers, not the package versions.
  • For minor library numbers, a newer library can be used with older applications -- e.g.: sqlite3 library 37.20 can be used with an application built with 37.15. But not the other way around. The programmatic interfaces used in 37.15 are still valid with 37.20. However, an application built with 37.20 might attempt to use something new, that is not available with 37.15.
Reply With Quote
Reply

Tags
dependencies, pkg_add

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cmake can't find a package dependency within Pkgsrc recipt darktrym NetBSD Package System (pkgsrc) 3 20th November 2016 09:09 PM
changing a dependency for a package .. daemonfowl OpenBSD Packages and Ports 7 4th September 2012 06:14 AM
dependency question. fender0107401 OpenBSD Packages and Ports 2 11th May 2010 11:05 PM
pkg_add g95;g95 x.f95: cannot find g95 enpey OpenBSD Packages and Ports 8 27th August 2008 12:48 AM
portupgrade -a =>Stale Dependency jaymax FreeBSD Ports and Packages 15 23rd July 2008 10:05 AM


All times are GMT. The time now is 01:41 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick