|
FreeBSD General Other questions regarding FreeBSD which do not fit in any of the categories below. |
|
Thread Tools | Display Modes |
|
|||
difference between rc.conf and loader.conf
What is the difference?
thx Last edited by disappearedng; 1st September 2008 at 05:46 AM. |
|
||||
Code:
LOADER.CONF(5) FreeBSD File Formats Manual LOADER.CONF(5) NAME loader.conf -- system bootstrap configuration information DESCRIPTION The file loader.conf contains descriptive information on bootstrapping the system. Through it you can specify the kernel to be booted, parame- ters to be passed to it, and additional modules to be loaded; and gener- ally set all variables described in loader(8). Code:
RC.CONF(5) FreeBSD File Formats Manual RC.CONF(5) NAME rc.conf -- system configuration information DESCRIPTION The file rc.conf contains descriptive information about the local host name, configuration details for any potential network interfaces and which services should be started up at system initial boot time. In new installations, the rc.conf file is generally initialized by the system installation utility, sysinstall(8). The purpose of rc.conf is not to run commands or perform system startup actions directly. Instead, it is included by the various generic startup scripts in /etc which conditionalize their internal actions according to the settings found there. The /etc/rc.conf file is included from the file /etc/defaults/rc.conf, which specifies the default settings for all the available options. Options need only be specified in /etc/rc.conf when the system adminis- trator wishes to override these defaults. The file /etc/rc.conf.local is used to override settings in /etc/rc.conf for historical reasons. See the rc_conf_files variable below. Code:
SYSCTL.CONF(5) FreeBSD File Formats Manual SYSCTL.CONF(5) NAME sysctl.conf -- kernel state defaults DESCRIPTION The /etc/sysctl.conf file is read in when the system goes into multi-user mode to set default settings for the kernel.
__________________
religions, worst damnation of mankind "If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”. vermaden's: links resources deviantart spreadbsd |
|
|||
Which also means, if I am not wrong:
loader.conf - this loads kernel modules rc.conf - this performs all other administrative tasks upon startup |
|
||||
/boot/loader.conf
-- load kernel modules -- tune kernel parameters that cant be set at runtime -- disable kernel built in modules (agp/acpi) /etc/rc.conf -- most important config file on FreeBSD -- set basic system setting like hostname and network -- enable/disable services -- load kernel modules using scripts (linux_enable="YES" loads linux.ko module) /etc/sysctl.conf -- tune kernel parameters that can be set at runtime -- tune various terminal settings like beep for example /etc/make.conf -- set CFLAGS/CPUTYPE and build options for Ports -- example: http://toya.net.pl/~vermaden/text/make.conf /etc/src.conf (from FreeBSD 7.x) -- set CFLAGS/CPUTYPE and build options for FreeBSD Base System and Kernel -- disable building various FreeBSD userland programs like sendmail or bind
__________________
religions, worst damnation of mankind "If 386BSD had been available when I started on Linux, Linux would probably never had happened." Linus Torvalds Linux is not UNIX! Face it! It is not an insult. It is fact: GNU is a recursive acronym for “GNU's Not UNIX”. vermaden's: links resources deviantart spreadbsd |
|
||||
To understand the various rc stuff in FreeBSD, you should read the rc manual page, it explains what is what in that regard.
During startup, you could basically say it works like something this in simple form: loader kernel init rc system getty / x based login manager login your users shell your start up files (depending on shell / x login / wm setup)
__________________
My Journal Thou shalt check the array bounds of all strings (indeed, all arrays), for surely where thou typest ``foo'' someone someday shall type ``supercalifragilisticexpialidocious''. |
Thread Tools | |
Display Modes | |
|
|
Similar Threads | ||||
Thread | Thread Starter | Forum | Replies | Last Post |
Xorg & i810 graphics / loader.conf / kldstat | OgreNaut | FreeBSD Installation and Upgrading | 26 | 7th November 2008 02:27 PM |
pf.conf | lumiwa | FreeBSD Security | 11 | 20th September 2008 01:01 AM |
make.conf | lumiwa | FreeBSD General | 9 | 8th September 2008 12:15 AM |
rc.conf questions | starbuck | FreeBSD General | 2 | 29th July 2008 06:16 PM |
httpd.conf | Snoop1990 | General software and network | 5 | 29th July 2008 04:30 AM |