Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Thread Tools Display Modes
  #1   (View Single Post)  
Old 2nd September 2008
bsdperson bsdperson is offline
Port Guard
Join Date: May 2008
Posts: 37
Default local dns (dnsmasq)

Behind my fw I cannot get dns to local machines to work. /etc/resolv.conf points to, locally I have dnsmasq running. /usr/local/etc/dnsmasq.conf contains lines like:


If I do arp -a I see the machine connected and it's mac. If I ping the ip it works, if I ping the name is sends the name query upstream returning an invalid ip.

I thought that since the machine gets an ip throught dhcp, the fw would also be able to resolve it.

Dnsmasq settings are:


What should I do?
Reply With Quote
  #2   (View Single Post)  
Old 2nd September 2008
robbak's Avatar
robbak robbak is offline
Real Name: Robert Backhaus
VPN Cryptographer
Join Date: May 2008
Location: North Queensland, Australia
Posts: 366

No idea: I don't use DNSmasq. Until you asked your question, I had no idea it existed. I have the same thing set up with isc-dhcpd and bind.

A few suggestions:
FreeBSD boxes do not send their domain names in dhcp by default (At least, not unless this has been changed recently.) To get them to do that, put this line in /etc/dhclient.conf
send host-name "yourhostname";
Many windows boxes use spaces and non-standard characters in their host names, which do not belong in the dns system. Use upper-case A-Z, 0-9 only. Many DNS systems will choke over names with non standard characters. Some won't - try and see - but start with standard letters.

Make sure you check the log files in /var/log/. The system may well be trying to tell you what is wrong.

That is all I can think of. If no one else here has dnsmasq experience, try posting to the dnsmasq mailing list with as much information as you can think of.
The only dumb question is a question not asked.
The only dumb answer is an answer not given.
Reply With Quote
  #3   (View Single Post)  
Old 2nd September 2008
ddekok ddekok is offline
Port Guard
Join Date: May 2008
Posts: 38

I haven't had much experience with dnsmasq, however, it appears that you are missing the address declarations.

The way I understand dnsmasq, it overrides specific values if they exist, otherwise it queries upstream. So, if you don't have the address declarations, it will query upstream.

Check out http://rhodesmill.org/brandon/2008/tomato-reverse-dns/ It covers setting up dnsmasq (on a linksys router running tomato firmware...) to specify local names for his computers. Hopefully that helps.
Reply With Quote
  #4   (View Single Post)  
Old 3rd September 2008
bsdperson bsdperson is offline
Port Guard
Join Date: May 2008
Posts: 37

Ok, so specifying lines like

is somehow different (wrt arp) from lines like

I'll try your suggestions and see how it goes. Thanks for all your help guys!

Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Local transfer is slow. maurobottone OpenBSD General 1 10th January 2009 02:12 PM
proxy : replace gif with local gif milo974 OpenBSD General 4 17th July 2008 06:45 AM
Attention A Nwe Local Root Exploit t4y4n OpenBSD General 6 2nd July 2008 01:23 AM
Send email to all local users cajunman4life FreeBSD General 8 15th June 2008 10:52 AM
/usr/local and application directories ducu_00 FreeBSD Ports and Packages 14 23rd May 2008 05:37 PM

All times are GMT. The time now is 10:46 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick