DaemonForums  

Go Back   DaemonForums > FreeBSD > FreeBSD Installation and Upgrading

FreeBSD Installation and Upgrading Installing and upgrading FreeBSD.

Reply
 
Thread Tools Display Modes
  #1   (View Single Post)  
Old 23rd October 2022
psarethi psarethi is offline
New User
 
Join Date: Oct 2022
Posts: 9
Default FreeBSD fails to install

FreeBSD fails to install, every time. In Qemu, I boot off the emulated usb stick, install to the emulated hard drive, using guided install (not zfs, the other option) and leaving as much as possible at default values. Installer claims to finish, claims that all is correct. When I boot the supposedly installed system, I get this (see attachment), every time.
Attached Images
File Type: png freebsd_fails_every_time.png (11.0 KB, 14 views)
Reply With Quote
  #2   (View Single Post)  
Old 24th October 2022
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,994
Default

You installed using an emulated usb stick to the qemu emulated hard drive. This probably changed the emulated hard drive number into ada1? Or it caused the /etc/fstab which is used to mount the partitions to refer to a wrong drive number (ada0)?.

You can boot using the emulated usb stick into the live CD and investigate which are the valid drives (in dmesg).

With # gpart show -p you can list the partitions.

Then mount the hard drive root partition and check the contents of /etc/fstab and correct the drive number.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote
  #3   (View Single Post)  
Old 25th October 2022
Trihex's Avatar
Trihex Trihex is offline
Real Name: Trihexagonal
Fdisk Soldier
 
Join Date: Jul 2017
Location: Land of the Dead
Posts: 79
Default

I've never used QEMU or a virtual machine.

However, there used to be a person at the FreeBSD forums that knew about Building A FreeBSD Desktop From Scratch on bare metal. I'd link to the Beginners Tutorial but they stole it.

You can still find it there. Just not me.
__________________
When Darkness takes everything embrace what Darkness brings.

https://trihexagonal.org/
Reply With Quote
  #4   (View Single Post)  
Old 31st October 2022
psarethi psarethi is offline
New User
 
Join Date: Oct 2022
Posts: 9
Default

Quote:
Originally Posted by J65nko View Post
You installed using an emulated usb stick to the qemu emulated hard drive. This probably changed the emulated hard drive number into ada1? Or it caused the /etc/fstab which is used to mount the partitions to refer to a wrong drive number (ada0)?.

You can boot using the emulated usb stick into the live CD and investigate which are the valid drives (in dmesg).

With # gpart show -p you can list the partitions.

Then mount the hard drive root partition and check the contents of /etc/fstab and correct the drive number.
That was it. I'd had to switch the disks around to get qemu to boot off the one, then switch them back to get it to boot off the other. Exactly as you said, once I'd ascertained the names of the partitions, all I had to do was mount the installed partition, edit one device name in the fstab. Now the installed partition boots.

Thank you very much.

p.s. and without having to do a chroot or an intramdisk rebuild. Yay!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD 7 fails to boot automatically after install .... I need to select my SSD from bsd007 OpenBSD Installation and Upgrading 15 26th January 2022 05:07 PM
pkgadd fails to install solaris packages in global and local zones as well. Padya Solaris 2 4th March 2013 12:54 PM
PC-BSD 1.5.1 fails to install archp2008 FreeBSD Installation and Upgrading 27 1st July 2008 11:47 PM
FreeBSD 7.0 amd64 make installworld fails. KernelPanic FreeBSD Installation and Upgrading 8 11th June 2008 04:34 PM
rum0 driver wireless fails after install jasites OpenBSD General 10 2nd June 2008 12:14 PM


All times are GMT. The time now is 04:22 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick