Go Back   DaemonForums > FreeBSD > FreeBSD Ports and Packages

FreeBSD Ports and Packages Installation and upgrading of ports and packages on FreeBSD.

Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1   (View Single Post)  
Old 21st December 2008
godfrank godfrank is offline
Port Guard
Join Date: Jun 2008
Posts: 14
Default PPTP Server, no internet connectivity (routing between interfaces?)

Hello folks!
I've been trying to setup a VPN server on my FreeBSD 7.0 box for a while now. As of today, I can login successfully to it from a Windows machine but I cannot get the Internet connectivity to work. FYI, I am using poptop for a "relatively secure" PPTP VPN that will be used mostly for my iPhone. My network's router is and the machine on which the PPTP server is running is

My theory is that I should do a bridge between the tun0 interface and my rl0 [CODE]interface but, being the networking neophyte that I am, I am not sure how to do so and if it really is what I need.

Here is a line I get when I log on to my VPN from a Windows machine:
ppp[83612]: tun0: Warning: ff02:3::/32: Change route failed: errno: Network is unreachable
Here are my rl0 and tun0 interfaces:
$ ifconfig rl0
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:50:fc:33:0d:5e
        inet netmask 0xffffff00 broadcast
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
$ ifconfig tun0
tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1398
        inet --> netmask 0xffffff00
        Opened by PID 83612
$ cat /usr/local/etc/pptpd.conf
speed 115200


pidfile /var/run/pptpd.pid
# cat /etc/ppp/ppp.conf
  set ifaddr
 set dns
  set nbns
 disable pap
 disable utmp
 disable passwdauth
 #enable chap     # MPPE Requirest chap81/MSChapV2
 enable MSChapV2
 enable mppe      # Enable Encrptions
 set log Phase Chat LCP IPCP CCP tun command  # Debugging
 set timeout 0   # Don't drop the connection
 # Force 128 bit encryption with a key change every packet
 # MacOSX only works with stateless connections and the are more
 # secure anyway - just less efficient.
 set mppe 128 stateless

 # Disable compression - freebsd clients try to use it but it breaks mppe
 disable deflate pred1
 deny deflate pred1
 set server /var/run/pptp_ppp_%d "" 0700
 accept dns              # Enable clients to request dns details
 disable ipv6cp          # Disable ipv6
 enable proxy            # Enable proxying addresses on the local net for clients

Thanks a lot!

Last edited by godfrank; 21st December 2008 at 03:47 PM.
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GRE throught OpenBSD 4.5 to 2K3 PPTP vpn There0 OpenBSD General 3 10th September 2009 12:54 PM
Problem with pptp gull OpenBSD General 2 21st January 2009 04:06 PM
PHP database interfaces TerryP Programming 6 11th September 2008 01:03 PM
Routing and routing some more! Weaseal FreeBSD General 1 19th August 2008 01:39 PM
OpenBSD and routing cchapman OpenBSD General 5 25th July 2008 05:55 PM

All times are GMT. The time now is 09:59 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Content copyright © 2007-2010, the authors
Daemon image copyright ©1988, Marshall Kirk McKusick